How to get DSi XL 1.4.2u to work for R4iSDHC (Red) or R4i?

Discussion in 'NDS - Flashcarts and Accessories' started by k3u, Nov 26, 2011.

  1. k3u
    OP

    Newcomer k3u Member

    Joined:
    Nov 26, 2011
    Messages:
    16
    Country:
    United States
    Hi, I'm new to these flash carts and my nephew updated his DSi XL to version 1.4.2u officially through Nintendo's server. Now both his card R4iSDHC and R4i won't work. I've tried updating the cards themselves to the latest firmware and it does nothing. Now I'm wondering if there's any fix for the cards? I've attached the pictures below to show what cards we have exactly. Thanks, any replies are appreciated.

    [​IMG] (www.r4isdhc.com)

    [​IMG] (www.r4i-sdhc.com)
     
  2. Buleste

    Member Buleste Old Fart

    Joined:
    Dec 19, 2010
    Messages:
    852
    Country:
    United Kingdom
    You've put two different pictures up. One for a www.r4isdhc.com cart and a www.r4i-sdhc.com cart so which one is it. If it is a www.r4isdhc.com cart is it that particular cart or one of the others by the same company as each different product requires a different download to patch the cart. Whichever cart it is you will need access to a DSl to be able to run the patch.
     
    1 person likes this.
  3. jimmyemunoz

    Member jimmyemunoz GBAtemp Advanced Maniac

    Joined:
    Feb 23, 2009
    Messages:
    1,958
    Location:
    Louisiana
    Country:
    United States
    Here is a link to the upgrade for the first card. Just pick your language from the list of downloads. It will support 1.4.3 but like Buleste said you need to run an update on a DS that the flash card works on. :D

    And here is a link to the upgrade for the second flash card. It will also support 1.4.3 but like Buleste said you need to run an update on a DS that the flash card works on. :D

    Good Luck! :D Oh yeah, once you update, put a parental security code for Nintendo firmware updates on your nephew's DS so this never happens again.
     
    1 person likes this.
  4. k3u
    OP

    Newcomer k3u Member

    Joined:
    Nov 26, 2011
    Messages:
    16
    Country:
    United States
    Hey guys, thanks for your speedy replies. I just need one of the two carts to work haha, I've tried going to both of the websites as jimmyemunoz posted and after copying the files and overwriting them into the microSD cards. But it doesn't work since his DSi XL is still on 1.4.2u version so are you guys saying I should update his DSi XL officially to 1.4.3u? (: Sorry I'm really new to this, my nephew is like bugging me to fix his cart for him.

    R4iSDHC (Red) : Gives me an error message.
    R4i : No cart inserted.

    P.S. The first link to the R4iSDHC (Red) update isn't working, perhaps the website is down?
     
  5. s4mid4re

    Member s4mid4re  

    Joined:
    Apr 2, 2011
    Messages:
    1,669
    Country:
    United States
    Nope, you have to get another system that the cart will run fine on. The dsi and 3ds have firmware updates that can block the use of flashcarts. In order to counter that, you have to update the bootstrap of your cart. In order to do so, you'll have to find a system that your cart is operable on. The ds phat and lite can't block flashcarts, so those are the preferred systems to update on. If you happen to have a dsi/3ds with a very low firmware that your carts can operate on, that'd be fine too.

    Once you find another system (either by borrowing or, worst case scenario, buying a new one), you can run the updater on the cart to make it compatible to the latest dsi/3ds firmware. Apparently, the www.r4i-sdhc.com one doesn't host their updater on their website; instead, you'll have to follow the procedures here (under "NDSi V1.4.3 firmware upgrade instruction") to update. For your other cart (www.r4isdhc.com), the host seems down, so you'll probably have to find it somewhere else...
     
    1 person likes this.
  6. k3u
    OP

    Newcomer k3u Member

    Joined:
    Nov 26, 2011
    Messages:
    16
    Country:
    United States
    Thank you for the very detailed post. However, with my luck. The website for (www.r4isdhc.com) is down, and the cart for (www.r4i-sdhc.com) still shows "No Cart Inserted" both in the DSi XL + my DS Lite.

    Overall :
    R4iSDHC (Red) works but there is no firmware download for it currently since the website is down.
    R4i : Doesn't work (No cart inserted) in both the DSi XL and my DS Lite however we have the latest firmware for it.

    EDIT : I found an alternative link for the R4iSDHC (Red) latest firmware. (: Alright I have it working on my DS Lite but still not working for the DSi XL. So, how do I update the bootstrap for the R4iSDHC (Red)? Since there's no "Update Button" like the direction you've posted. Also I believe the R4i (Black) is broken, seems to not work on any firmware regardless of which DS it is in (DSi XL / DS Lite) keeps showing "No cart is inserted". So lets forget about that R4 and lets just focus on the R4iSDHC (Red). (:
     
  7. s4mid4re

    Member s4mid4re  

    Joined:
    Apr 2, 2011
    Messages:
    1,669
    Country:
    United States
    I found the procedures here. I'm not so familiar with the method they have, but from what I read, you're supposed to place the updater on the root of your ms and boot up your flashcart. Once booted up, your flashcart will automatically start the update process. Most carts brick if you turn the system off while updating, so make sure the update process ends before you turning off your system.
     
  8. k3u
    OP

    Newcomer k3u Member

    Joined:
    Nov 26, 2011
    Messages:
    16
    Country:
    United States
    Alright thank you a bunch, let me try it. (:

    EDIT : Another problem, of all the kernels available to download there, mine doesn't work. It doesn't re-direct me into the correct page to download the 1.4 kernel but instead just sends me to another tab of the same page. Sigh. :/
     
  9. s4mid4re

    Member s4mid4re  

    Joined:
    Apr 2, 2011
    Messages:
    1,669
    Country:
    United States
    I'm not sure if I'm getting what you mean (the EDIT). Can you elaborate a little bit on what you are trying to download and for which cart? (it'd be easier for me if you can provide the direct link for the file you want, as well as the website for it)
     
  10. k3u
    OP

    Newcomer k3u Member

    Joined:
    Nov 26, 2011
    Messages:
    16
    Country:
    United States
    Oh sorry. I'm using this link provided by you : http://www.r4isdhc.c...firmware-steps/ and I went to the page

    Step one: Copy the corresponding V1.42 upgrade firmwares to Micro sd card
    Step two: Insert the R4 card with firmware into the console which is lower than the V1.42 version, then turn it on to enter the R4 upgrade interface:
    a> The display of “loading” interface shows the R4 card upgrade is in process, please don’t cut off the power or take out the card
    b> The prompt“V1.42 upgrade completed” will be shown on the lower left corner after the R4 card upgrade is done. Now you are allowed to cut off the power and take out the card. It takes about 10 seconds to finish the upgrade
    c> Download the latest kernel to the successfully upgraded card, and use the card on the V1.42 NDSI to confirm it’s a successful upgrade

    On step "C" I went to the link provided and it sent me to page of all R4 kernels and the one I need (R4iSDHC Red V2.0 [Bottom Left Corner]) doesn't have a download link despite having a download button. :/
     
  11. s4mid4re

    Member s4mid4re  

    Joined:
    Apr 2, 2011
    Messages:
    1,669
    Country:
    United States
    I don't think step c is a necessity if you updated successfully. Test if your cart works on your dsi and report back.
     
  12. k3u
    OP

    Newcomer k3u Member

    Joined:
    Nov 26, 2011
    Messages:
    16
    Country:
    United States
    How do I get the V1.42 Kernel stated in the instructions? I still have the R4iEnglishV2.0.14B loaded on the cart which works only on the DS Lite and not the DSi XL.
     
  13. s4mid4re

    Member s4mid4re  

    Joined:
    Apr 2, 2011
    Messages:
    1,669
    Country:
    United States
    I believe the v1.42 refers to a dsi with firmware v1.42, not a firmware for the flashcart.
     
  14. k3u
    OP

    Newcomer k3u Member

    Joined:
    Nov 26, 2011
    Messages:
    16
    Country:
    United States
    Okay so I put the R4iEnglishV2.0.14B (Latest firmware for cart) into the cart and like I said it works only on the DS Lite. Am I missing something? There was no "Loading" or "Updating". :/ I'm sorry if I'm missing something. ._.

    Here are the pictures in case if it points to any clues or anything I'm doing wrong. o.o

    DS Lite :
    [​IMG]
    [​IMG]
    [​IMG]

    DSi XL :

    [​IMG]
    [​IMG]
     
  15. s4mid4re

    Member s4mid4re  

    Joined:
    Apr 2, 2011
    Messages:
    1,669
    Country:
    United States
    As the updater provided on the official website was down, and you got it off some other source, I can't see how the update goes. Does the updater have an extension of .nds?
     
  16. k3u
    OP

    Newcomer k3u Member

    Joined:
    Nov 26, 2011
    Messages:
    16
    Country:
    United States
    I'm not sure. It was a kernel downloaded not an update, unless those are the same haha.

    Here's the URL for the download
    R4iEnglishV2.0.14B : http://www.mediafire...33ciab65ztga9c3

    This is website where I got it from : http://www.r4ibuy.com/new-r4i-sdhc-happy-box-v2-0-for-nintendo-ds-dslite-dsi-dsixl-3ds/
     
  17. s4mid4re

    Member s4mid4re  

    Joined:
    Apr 2, 2011
    Messages:
    1,669
    Country:
    United States
    That's the kernel/system files for the flashcart you need; the file you need is the bootstrap updater. Since every file hosted in the official site seems down, there's no way to get files, unless you can find another source hosting the bootstrap update. I'm sorry but this is as far as I can go, since I can't find the required file. /:
     
  18. k3u
    OP

    Newcomer k3u Member

    Joined:
    Nov 26, 2011
    Messages:
    16
    Country:
    United States
    It's alright, thank you a bunch for posting so much information helping me out though. (: But as a heads up, can you give me further instructions on how to "update the Bootstrap" when the site is back up?
     
  19. s4mid4re

    Member s4mid4re  

    Joined:
    Apr 2, 2011
    Messages:
    1,669
    Country:
    United States
    Do as the instructions told you, and you should be fine. If the updater is a .nds file, place it onto the root and run it just like any other game; the update process will start when the updater is booted.
     
  20. k3u
    OP

    Newcomer k3u Member

    Joined:
    Nov 26, 2011
    Messages:
    16
    Country:
    United States
    Alright thank you!
     

Share This Page