[How-To]Get 11.4 Emunand working on Gateway with online access!

Discussion in '3DS - Tutorials' started by telon22, May 31, 2017.

  1. telon22
    OP

    telon22 GBAtemp Regular

    Member
    282
    69
    Jun 28, 2014
    India
    Important:-
    - This is meant to be used only on EMUNAND. Don't try this on sysnand and you will or might brick!
    - Before starting any of this make sure to make backup of your emunand. You were warned!
    - And to clarify this isn't actually frakenfirmware. You are just "selectively updating" 3ds via official updates and by not installing 2-3 titles that are not compatible with Gateway you can boot the firmware and even go online. You can actually just do a system update from setting in case you want to update your firmware fully.
    -Luma 8.0 users check this for now https://gbatemp.net/threads/luma-8-0-wont-load-my-emunand.473263/#post-7373368

    -Read FAQ for other questions.


    Most of us, including me were stuck on 11.2 emunand for Gateway cheats. In return we couldn't play online as system wont go online unless updated, like you all have seen that error on friend list that asks you to update. Anyways here is the method to almost completely update to 11.4 with online access and it is "working as of now".

    I own a US N3DS and this tut makes use of system titles compatible with this model only. While many titles might be similar others might not be so just find the alternate titles for your region/model.
    Again if you don't do this you may brick!

    Here(o3ds) https://yls8.mtheall.com/ninupdates/reports.php?date=02-06-17_07-00-38&sys=ctr
    +
    https://yls8.mtheall.com/ninupdates/reports.php?date=04-10-17_08-00-38&sys=ctr


    (n3ds) https://yls8.mtheall.com/ninupdates/reports.php?date=02-06-17_07-00-47&sys=ktr
    +
    Here https://yls8.mtheall.com/ninupdates/reports.php?date=04-10-17_08-00-47&sys=ktr

    And some Reference from https://3dbrew.org/wiki/Title_list

    There wasn't much to do tbh as most of the updated titles for 11.4 were already compatible with gateway.
    These were the titles that were updated from 11.2-11.4 in case of US N3DS.

    0004001000021900,USA,v23552,11.3.0-36
    0004003000008F02,USA,v27648,11.3.0-36
    000400300000CE02,USA,v18432,11.3.0-36
    0004001000021500,USA,v4096,11.4.0-37
    000400300000CC02,USA,v3072,11.4.0-37
    000400DB00017302,USA,v11328,11.4.0-37
    0004013000002902,USA,v14336,11.4.0-37
    0004013000003202,USA,v15360,11.4.0-37
    0004013000008002,USA,v22528,11.4.0-37
    0004003020009402,USA,v9232,11.4.0-37
    000400DB20016302,USA,v592,11.4.0-37


    EUR O3DS/N3DS title list https://gbatemp.net/threads/how-to-...with-online-access.472624/page-3#post-7365492

    Don't download/install below three as these will brick emunand.
    [N3DS only]0004013820000002,USA,v28512,11.4.0-37 (Native_Firm) -- Will Brick gateway emunand
    [N3DS only]0004013020001C02,USA,v13312,11.3.0-36 (GSP_Services)-- Will Brick gateway emunand
    [O3DS only]0004013000001C02,USA,v13312,11.3.0-36 (GSP_Services)-- Will Brick gateway emunand
    [O3DS only]0004013800000002,USA,v28512,11.4.0-37 (Native_Firm) -- Will Brick gateway emunand
    0004013000002D02,USA,v11264,11.4.0-37 (NWM_Services) -- Latest version will Brick gateway emunand


    EDIT- It seems you can skip steps 4-6, if you get online access with just first 3 steps!
    However in any rare case you are getting lag on wifi manger do complete steps.

    Steps-
    1- Backup your emunand.
    2- Download the titles marked with green with 3DNUS or any similar piece of software. These are the latest titles anyways.
    3- Use sysupdater and put all the green marked titles in updates folder. Update and restart.

    4 You need just one more title 0004013000002D02, but you wont be installing the latest version as mentioned above. For this first download v9216(from 8.0.0 update) with 3dsnus mark it as old and v10240(from 9.0.0) update and mark this as new.
    5-Spoof the v10240 version with hxd to v11264 which is the current one.

    How to spoof the cia version?
    Manual Way/Offline:
    (This is from my old thread tut)
    In this case I am taking example of 0004001000021000.cia[US].
    http://yls8.mtheall.com/ninupdates/titlelist.php?sys=ctr&wiki=1 shows that we have v8203 from 9.0 update and we need to spoof it to atleast v9221(or more if you wish) which was in 9.6 update.
    Open hxd and look for offset 00002F90 and then 0C-0D have your version no in hexadecimal. convert it decimal with this. In our case it is 20 0B with means 8203 in decimal and now again use decimal to hex to convert v9221 to hex which is 24 05 in hex. Now just overwrite 20 0B with 24 05 and save.
    This completes the spoofing of version.
    Alternate Way- If the title can be downloaded via 3dnus you can use the option "change version number to" before downloading that title and it will automatically spoof the version no to what you want to set.

    6- Then open FBI and install the title 0004013000002D02 marked as old(v9216). Reboot and then install the new marked one(which should be now spoofed to show as v11264).
    7-Restart and check Friend List, you should have online access unless you were ninty banned xD.
    8- Donot attempt to system update from settings because it will install the remaining 2 non-compatible titles and you will be left with a bricked emunand. After gateway supports 11.2+ firmware you can update the system.


    FAQ
    Q:What does 0004013000002D02 do? Why are we using a super old version of it, not even the version from 11.2?
    A:It wont allow you to directly install the spoofed version of 11.2. So you first downgrade it with old one and in the same run just install the spoofed 11.2 one.

    Q:What do I use to download update files?
    A: https://gbatemp.net/threads/3dnus.376488/. Use 1.9 for n3ds and 1.8 for o3ds. There is a new updated version too but I used this.

    Q:Why don't we spoof the other 2 titles too?
    A: Because I tried that many times and gateway always bricks the emunand no matter. Plus I found you actually don't need to spoof them as online still worked.

    Q: Ughh.. I dont know which files I need to download for my region/model?
    A: From the links given, gather the title list that need updating, and just remove the 3 titles you shouldn't install as stated, they are same for all. Rest follow the guide.

    Q:Will sysupdater brick me on gateway doing this. I read a warning?
    A: Only if you don't follow this guide exactly . This is what backups are for and make sure to create one so you can always restart. This has to be done on GATEWAY-EMUNAND mode only! If you are paranoid install the titles via FBI and you can achieve the same results.

    Q: Will this Game/DLC work now that we have 11.4 emunand set up?
    A: The emunand is good to go, but gateway might/will block certain dlc like FE: shadow's one. They install just fine in cfw mode on the same emunand, Gateway needs to fix their launcher!
     
    Last edited by telon22, Jun 6, 2017
    rocknard, earny, Oleboy555 and 6 others like this.
  2. THYPLEX

    THYPLEX GBAtemp Fan

    Member
    371
    64
    May 20, 2017
    Italy
    Rome
    In short , it's a Franken firmware , correct ?
     
    retrofan_k likes this.
  3. telon22
    OP

    telon22 GBAtemp Regular

    Member
    282
    69
    Jun 28, 2014
    India
    You may say so but at the very least its incomplete not corrupt and you should have no issues on it/
     
  4. THYPLEX

    THYPLEX GBAtemp Fan

    Member
    371
    64
    May 20, 2017
    Italy
    Rome
    And how can i suppose to remove this Franken firmware?
    By cartdrige update ?
     
  5. telon22
    OP

    telon22 GBAtemp Regular

    Member
    282
    69
    Jun 28, 2014
    India
    No its not like that. You can just update from system settings whenever you want to update
    Edit- You seemed to be confused so I added some information regarding this :grog:
     
    Last edited by telon22, May 31, 2017
    chrisluna413 likes this.
  6. Tomy Sakazaki

    Tomy Sakazaki GBAtemp Advanced Fan

    Member
    787
    215
    Oct 23, 2006
    Brazil
    There isn't any way to downgrade only the necessary titles on an already updated 11.4 emunand? I'm actually already updated in 11.4 with a sysnand only setup and wanted to ressurect the cheat engine of gateway if it's possible.
     
  7. telon22
    OP

    telon22 GBAtemp Regular

    Member
    282
    69
    Jun 28, 2014
    India
    Technically to downgrade you just need to downgrade the titles that were updated from 11.2-11.4. While I warn you against the dangers on doing this on sysnand plus gateway+sysnand setup, if you still want to experiment there are actually two ways:
    - While on a cfw first you can use 11.2 update pack (from chaos site) and with sysupdater you can downgrade.
    -2nd way is to just downgrade certain titles (like in my tutorial) you would actually need to just downgrade 2-3 titles and with this kind of 11.4 emunand gateway should work.

    You can use fbi and it should work or try uninstalling the titles first and them install them in same run.
     
    Last edited by telon22, May 31, 2017
  8. Tomy Sakazaki

    Tomy Sakazaki GBAtemp Advanced Fan

    Member
    787
    215
    Oct 23, 2006
    Brazil
    Well, I'm actually kind sane and will do the experiments using emunand :P I only didn't know if apps like sysUpdater still worked well with the newer firmware versions, with CFW loaded and running.
     
  9. THYPLEX

    THYPLEX GBAtemp Fan

    Member
    371
    64
    May 20, 2017
    Italy
    Rome
    And so said , i'm not risking a brick by doing Just a normal update with a 3ds with partial update firmware ?
    And why ?

    — Posts automatically merged - Please don't double post! —

    So i'm not risking anything ?
    Well , glad to read so.
     
    Last edited by THYPLEX, May 31, 2017
  10. ultimatetemper

    ultimatetemper GBAtemp Fan

    Member
    312
    53
    Dec 30, 2010
    Which are the files for an EUR O3DS?
     
  11. telon22
    OP

    telon22 GBAtemp Regular

    Member
    282
    69
    Jun 28, 2014
    India
    While I saw few titles are different but the one you shouldn't install are same. So spoof the 0004013000002D02 and dont install the remaining 2 as mentioned. Rest install others.
    https://yls8.mtheall.com/ninupdates/titlelist.php?date=02-06-17_07-00-38&sys=ctr&reg=P&csv=1
    https://yls8.mtheall.com/ninupdates/titlelist.php?date=04-10-17_08-00-38&sys=ctr&reg=P&csv=1
    I also urge you to backup first so you can easily redo if you mess up.
     
  12. DarkCrudus

    DarkCrudus The Ghost

    Member
    1,028
    44
    Apr 15, 2007
    United States
    Minnesota
    I cant seem to get any of these nus downloaders to work to get these files.. :/
     
  13. telon22
    OP

    telon22 GBAtemp Regular

    Member
    282
    69
    Jun 28, 2014
    India
    I used 3DNUS v1.9, which was already present in my archive. I tried that and it worked, so at the very least it should work for you too.
    Other than that make sure you put the exact title in the left bar(long one) and on the right side one put the version no without v for eg v9912 should be written as 9912 only
     
    Last edited by telon22, Jun 1, 2017
  14. BD2

    BD2 Member

    Newcomer
    25
    0
    Oct 12, 2009
    Italy
    with this method the dlc that requires 11.3 at least will install and work?(fe echoes e.g)
     
  15. telon22
    OP

    telon22 GBAtemp Regular

    Member
    282
    69
    Jun 28, 2014
    India
    While I haven't tried this, since i don't play this game but I don't see amy reason why it wont. All games and dlc should be compatible, plus if you can make this work you wont be losing anything either...
     
  16. BD2

    BD2 Member

    Newcomer
    25
    0
    Oct 12, 2009
    Italy
    thanks a lot for the help^^
     
    Last edited by BD2, Jun 1, 2017
  17. DarkCrudus

    DarkCrudus The Ghost

    Member
    1,028
    44
    Apr 15, 2007
    United States
    Minnesota
    I had grabbed 3dnus1.9. I was unable to select old/new 3ds, it was just greyed out. I would guess that would be an issue
     
  18. telon22
    OP

    telon22 GBAtemp Regular

    Member
    282
    69
    Jun 28, 2014
    India
    ok I would say if you have new3ds then continue with 1.9 but if you have o3ds then use 1.8 as 1.8 is o3ds only.
    https://gbatemp.net/threads/3dnus.376488/
     
  19. parrotgeek1

    parrotgeek1 Advanced Member

    Newcomer
    68
    31
    Dec 2, 2012
    United States
    What does 0004013000002D02 do? Why are we using a super old version of it, not even the version from 11.2?
     
  20. telon22
    OP

    telon22 GBAtemp Regular

    Member
    282
    69
    Jun 28, 2014
    India
    It wont allow you to directly install the spoofed version of 11.2. So you first downgrade it with old one and in the same run just install the spoofed 11.2 one.