HOW TO: Fix R4 Upgrade freezing on Create Save File

Discussion in 'R4 DS' started by armadadrive, Sep 13, 2018.

  1. armadadrive
    OP

    armadadrive Newbie

    Newcomer
    1
    Sep 13, 2018
    Canada
    I just picked up an R4 SDHC card from nds-card after seeing positive mentions here. I joined the community to post this fix because I could NOT find anything to help me and I stumbled across the solution myself. If this is a known thing, go ahead and delete the post but as I said, I never saw this suggestion in all my searching.

    The issue: my R4 card for my DS Lite was freezing when creating new save game files.

    The story: I had a couple of ROMs that worked, but I grabbed some more backups (I paid a lot for these Mario games second hand and my 4 year old does not care about that) in different places and some worked, some didn't. All worked in a DS emulator in Windows, though, so I knew the ROM dumps were good. I had checked the contents of the microSD card after a few games froze from the R4 launcher (remember, some worked so I didn't suspect it was the card nor the R4 clone) -- as some people noted, some games were having UPPERCASE SAV files created which didn't match with the lowercase ROM name. But changing these names didn't help... the ROMs from one particular source still froze while others worked.

    I mounted the microSD card with an adapter and went to work in Linux to play again with the filenames and after running ls -l, I noticed something: the file permissions on the freezing ROMs were different than the permissions on the working ROMs.

    The fix: I ran `sudo chmod 677 *` from the Linux bash terminal in the game directory to update the ROM file permissions. Now, everything works! Seems like the R4 firmware was unable to create .sav files because of a file permissions issue in this ROM set.

    Unfortunately, Windows machines don't treat files in quite the same manner so there is no chmod command. I've found a tool in the Windows command line called icacls.exe that does similar permissions stuff, but I can't verify it works. What I can say is that the Unix/Linux chmod permissions (specifically set to 677) worked for me. I ran Bash for Windows after installing the Windows Subsystem for Linux and I believe this tool should be present in MacOS as well. You may also be able to modify the files with Cygwin if you don't want to (or feel comfortable) installing the full Windows Subsystem for Linux.
     
  2. Technicmaster0

    Technicmaster0 GBAtemp Psycho!

    Member
    9
    Oct 22, 2011
    Gambia, The
    May be a problem with the SD aswell
     
Loading...