How to fix a broken system menu

BedtimeGuy

Well-Known Member
OP
Member
Joined
Jul 29, 2009
Messages
462
Trophies
0
Age
27
Location
EVERYWHERE
Website
Visit site
XP
222
Country
Canada
I was theming the system menu and have sort of soft bricked. CBHC works fine, so I can get in to the HBL... but the system menu won't load. It gets stuck on the splash screen playing the boot sound.

However, if I launch SDCafiine with a theme in the folder, the menu runs fine.

To clarify what stupid thing I did to get here... I changed from the dark orange theme from this thread to another, but some buttons remained orange. After trying a few other themes with similar results, I foolishly tried booting the WiiU after deleting the Acs2.pack and Set2.pack files in the theme folder, which seemed to do nothing. Undeterred, I then tried booting without a Men2.pack, which caused it to fail to load. I have since put all the files back exactly as they were, even checked that they're the same, but the menu won't load!

Any help would be greatly appreciated, I put way too much time in to this WiiU
 
Last edited by BedtimeGuy,

GaryOderNichts

Well-Known Member
Member
Joined
Aug 9, 2018
Messages
564
Trophies
1
XP
3,316
Country
Germany
First of all DO NOT UNINSTALL CBHC! This will fully brick your console.
The issue is that the file modes are messed up after deleting the files.
You can now either use wupserver and wupclient to manually set the modes on the file, or use this FTPiiU everywhere mod: https://github.com/Laf111/WiiUFtpServer/releases.
This mod will set the modes of uploaded files to 0x666, which grants the system menu (and every other app) full access to the file.
 

MikaDubbz

Well-Known Member
Member
Joined
Dec 12, 2017
Messages
2,773
Trophies
1
Age
34
XP
4,924
Country
United States
You're gonna be really mad to find out that the solution to your problem of some of the features staying the same as your previous theme was simply to transfer the files again.

I can not explain it, but FTPiiU doesn't always take, like even if the system menu reflects the change you made in FTP, it can (but not always) revert to the previous file if you then enter another app and return to the system menu; in your case, it sounds like one of the two files of the second theme properly transferred and stuck, but the other one decided not to stick. Best solution to this odd quirk of FTP on the Wii U, is after you make the file transfer in FTP, return to the menu, check if the desired changes are there, if not, try again, if they are, turn off the Wii U without entering any other apps and then turn it on, this has always ensured permanent system menu changes I've made, from the theme to the wara wara plaza to various game icons and banners that I wanted to look different from their default.
 
  • Like
Reactions: BedtimeGuy

BedtimeGuy

Well-Known Member
OP
Member
Joined
Jul 29, 2009
Messages
462
Trophies
0
Age
27
Location
EVERYWHERE
Website
Visit site
XP
222
Country
Canada
You're gonna be really mad to find out that the solution to your problem of some of the features staying the same as your previous theme was simply to transfer the files again.

I can not explain it, but FTPiiU doesn't always take, like even if the system menu reflects the change you made in FTP, it can (but not always) revert to the previous file if you then enter another app and return to the system menu; in your case, it sounds like one of the two files of the second theme properly transferred and stuck, but the other one decided not to stick. Best solution to this odd quirk of FTP on the Wii U, is after you make the file transfer in FTP, return to the menu, check if the desired changes are there, if not, try again, if they are, turn off the Wii U without entering any other apps and then turn it on, this has always ensured permanent system menu changes I've made, from the theme to the wara wara plaza to various game icons and banners that I wanted to look different from their default.
I did run in to that behaviour a lot when customizing my wara wara plaza (also following on of your posts, thanks!)

Anyway, I eventually got this fixed! That mod of FTPiiU is really nice, has a lot of cool features. It actually took 3 attempts of uploading the previous working theme files to get it working... then excited that it works, I tried changing the theme. Of course that broke it again :glare: tried over 10 more times before it worked again.

It may have just been random chance that those two attempts worked out, but I think the key may be that I did the upload, then in my FTP client (filezilla) I manually set the permissions for the files to 666. WiiU FTP Server actually showed the CHMOD commands so... I guess that worked? I also made sure to turn off the WiiU from the FTP screen.
 
General chit-chat
Help Users
    AliceCE @ AliceCE: all colors kick off, and everything is rendered in black and white