How to CFW 2DS with 8.1.0-19U, still confused.

Discussion in '3DS - Flashcards & Custom Firmwares' started by ochentay4, May 30, 2016.

  1. ochentay4
    OP

    ochentay4 Advanced Member

    Newcomer
    50
    2
    Jun 23, 2015
    Argentina
    Hi, I have a 2DS with 8.1.0-19U and currently do not have (and will not for the moment) Cubic Ninja/Sky3DS/Gateway. I want to run homebrews, CIAs, everything, but keeping it simple. Im understood that Luma3DS is one of the best (if not the best CFW).

    I currently do not understand if I can hack the 2DS with 8.1.0-19U firmware or I have to update to 9.2 and then start to hack it. I also read many guides but some are outdated and most ask for Cubic Ninja, which I think we no longer need it.

    Could someone point me in the right direction?

    Thanks!
     
  2. x_master_1234

    x_master_1234 GBAtemp Regular

    Member
    155
    31
    Feb 29, 2016
    United States
    ochentay4 likes this.
  3. ochentay4
    OP

    ochentay4 Advanced Member

    Newcomer
    50
    2
    Jun 23, 2015
    Argentina
  4. ochentay4
    OP

    ochentay4 Advanced Member

    Newcomer
    50
    2
    Jun 23, 2015
    Argentina
    After suffering for 50mins, I managed to update my 2DS to 9.2.0-20U, now what?
     
  5. Temarile

    Temarile (ノ◕ヮ◕)ノ*:・゚✧ A9LH ✧゚・: *ヽ(◕ヮ◕ヽ)

    Member
    1,132
    422
    Jan 7, 2016
    Netherlands
    ochentay4 likes this.
  6. ochentay4
    OP

    ochentay4 Advanced Member

    Newcomer
    50
    2
    Jun 23, 2015
    Argentina
  7. MelonGx

    MelonGx GBAtemp Advanced Maniac

    Member
    1,634
    439
    Jan 8, 2009
    China
    Do you use rxTools 2.5.2 the guide mentioned for the upgrading?
     
  8. ochentay4
    OP

    ochentay4 Advanced Member

    Newcomer
    50
    2
    Jun 23, 2015
    Argentina
    Well, I got to do everything I needed till tha
    Yes I did, why?
     
  9. MelonGx

    MelonGx GBAtemp Advanced Maniac

    Member
    1,634
    439
    Jan 8, 2009
    China
    Just want to confirm that if rxTools 2.5.2 Devmode works on 8.X or not.
    There are reports that rxTools 2.5.2 Devmode cannot boot 5.X and 7.X.
     
  10. ochentay4
    OP

    ochentay4 Advanced Member

    Newcomer
    50
    2
    Jun 23, 2015
    Argentina
    I just followed the entire guide. It took me days. I thought that all this process could be simple but it wasnt. Many oportunities to screw up, and thanks god I didnt. I finished with a clean and hacked 2DS and an uncluttered SD card. Now what? How to install CIA games from internet? Using FBI? How to update all tools that were provided? Only replacing the folder/files? Is it safe to update firmware using internet check? So many questions!!

    Just in case, I made a complete backup of the final SD content.
     
  11. ochentay4
    OP

    ochentay4 Advanced Member

    Newcomer
    50
    2
    Jun 23, 2015
    Argentina
    Also, more questions:

    1. In menu screen I still have sysupdater, I think its not safe to have it. Do I need it? If not, how to delete?
    2. In Data Management on 3DS content I see the following programs installed: TinyFormat with a X (I dont see it in main menu) and sysUpdater, can I delete the from here?

    I still dont really understand what I really did on the tutorial, could someone enlighten me?
     
  12. Temptress Cerise

    Temptress Cerise Miss Magic~ <3

    Member
    2,201
    1,469
    May 1, 2016
    United States
    You either dump your own games and convert them to .cia, or you find them on other sites, like that iso site, I guess. You install them with FBI. To update the tools(Decrypt9//Hourglass9,EmuNAND9,Uncart), well currently, you'd have to do it manually for those, so'd you'd just have to recheck the github release pages for each of those on your own.

    FBI, is now able to update itself, though not sure it can do this if it's injected. Just install the FBI.cia version, and keep the H&S injected one as backup.

    The LumaUpdater used in the guide can update your Luma3DS, but it can't update itself, so if a new version is released, you'll need to download it again. StarUpdater, which is another Luma3DS updater, can update itself, you could switch to that if that makes you feel better.
    Link: http://gbatemp.net/threads/release-starupdater-a-luma3ds-updater.427999/


    It's safe to update your firmware using the internet. If you're worried though, you could always let others update, and wait for the initial reports of people reporting whether it went smoothly or not.

    You can either use Data Management or FBI to uninstall sysUpdater. For TinyFormat, yeah, it's safe to remove that from within Data Management.

    As for what you did, I don't think I can explain that well.
     
    ochentay4 likes this.
  13. ochentay4
    OP

    ochentay4 Advanced Member

    Newcomer
    50
    2
    Jun 23, 2015
    Argentina
    Wow, thanks for the rapid and terrific answer! Thanks!!!!
     
  14. Clector

    Clector GBAtemp Advanced Fan

    Member
    970
    234
    Mar 15, 2016
    Bangladesh
    Not here
    I can ensure that 8.1.0-19 can use DevMode/PastaMode from RxTools 2.5.2.
     
    Last edited by Clector, May 31, 2016
    MelonGx likes this.
  15. MelonGx

    MelonGx GBAtemp Advanced Maniac

    Member
    1,634
    439
    Jan 8, 2009
    China
    PastaMode is rxTools 3.X, which use CakeHax to web-boot, is completely another story from rxTools 2.X (which use Roxas75 original engine to web-boot).
    CakeHax cannot web-boot -2 to -6 frankenfirmwares, but rxTools 2.X web-boot can. That's the reason Plailect's Guide doesn't pickup rxTools 3.X but picks up 2.5.2.
    However, after he picked up 2.5.2, the incompatibility of 2.5.2 Devmode unable to boot 5.X & 7.X was out.

    BTW, I asked mid-kid on CakeHax issue, he said he knew CakeHax had unsupported -2 to -6 frankenfirmwares for over a year, but he had no priority to fix this first.
     
    Last edited by MelonGx, May 31, 2016
  16. ochentay4
    OP

    ochentay4 Advanced Member

    Newcomer
    50
    2
    Jun 23, 2015
    Argentina
    Could someone help me? I'm trying to convert 3DS files to CIA with "3DS Simple CIA Converter v4.3", and aparently I need to generate xorpads, and dont know how to do it. I read somewhere that I can generate it using Decrypt9Wip but the copy that remained in my SD card no longer works, it just goes back to Homebrew menu. I also download Decrypt9 (stable) and same behavior. HelP!!!
     
  17. Quantumcat

    Quantumcat Dead and alive

    Member
    11,894
    6,381
    Nov 23, 2014
    Australia
    Canberra, Australia
    Xorpads are generated on your 3DS. If you look near the end if part 5 of the plailect guide, it should mention something about Uncart and link to a guide (at least it did when last I looked at it). Alternatively, download & install freeShop or CIAngel and you will be able to download and install most of the available eShop games. If you have the latest FBI you can install from QR code. In the release threads for CIAngel and freeShop the QR codes for the latest versions are given. If you want to get the latest FBI search google for FBI GitHub releases and you should find the release page, which will have a .cia you can download, put on your SD card, and install with the health and safety injected version of FBI.
     
    ochentay4 likes this.
  18. tjhooker73

    tjhooker73 GBAtemp Regular

    Member
    135
    38
    Aug 15, 2015
    United States
    Converting isn't worth it. That 3ds iso site should have a working link to any CIA be it game or dlc if you look or ask
     
    ochentay4 likes this.
  19. squall14716

    squall14716 GBAtemp Maniac

    Member
    1,247
    732
    May 16, 2011
    United States
    I'm assuming you followed the guide all the way through step 5 and are now using A9LH, correct? If so, you boot into Decrypt9WIP using A9LH, not the Homebrew menu.

    It looks like that guide doesn't setup Decrypt9WIP as a payload, here's how you do it (again, assuming A9LH and Luma3DS as the guide has you set up). Download the latest release of Decrypt9WIP, extract "Decrypt9WIP.bin" to your "luma/payloads" folder in your SD card. Rename "Decrypt9WIP.bin" to "down_Dec9.bin". Now, you will be able to start Decrypt9WIP by holding down on the d-pad when booting your 3DS.
     
    ochentay4 likes this.
  20. ochentay4
    OP

    ochentay4 Advanced Member

    Newcomer
    50
    2
    Jun 23, 2015
    Argentina
    Yeah, I downloaded freeShop and tested it and it worked, but it is in early develeopment stages and doesnt seem stable or fast, I would really like to convert my 3DS downloaded games to CIA. Will test CIAngel later. I already have the latest FBI as I did everything the guide told me a day ago. In fact, I already installed a Legit CIA and it worked. Thanks for the reply.

    I do not trust 3DS Rom sites, I prefer to get the 3DS files myself and check it to No-Intro database (as I always did for every console) and then convert to CIA. Anyway, could you tell me in a private message a recommended site?

    You assume correctly, I followed the guide exactly as I was told and all worked fine. You are correct, Decrypt9WIP it isnt setup as payload, I will follow your help and do it later.

    Thanks everyone for the rapid answers, I'm excited to try everything 3DS Homebre has to offer!

    One more thing, what do I need if my SD card fails? And if I dont have a backup of it (which I have)?