How long did your shipping take?

Discussion in 'Wii - Hacking' started by djg08642, Apr 9, 2008.

Apr 9, 2008
  1. djg08642
    OP

    Newcomer djg08642 Member

    Joined:
    Apr 8, 2008
    Messages:
    11
    Country:
    United States
    D2Pro - canadamods.ca
    -------------
    Ordered: 3/19/08
    Shipped: 3/20/08 - LOST
    Re-Shipped: 4/2/08

    Delivered, April 10, 2008, 9:59 am, MILWAUKEE, WI 53226
    Arrival at Unit, April 10, 2008, 4:09 am, MILWAUKEE, WI 53226
    Origin Post is Preparing Shipment

    =============================================
    Wii-Clip v4 - ic2005.com
    -------------
    Ordered: 3/19/08
    Shipped: 4/3/08

    Delivered, April 11, 2008, 11:12 am, MILWAUKEE, WI 53226
    Arrival at Unit, April 11, 2008, 10:11 am, MILWAUKEE, WI 53226
    Inbound Out of Customs, April 10, 2008, 12:01 am
    Inbound Into Customs
    Inbound International Arrival, April 05, 2008, 3:20 pm, ISC NEW YORK NY (USPS)
    Foreign International Dispatch, April 03, 2008, 2:12 pm, SHENZHEN EMS, CHINA PEOPLES REP
    Foreign Acceptance, April 03, 2008, 8:59 am
    Origin Post is Preparing Shipment



    What are everyone else's recent experiences with Canada Post/EMS/USPS tracking and customs? Is it normally this slow and are tracking updates almost unheard of?
     
  2. djg08642
    OP

    Newcomer djg08642 Member

    Joined:
    Apr 8, 2008
    Messages:
    11
    Country:
    United States
    Well the Wii-Clip cleared customs not 5 minutes after I called them this evening...

    If only I could say the same for the D2Pro [​IMG]

    Inbound Out of Customs, April 10, 2008, 12:01 am
    Inbound Into Customs
    Inbound International Arrival, April 05, 2008, 3:20 pm, ISC NEW YORK NY (USPS)
    Foreign International Dispatch, April 03, 2008, 2:12 pm, SHENZHEN EMS, CHINA PEOPLES REP
    Foreign Acceptance, April 03, 2008, 8:59 am
    Origin Post is Preparing Shipment
     
  3. djg08642
    OP

    Newcomer djg08642 Member

    Joined:
    Apr 8, 2008
    Messages:
    11
    Country:
    United States
    Got the modchip today from Canada. Canadapost tracking stopped working once it got into the US. And USPS tracking never worked.. It always said "Originating post" blah blah blah.
     
  4. stok3d

    Member stok3d Retro Gaming Inc.

    Joined:
    Oct 28, 2007
    Messages:
    252
    Location:
    SomeBeachSomeWhere
    Country:
    Canada
    well, i feel regular 'registered post' can be slow sometimes

    i have a package coming from australia and tomorrow will be the 10th business day, it hasn't shown up on canada post as of yet. not going to get worried unless it's like this by next friday.

    obviously it's slower when you don't pay express but more than 3 weeks with any kind of air-mail is kinda weak imo. then again it could be at customs, who knows.
     
  5. djg08642
    OP

    Newcomer djg08642 Member

    Joined:
    Apr 8, 2008
    Messages:
    11
    Country:
    United States
    Try checking with the Australian postal service tracking system. Was it through EMS?

    CanadaPost tracking was pretty useless in my case. I got the "Your package has been delivered" e-mail 14 hours it actually got here and the status never changed once it got out of the US on the USPS or CanadaPost website.
     
  6. stok3d

    Member stok3d Retro Gaming Inc.

    Joined:
    Oct 28, 2007
    Messages:
    252
    Location:
    SomeBeachSomeWhere
    Country:
    Canada
    No, it was coming from Oz so it was sent through Oz Post as 'registered post'

    The tracking # I was given isn't showing up anywhere. I have tried tracking with Oz post and the 3 major Canadian postal companies but there hasn't been any sign of this package anywhere. bummer..but not surprising as it's the story of my life, lol
     
  7. stok3d

    Member stok3d Retro Gaming Inc.

    Joined:
    Oct 28, 2007
    Messages:
    252
    Location:
    SomeBeachSomeWhere
    Country:
    Canada
    Bump........




    Anyone else care to share their ship times from Australia to Canada or Australia to the USA via Registered Post?
     
  8. phistyle

    Newcomer phistyle Member

    Joined:
    Mar 14, 2007
    Messages:
    17
    Country:
    United States
    I ordered a wii-clip + d2ckey last monday and he shipped it last Tuesday and I received it this Thursday in the USA...so about 10 days total including weekends...
     
  9. djg08642
    OP

    Newcomer djg08642 Member

    Joined:
    Apr 8, 2008
    Messages:
    11
    Country:
    United States
    Got my Wii-Clip today from ic2005.com

    Don't rely on the tracking systems that much. The post office and the carriers don't download the data after scanning packages until later in the day. See my first post for full tracking for each item.
     
  10. NoAlias

    Newcomer NoAlias Member

    Joined:
    Mar 17, 2008
    Messages:
    36
    Location:
    Netherlands
    Country:
    Netherlands
    Ordered on 31-mar-2008
    Shipped on 1-apr-2008
    Not arrived yet on 17-apr-2008

    So for the past 17 days I've been waiting on my wii-clip with D2CKey to arrive from Australia.

    I know that Australia is a long way away from Holland, but this is getting rediculous. [​IMG]
    I can't track the item, because I requested 'cheap' shipping via registerred post.
    The mail handler here in Holland tells me that the package has not arrived at the customs office yet.

    I hope it arrives soon. [​IMG] [​IMG]

    Cheers,
     
  11. phaerun

    Member phaerun GBAtemp Regular

    Joined:
    Mar 16, 2008
    Messages:
    103
    Location:
    Αθήνα
    Country:
    Greece
    I ordered my XCM II-Hot Rock Wii Case from Canada March 20th. When i mailed them on March 30th they told me it will take 3 weeks give or take.
    It arrived April 8th.

    I think it might have to do with the fact that it was originated outside eu . Then again who knows [​IMG]
     
  12. NoAlias

    Newcomer NoAlias Member

    Joined:
    Mar 17, 2008
    Messages:
    36
    Location:
    Netherlands
    Country:
    Netherlands
    Updated on 21-apr-2008:

    Ordered on 31-mar-2008
    Shipped on 1-apr-2008
    Australia post informs me that the package left Australia by plane on 3-apr-2008
    Dutch Post informs me that the package has not entered Dutch customs yet at 21-apr-2008.

    I consider it to be lost. Although that still needs to be investigated by the post services.
    Fortunately for OzModChips (who sent it), the package was insured, but naturally how the tugging war begins to see who should compensate Oz for the loss of the package.

    And I'm still waiting for my chip [​IMG] [​IMG] [​IMG]

    Undoubtedly this will be continued...................
     
  13. NoAlias

    Newcomer NoAlias Member

    Joined:
    Mar 17, 2008
    Messages:
    36
    Location:
    Netherlands
    Country:
    Netherlands
    (This is not a double post, but a major update in the status)

    Updated on 23-apr-2008:

    Ordered on 31-mar-2008
    Shipped on 1-apr-2008
    Arrived on 23-apr-2008

    Australia post told me 2 days ago that the package left Australia by plane on 3-apr-2008 and they had no record of it since then.
    Dutch Post informed me that the package had not entered Dutch customs on 21-apr-2008.

    OzMod inquired with Australia Post too, and they told him that the package had arrived at Dutch Customs on 4-apr-2008.
    A but strange that they tell two different stories.

    Anyway, IT HAS ARRIVED [​IMG]

    Travel time from Australia to Holland: 22 days.

    Cheers,
     
  14. Lloyd14

    Member Lloyd14 GBAtemp Regular

    Joined:
    May 9, 2006
    Messages:
    223
    Location:
    Iselia
    Country:
    Netherlands
    How long did your shipping take?
    FOR WHAT!!!

    My Verbatim DL+R disks took 6 days because i orderd them before easters.
     

Share This Page