How do you update games if your if your console doesnt have the current version?

Discussion in '3DS - Flashcards & Custom Firmwares' started by Tyrantt, Feb 14, 2015.

  1. Tyrantt
    OP

    Tyrantt Advanced Member

    Newcomer
    73
    0
    Feb 13, 2015
    United States
    Portland, Oregon
    How do you update games if your console doesnt have the current version? for example, i have 9.4 on the N3DS and its telling me that in order to play the game, even single player, i have to update the game. So how do I update the game without updating the console?

    also, does anyone know where the SD card is on the N3DS? i cant seem to find it. lol
     


  2. Oishikatta

    Oishikatta GBAtemp Advanced Fan

    Member
    971
    545
    Oct 30, 2014
    United States
    You don't.

    With gateway you can update by installing .cia, but there is no gateway for N3DS yet. The micro sd card is under the back.
     
  3. Tyrantt
    OP

    Tyrantt Advanced Member

    Newcomer
    73
    0
    Feb 13, 2015
    United States
    Portland, Oregon

    So in other words, I wont be able to play my super smash bros cart unless i upgrade? How to people play online then if/when there is a patch for that game that requires the update in order to play online?

    and im using sky3ds also.
     
  4. Hkari

    Hkari GBAtemp Regular

    Member
    146
    34
    Oct 15, 2008
    United States
    Everything I'm saying is from the view of someone who uses gateway, so it might be a bit different for sky. This is to the best of my knowledge.

    If you aren't going to play a game online and the game requires a game update, you can just ignore the game update sometimes (all the time?) by pressing the A button to launch instead of the Y button to go to eshop (1). If you want to play online, you need the latest game update. If you are on the latest firmware, you can download the update for the game from the eshop if your game is the same region as your eshop (2), or you can use cia updates (3). If your game and eshop are different regions, you have to use cia updates (4).

    1. The JP Smash rom on my NTSC-U console tells me an update is available when I try to launch it. I press the A button to ignore the prompt and play the game. I can't play online.
    2. My NTSC-U copy of Pokémon Y with my NTSC-U console has an update available. I am on the most recent firmware. I load up the eshop and download the update.
    3. Same game and console as № 2, but my console isn't on the latest firmware. I have to find the update as a cia file and install the cia file myself because I can't access the eshop (outdated firmware). Sky users can't install cia files with only the sky card.
    4. My JP dump of Monster Hunter 4 G needs an update on my NTSC-U console. I want to play online so I have to find the update as a cia file and install the cia file myself because I can't access the eshop (different region). Sky users can't install cia files with only the sky card.
     
    cvskid likes this.
  5. Tyrantt
    OP

    Tyrantt Advanced Member

    Newcomer
    73
    0
    Feb 13, 2015
    United States
    Portland, Oregon

    I pushed A to launch the game instead of Y to update it and it says "Unable to find the latest data for super smash bros for N3DS. please close the game and go to nintendo eshop to download the latest update data to your sd card"
     
  6. CrazySpaniard

    CrazySpaniard Member

    Newcomer
    34
    23
    Nov 14, 2008
    Canada
    try turning off wifi maybe, I just got a n3ds and smash today and I immediately popped it in and started playing offline on 9.0
     
  7. Adeka

    Adeka Beta Tester

    Member
    3,988
    1,209
    Mar 19, 2013
    United States
    Doesn't the update get installed to the sd card? Can't you transfer the update from the sd to the micro sd (assuming you can update via an older ds with gateway)?
     
  8. Hkari

    Hkari GBAtemp Regular

    Member
    146
    34
    Oct 15, 2008
    United States
    I don't know why it's different for you. I can do it just fine. I just press the A button from the point in the picture() and it works. Could anyone playing on a sky card weight in?

    I've never had a problem playing with wifi on besides the screen saying update available that I can bypass.
     
  9. aekotra

    aekotra Member

    Newcomer
    17
    2
    Oct 26, 2014
    Canada
    I have no idea if this works. My hunch is that game patches are not tied to the system in any way.

    My brother has the Smash retail cart but not a Gateway. I ripped my update folder for him so he can stay on 9.2 and still play Smash online with me. He hasn't tested it yet; maybe you can beat him to it! Here's the instructions I sent him:

    1) Open your SD card on your PC
    2) Inside you'll have a folder structure like this (I broke it into lines)

    \Nintendo 3DS
    \2d4ff57ee8a0d439599a39436be3ccd5
    \19e300c83110b5203030303000284245
    \title
    \0004000e
    \000edf00

    Folders #2 and #3 (the long ones) might be different on your SD, but the other directories should be the same.

    3) \000edf00 is the Smash Bros game ID where the updates are stored. Backup that folder (just in case). Delete it from your SD.

    4) Download my \000edf00 folder.
    http://www39.zippyshare.com/v/UHHgdw1I/file.html

    5) You'll find the \000edf00 folder inside the zip. Put that folder where yours was.

    6) Play Smash online with firmware 9.2????
     
  10. Tyrantt
    OP

    Tyrantt Advanced Member

    Newcomer
    73
    0
    Feb 13, 2015
    United States
    Portland, Oregon
    my firmware on the N3DS is 9.4 will this work?
     
  11. Adeka

    Adeka Beta Tester

    Member
    3,988
    1,209
    Mar 19, 2013
    United States
    Nobody knows. Someone should try it. I ran my battery out of my new 3ds already and it's charging :P
     
  12. aekotra

    aekotra Member

    Newcomer
    17
    2
    Oct 26, 2014
    Canada

     
    Adeka likes this.
  13. cvskid

    cvskid GBAtemp Addict

    Member
    2,156
    772
    Apr 13, 2014
    United States
    Is it for the USA version of super smash bros 3ds?
     
  14. aekotra

    aekotra Member

    Newcomer
    17
    2
    Oct 26, 2014
    Canada
    Tyrantt, the folder I uploaded is for the USA version. It's possible that the region doesn't matter(?).
     
  15. cvskid

    cvskid GBAtemp Addict

    Member
    2,156
    772
    Apr 13, 2014
    United States
    Does not work for me, tried replacing the whole folder with yours and it says that there are no update files and i have to download the latest update. So then i named each file from the 1.0.5 update the same file names from the 1.0.4 update and it still reads it as 1.0.4 update. Also in the data management despite having the 1.0.5 update folder it still reads as 1.0.4 update. I might be doing something wrong and someone might figure it out later on.
     
  16. Oswarlan

    Oswarlan GBAtemp Regular

    Member
    148
    35
    May 28, 2013
    United States
    There is no way this method would work, as content is encrypted per-device. The only way to get your update, is to update the console (which you can't really do on the N3DS yet), or install a cia containing the update, which is also a no go on the N3DS. That is it.
     
    cvskid likes this.
  17. LinkmstrYT

    LinkmstrYT ( ͡° ͜ʖ ͡°)

    Member
    1,458
    800
    Dec 16, 2013
    United States
    You wanted to see where I live? You stalker...
    In short, you can't update games without updating your New3DS to access the eShop.
     
  18. aekotra

    aekotra Member

    Newcomer
    17
    2
    Oct 26, 2014
    Canada
    Any chance we could grab the update with FunkyCIA2?

    https://gbatemp.net/threads/release...our-eshop-content-super-easy-and-fast.376941/
    I wonder if this would apply to updates:
     
  19. Oishikatta

    Oishikatta GBAtemp Advanced Fan

    Member
    971
    545
    Oct 30, 2014
    United States
  20. aos10

    aos10 look at me,shitposting about GW,i am so cool

    Member
    2,824
    635
    Apr 10, 2012
    Saudi Arabia
    if i used the cia update on emunand
    will it work when i am back to sysnand ?
    for example
    i have 9.2 sysnand and 9.5 emunand
    installed SSB update on emunand
    will it work when i am back to sysnand ?