1. woolywoods

    OP woolywoods Newbie
    Newcomer

    Joined:
    Aug 6, 2020
    Messages:
    4
    Country:
    United States
    I've seen threads with methods to add games to EZF advance using a ds flashcart and a ds, however, I can't get mine to work? I'm using the DS x-treme, and I'm following the instructions in this post.* I've tried pressing start and select while booting up slot 2, as well as normally booting. I don't want to flash over the cartridge, and my gba is in repairs currently, so I can't add games normally.

    Am I just missing a step? Is the Ds-xtreme not compatible with the guide?

    Thank you in advance! :)

    *New member so I can't post links, but the title is [release] EZF advance (original) flasher for nintendo ds

    edit : not sure if my ezf is an original, (which might be the issue here) because the sticker is long lost- is there any other way to tell? Something about the cartridge itself?
     
    Last edited by woolywoods, Aug 6, 2020
  2. thaddius

    thaddius Charmander is not pleased.
    Member

    Joined:
    May 5, 2008
    Messages:
    1,340
    Country:
    Canada
    The thread you're referring to is this one. And you're right, it doesn't seem to work.

    I tried to flash my EZFAdvance with the ezfa.nds file with both an original DS and a DS Lite on an Acekard2i and a Supercard DSTWO. Each time the flashing process went fine - the application detected the card and said it was flashing the files I had in the 'gba' folder in the root of my SD card on the DS cart - but the GBA card says "No Game Found, Try to reburn me" when you turn it back on.

    EDIT: And btw, my EZFAdvance (which is legitimate) lost it's sticker long ago too. That seems to be normal for these things.

    EDIT 2: I ended up trying the original project and it does work although it can only flash one game. You name the game rom.gba and put it in the root of your DS card's SD.

    I then ran the new one again after and it just left me with a white screen. Might be SOL on this one.
     
    Last edited by thaddius, Aug 6, 2020
    woolywoods likes this.
  3. woolywoods

    OP woolywoods Newbie
    Newcomer

    Joined:
    Aug 6, 2020
    Messages:
    4
    Country:
    United States
    I got desperate and tried running the original project as well, it got to the "EZF card is detected!" screen but then didn't do anything for a minute or so, and I turned off the ds. When running the new version, where you can save multiple games, it literally just made my device blackscreen and then turn off. When you turn it back on, you can see that nothing changed. I wasn't even aware it was supposed to show any screen until now...

    I'm going to run it again and see what happens.

    Edit : Same thing happened, so I'm going to try and flash on the original software, since at least the original could detect the EZFA.

    Edit 2: While I was waiting, I decided to look at the original code to figure out what was going on here, and apparently it's supposed to run this bit of code that will tell me it's burning the rom, and that code just isn't running.

    Edit 3: In the original code, you needed your drive to have a specific name (fat) so it could burn the rom I believe- I'm going to format the drive and rename it to that.

    Edit 4: ( sorry for the edits, I think it's just smart to leave a log of what works and what doesn't...) renamed the drive fat, and formatted it to fat32 (kept the original files and copied them back on) I now have gotten to the white screen!
     
    Last edited by woolywoods, Aug 6, 2020
  4. thaddius

    thaddius Charmander is not pleased.
    Member

    Joined:
    May 5, 2008
    Messages:
    1,340
    Country:
    Canada
    Attached to this post is what the display looks like on mine when flashing.

    Running the original nds file may have been a mistake as it seems to have gotten rid of the menu. I no longer get the "No Game Found, Try to reburn me" message. I'll have to see about getting the writer cable to work to fix it.
     

    Attached Files:

  5. woolywoods

    OP woolywoods Newbie
    Newcomer

    Joined:
    Aug 6, 2020
    Messages:
    4
    Country:
    United States
    Oof. The updated version I'm getting even less luck trying. I'll try a couple more things, but I might just have to wait until I can get my gba running again in order to properly flash.

    Edit: After I got the whitescreen, I tried the exact same procedure and I'm back to black screen and immediate power down.

    Edit 2: I'm gonna give up for now, but if something ends up working I'll come back here and update.
     
    Last edited by woolywoods, Aug 6, 2020
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - advance, games,