How do Install wads on my NAND dump?

Discussion in 'Wii - Hacking' started by cthg, Aug 18, 2009.

Aug 18, 2009
  1. cthg
    OP

    Member cthg GBAtemp Regular

    Joined:
    Jan 22, 2009
    Messages:
    197
    Country:
    United States
    I dumped my NAND using Wanin's FS dumper and whenever I try to install a wad to it using wad manager 1.5 I get a ret-1 when I try to mount the SD

    I've tried it with the NAND dump on the root of the sd card and with it in the wii-fs folder the program makes it never works.
     
  2. kedest

    Member kedest GBAtemp Psycho!

    Joined:
    Feb 6, 2007
    Messages:
    3,283
    Country:
    Netherlands
    the nand and wads can't be on the same device
     
  3. ChokeD

    Member ChokeD The Contributor

    Joined:
    Jul 18, 2009
    Messages:
    967
    Country:
    United States
    Definitly Harry potter data, I had 2 errors at first when dumping my nand. Both were Harry Potter titles.

    10000/52355045/data/HP:OOTP = Order Of The Pheonix

    10000/52483645/data/HP:HBP1 = Harry Blood Prince

    I followed the address to the data and deleted it out of my nand with AnyTitleDeleter:

    and got a perfect dump afterwards with simpleFSdumper.



    tried 3.2U and 4.1U
    2 different wii's
    same HD Maxtor III
    1TB fat32/wbfs both active(don't know which is first partition, I believe the fat is)
    2gb sd Lexar regular(not sdhc)
    wadmanager1.5
    rev14
    triiforce.4

    this is what my current file structure looks like

    sd:/wad/wog.wad

    usb:/shared1
    usb:/shared2
    usb:/sys
    usb:/ticket
    usb:/title
    usb:/tmp
    usb:/import
    usb:/meta

    I've tried the opposite:

    usb:/wad/wog.wad

    sd:/shared1
    sd:/shared2
    sd:/sys
    sd:/ticket
    sd:/title
    sd:/tmp
    sd:/import
    sd:/meta

    in wad manager Ive chosen 249,nand=where it's located,source=where the wad is,

    if the wad is on the usb, the nand(sd) is seen but when choosing the source it gives an -1 error

    if the wad is on the sd, it seems(IDK no error is given at this time) to find the nand(USB), choosing sd as source, then it shows you the wads and choose wad, then gives -1 error
    --------------------------------------------------------------------------------------------------
    fire up triiforce with this config:

    sd:/wad/wog.wad

    usb:/shared1
    usb:/shared2
    usb:/sys
    usb:/ticket
    usb:/title
    usb:/tmp
    usb:/import
    usb:/meta

    choosing usb-nand= error -1 cannot get dir entry count! (result -1)
    reading folder /title/00010001 failed
    error getting the title list

    then the wii freezes and have to hard reset
    -------------------------------------------------------------------------------------------------

    fire up triiforce with this config:

    usb:/wad/wog.wad

    sd:/shared1
    sd:/shared2
    sd:/sys
    sd:/ticket
    sd:/title
    sd:/tmp
    sd:/import
    sd:/meta

    choosing sd-nand= loading no titles found (because I didn't have wads installed on my nand when it was dumped with simpleFSdumper

    then you can hit home and the wii does not freeze because it is properly loading nand on sd.
    -------------------------------------------------------------------------------------------------

    my question:
    I have only 1 choice inside wadmanager 1.5 when choosing nand= USB 2.0 Mass Storage Device
    I have 2 choices inside wadmanager 1.5 when choosing source= USB 2.0 Mass Storage Device and Mass Storage Device

    could this be where the problem lies ????
    could rev14 see it as a non 2.0 device somewhere in the process

    I have chosen every combo of that also and believe me same error -1

    Triiforce does not find my nand or read the USB it draws error -1 immediately.

    Could anyone, does anyone, know the difference/reasoning behind the "2.0 Mass Storage Device" and "Mass Storage Device" options in Wad Manager 1.5 ?????

    Is it safe to assume that the rev14/wadmanager1.5 is identifying my hd as a 2.0 at some point and then identifying it as a non-2.0 at another ?????

    Does anyone else get the choices I do in Wad Manager 1.5
    ????

    only/just "2.0 Mass Storage Device" when choosing the nand

    then "2.0 Mass Storage Device" and "Mass Storage Device" options when choosing source ?????

    My theory,

    rev14 has compatibility issues with usb's as far as the nand/emu goes.

    seeking answers,
    ChokeD


    EDIT: I got me a 16GB Toshiba thumb drive today for $39.95, everything works with it, "EVERYTHING ABOVE IN THIS POST".


    So what did I do ???? I took the FS-dumped nand with wads injected into it and put it on my USB HD from my usb thumb drive and Triiforce said:

    choosing usb-nand= error -1 cannot get dir entry count! (result -1)
    reading folder /title/00010001 failed
    error getting the title list


    It has to be an HD compatibility problem inside rev14 the way that Triiforce is using it. Why else would my USB HD work flawlessly with USBLoader GX and not Triiforce.

    Because I might not be using a 2.0 port on my USB HD ??????
     
  4. kLiNiKaL

    Member kLiNiKaL Dr. Greenthumb

    Joined:
    May 24, 2009
    Messages:
    581
    Location:
    Los Ganjales
    Country:
    Jamaica
    ChokeD i've been getting exactly the same error, with the same setup (my SD and HDD is a diff brand btw.) but my locations and file structure and tests are identical, i've tried withe the fs method and trying with the .bin and still no joy.

    has anyone got this working?
     
  5. ChokeD

    Member ChokeD The Contributor

    Joined:
    Jul 18, 2009
    Messages:
    967
    Country:
    United States
    triiforce does not use the .bin file. My folder structure is the correct method. My dump was a good dump, no errors. This really needs resolved, but I have a feeling that it won't be until waninkoko rev15 comes out.

    Triiforce does not find my nand or read the USB it draws error -1 immediately.

    Could anyone, does anyone, know the difference/reasoning behind the "2.0 Mass Storage Device" and "Mass Storage Device" options in Wad Manager 1.5 ?????

    Is it safe to assume that the rev14/wadmanager1.5 is identifying my hd as a 2.0 at some point and then identifying it as a non-2.0 at another ?????

    Does anyone else get the choices I do in Wad Manager 1.5 ????

    only/just "2.0 Mass Storage Device" when choosing the nand

    then "2.0 Mass Storage Device" and "Mass Storage Device" options when choosing source ?????
     

Share This Page