Hacking How do I launch .bin and .elf on Wii U 5.4.0?

Irastris

Well-Known Member
Member
Joined
May 3, 2015
Messages
1,115
Trophies
0
XP
826
Country
United States
@Onion_Knight has mentioned that he has brought Loadiine v3 to 5.4.0 but needs someone to test it.

Compiled a special build that hopefully will work for 5.4.0 if anyone wants to give it a try.

My problem is that it isn't a single MP4, but rather 4 files:
  • code532.bin
  • fs532.elf
  • loader532.elf
  • menu532.elf
How do I go about launching these? I've only been loosely following Wii U developments until now and never heard of those formats 'till now. (Well I've heard of .elf in original Wii homebrew but not Wii U.)

Please note I need a solution that works with locally hosted via HFS, because my DNS is set to 192.168.0.0. I'm too paranoid even for TubeHax.
 
  • Like
Reactions: memomo

Kakkoii

Old fart
Member
Joined
Sep 14, 2007
Messages
631
Trophies
0
XP
586
Country
Canada
You should be able to just place those files in the same location you do for all the other local hosted hacks that aren't already compiled to mp4. Here I've uploaded the Pong one, simply replace the code532.bin that's already in it, with the one you have there, along with the other files included. Or you may need to place the .elf files in an "elfloader" folder that's located at the root directory of your local host or maybe the exploit folder. Depends on if that code532.bin is the compiled elfloader or heavily modified.

I can't confirm if this is how to do it right now though, currently testing a modification I made to WUPinstaller, hopefully it fixes the install issues...
 

Attachments

  • exampleExploit.zip
    11.6 KB · Views: 172
Last edited by Kakkoii,
  • Like
Reactions: Irastris

Irastris

Well-Known Member
Member
Joined
May 3, 2015
Messages
1,115
Trophies
0
XP
826
Country
United States
You should be able to just place those files in the same location you do for all the other local hosted hacks that aren't already compiled to mp4. Here I've uploaded the Pong one, simply replace the code532.bin that's already in it, with the one you have there, along with the other files included. Or you may need to place the .elf files in an "elfloader" folder that's located at the root directory of your local host or maybe the exploit folder. Depends on if that code532.bin is the compiled elfloader or heavily modified.

I can't confirm if this is how to do it right now though, currently testing a modification I made to WUPinstaller, hopefully it fixes the install issues...

Thanks for the help, but how do I then run that? Attempting to load index.php on my Wii U says "Unable to load file."
 

Kakkoii

Old fart
Member
Joined
Sep 14, 2007
Messages
631
Trophies
0
XP
586
Country
Canada
Damn, I'm using HFS. Any chance you could help me with setting up Apache? I've always crashed and burned the last times I've done it.
Just install XAMPP and uncheck each of the module options in the installer except for Apache. Place your folders in the xampp/htdocs/ folder, open XAMPP control panel and "Start" the apache server. You should now be able to visit your local IPv4 address and click any of the folders that you place in the htdocs directory, causing the server to load the index.php.

5.6.15 is the one I'm using.
https://www.apachefriends.org/download.html

edit: Also, if Skype is running it takes over the SSL port and can make it not work properly. You can change the port to something else by clicking the "Config" button for Apache, and choose "Apache (httpd-ssl.conf)", and searching for the two instances of "443" in it and changing them to a different port that your system doesn't use, something in the thousands, like 4906. Then you would connect like "http://myIP:4906/"
 
Last edited by Kakkoii,

Irastris

Well-Known Member
Member
Joined
May 3, 2015
Messages
1,115
Trophies
0
XP
826
Country
United States
Just install XAMPP and uncheck each of the module options in the installer except for Apache. Place your folders in the xampp/htdocs/ folder, open XAMPP control panel and "Start" the apache server. You should now be able to visit your local IPv4 address and click any of the folders that you place in the htdocs directory, causing the server to load the index.php.

5.6.15 is the one I'm using.
https://www.apachefriends.org/download.html
Wow, that was surprisingly straight forward. I wish I had known about XAMPP months ago!
 

Irastris

Well-Known Member
Member
Joined
May 3, 2015
Messages
1,115
Trophies
0
XP
826
Country
United States
Just install XAMPP and uncheck each of the module options in the installer except for Apache. Place your folders in the xampp/htdocs/ folder, open XAMPP control panel and "Start" the apache server. You should now be able to visit your local IPv4 address and click any of the folders that you place in the htdocs directory, causing the server to load the index.php.

5.6.15 is the one I'm using.
https://www.apachefriends.org/download.html

edit: Also, if Skype is running it takes over the SSL port and can make it not work properly. You can change the port to something else by clicking the "Config" button for Apache, and choose "Apache (httpd-ssl.conf)", and searching for the two instances of "443" in it and changing them to a different port that your system doesn't use, something in the thousands, like 4906. Then you would connect like "http://myIP:4906/"

Welp, it's unfortunately not as straight forward as it first seemed.
I configured Apache to run on port 8080, since that's what I have port-forwarded and use for HFS.
Loads up perfectly in Firefox, but the Wii U Browser just sits there and then gives the error that it couldn't find the page.

I've changed the httpd-ssl.conf to say "Listen 8080" and "ServerName www.example.com:8080".

There's a third string that says "<VirtualHost _default_:443>" but changing that port to anything else causes it to say "Bad request!" in Firefox and still not load on the WiiU.
 

Kakkoii

Old fart
Member
Joined
Sep 14, 2007
Messages
631
Trophies
0
XP
586
Country
Canada
Welp, it's unfortunately not as straight forward as it first seemed.
I configured Apache to run on port 8080, since that's what I have port-forwarded and use for HFS.
Loads up perfectly in Firefox, but the Wii U Browser just sits there and then gives the error that it couldn't find the page.

I've changed the httpd-ssl.conf to say "Listen 8080" and "ServerName www.example.com:8080".

There's a third string that says "<VirtualHost _default_:443>" but changing that port to anything else causes it to say "Bad request!" in Firefox and still not load on the WiiU.
I believe I changed the port in httpd.conf and used that port instead of the ssl one. I did change that virtualhost as well though, but I connect with the port in httpd.conf.
 

Irastris

Well-Known Member
Member
Joined
May 3, 2015
Messages
1,115
Trophies
0
XP
826
Country
United States
I believe I changed the port in httpd.conf and used that port instead of the ssl one. I did change that virtualhost as well though, but I connect with the port in httpd.conf.

After I changed all the 80 ports to 8080 in httpd.conf, Apache won't even start. It just produces errors saying it shutdown unexpectedly.
I'm about tear every last hair from my skull. :hateit:
 

Kakkoii

Old fart
Member
Joined
Sep 14, 2007
Messages
631
Trophies
0
XP
586
Country
Canada
After I changed all the 80 ports to 8080 in httpd.conf, Apache won't even start. It just produces errors saying it shutdown unexpectedly.
I'm about tear every last hair from my skull. :hateit:
Don't use 8080, that's a common one used for other stuff, also, the SSL port can't be the same as the other port...
 

Irastris

Well-Known Member
Member
Joined
May 3, 2015
Messages
1,115
Trophies
0
XP
826
Country
United States
Don't use 8080, that's a common one used for other stuff, also, the SSL port can't be the same as the other port...

Still no luck, set httpd.conf to 4906 and httpd-ssl.conf to 443.
Tried again setting httpd-ssl.conf to 5012 and still nothing.
Continues to work in Firefox, and nothing on the Wii U.
 

Kakkoii

Old fart
Member
Joined
Sep 14, 2007
Messages
631
Trophies
0
XP
586
Country
Canada
Still no luck, set httpd.conf to 4906 and httpd-ssl.conf to 443.
Tried again setting httpd-ssl.conf to 5012 and still nothing.
Continues to work in Firefox, and nothing on the Wii U.
How are you writing the url on the WiiU?

Also, try going to "config" at the top right of XAMPP, click "Service and Port Settings", and change the "Main Port" and "SSL Port" to what you set in the files.
 
Last edited by Kakkoii,

Irastris

Well-Known Member
Member
Joined
May 3, 2015
Messages
1,115
Trophies
0
XP
826
Country
United States

Scuba156

Well-Known Member
Member
Joined
Jan 19, 2010
Messages
340
Trophies
0
Age
33
XP
314
Country
Set your DNS on the Wii U to the IP Address of the PC hosting the files. Just tested it, it blocks all traffic except to the IP set in the DNS
 

Irastris

Well-Known Member
Member
Joined
May 3, 2015
Messages
1,115
Trophies
0
XP
826
Country
United States
I'm not sure why the WiiU can't access it, it could be your firewall. I think you need to go into your router settings and forward that port to your IP.
That's gonna be an issue, and this is why I was so persistant to use 8080:
I lost my router access code sticker, and paying $30 for a new one though just for that is something I'd prefer not to do.

Why does HFS work without a hitch on 8080 but Apache has a hissy fit and shits everywhere?

--------------------- MERGED ---------------------------

Set your DNS on the Wii U to the IP Address of the PC hosting the files. Just tested it, it blocks all traffic except to the IP set in the DNS
I did this 8 hours ago for using HFS. Still doesn't make Apache work.
 

Kakkoii

Old fart
Member
Joined
Sep 14, 2007
Messages
631
Trophies
0
XP
586
Country
Canada
That's gonna be an issue, and this is why I was so persistant to use 8080:
I lost my router access code sticker, and paying $30 for a new one though just for that is something I'd prefer not to do.

Why does HFS work without a hitch on 8080 but Apache has a hissy fit and shits everywhere?
8080 should work as long as nothing else is using it, and leave your SSL as 443. Hell, even 80 should work, just make sure Skype is closed.
 

Scuba156

Well-Known Member
Member
Joined
Jan 19, 2010
Messages
340
Trophies
0
Age
33
XP
314
Country
That's gonna be an issue, and this is why I was so persistant to use 8080:
I lost my router access code sticker, and paying $30 for a new one though just for that is something I'd prefer not to do.

Why does HFS work without a hitch on 8080 but Apache has a hissy fit and shits everywhere?

--------------------- MERGED ---------------------------


I did this 8 hours ago for using HFS. Still doesn't make Apache work.
Works just fine here. Remove HFS completely then try again with XAMPP
 

Irastris

Well-Known Member
Member
Joined
May 3, 2015
Messages
1,115
Trophies
0
XP
826
Country
United States
8080 should work as long as nothing else is using it, and leave your SSL as 443. Hell, even 80 should work, just make sure Skype is closed.
I don't even have a Skype account or Skype installed.
Tried again and doesn't work. httpd as 8080 and httpd-ssl as 443. Changed XAMPP Service and Port Setting to reflect that.
Continues to work in Firefox and not on the Wii U.

Works just fine here. Remove HFS completely then try again with XAMPP
Did it, no change.
Re-downloaded it and ran it afterwards and then the Wii U browser connects fine. Useless though since HFS can't host PHP.
 

Site & Scene News

General chit-chat
Help Users
    T @ tungns: very true