How do I install WAD files to emunand with usbloadergx?

Discussion in 'Wii - Hacking' started by TriangleThesis, Jun 12, 2018.

  1. TriangleThesis
    OP

    TriangleThesis Member

    Newcomer
    1
    Jun 3, 2018
    United States
    I couldn't find a guide anywhere about installing wad files to the emunand and I need help, most of the guides don't help at all.
     
  2. GreyWolf

    GreyWolf GBAtemp Guru

    Member
    8
    Mar 2, 2015
    United States
    Settings>Features>Install WAD to emuNAND :P
     
  3. TriangleThesis
    OP

    TriangleThesis Member

    Newcomer
    1
    Jun 3, 2018
    United States
    I already tried that and it didn't work.
     
  4. GreyWolf

    GreyWolf GBAtemp Guru

    Member
    8
    Mar 2, 2015
    United States
    How did it not work?
     
  5. TriangleThesis
    OP

    TriangleThesis Member

    Newcomer
    1
    Jun 3, 2018
    United States
    They didn't load up.
     
  6. GreyWolf

    GreyWolf GBAtemp Guru

    Member
    8
    Mar 2, 2015
    United States
    What do you mean? They didn't install or they didn't run once installed? Come on, we're not dentists. If you want help at least give some information.
     
  7. TriangleThesis
    OP

    TriangleThesis Member

    Newcomer
    1
    Jun 3, 2018
    United States
    It said they were installing and when it was done I tried to play it and it sent me back to the Wii home menu.
     
  8. GreyWolf

    GreyWolf GBAtemp Guru

    Member
    8
    Mar 2, 2015
    United States
    That sounds like a cIOS problem. Have you generated a SysCheck report?
     
  9. TriangleThesis
    OP

    TriangleThesis Member

    Newcomer
    1
    Jun 3, 2018
    United States
    Here is my SysCheck:
    Warning: Spoilers inside!
     
  10. jeannotte

    jeannotte GBAtemp Fan

    Member
    3
    Jun 15, 2016
    France
    Hello,

    @TriangleThesis :

    Only your cios 249 is badly installed.

    Reinstall your cios 249 correctly as on this base = >> IOS249 [56] rev 21010, Info: d2x-v10beta52.
     
  11. TriangleThesis
    OP

    TriangleThesis Member

    Newcomer
    1
    Jun 3, 2018
    United States
    I reinstalled it but the WAD files still don't play.
     
  12. GreyWolf

    GreyWolf GBAtemp Guru

    Member
    8
    Mar 2, 2015
    United States
    What game doesn't work? Almost all WW/VC games work just fine under emuNAND. There are only like 10-15 games that don't.

    Emulated NAND via cIOS and NEEK both require an MBR/FAT32-formatted drive. They do not work with GPT and they do not work with other filesystems like NTFS.
     
    Last edited by GreyWolf, Jun 13, 2018
  13. TriangleThesis
    OP

    TriangleThesis Member

    Newcomer
    1
    Jun 3, 2018
    United States
    I have been trying to play Sonic 4 Episode 1 and I Just tried to reinstall it to the EmuNand and it said it wasn't processed. How do I install it the the EmuNand?
     
    Last edited by TriangleThesis, Jun 13, 2018
  14. GreyWolf

    GreyWolf GBAtemp Guru

    Member
    8
    Mar 2, 2015
    United States
    It could be a bad WAD? There should be a file called "WadManager_errors.txt" in the loader's folder afterwards.

    Do you actually have a dumped NAND and the loader configured to point to the folder it's in? That is required.
     
  15. TriangleThesis
    OP

    TriangleThesis Member

    Newcomer
    1
    Jun 3, 2018
    United States
    I didn't have a dumped NAND so I dumped it to my EmuNAND folder then I installed WADs to it, the WAD files are fine because I tried them in Dolphin emulator and they worked perfectly but it still says it couldn't be processed.
     
  16. TriangleThesis
    OP

    TriangleThesis Member

    Newcomer
    1
    Jun 3, 2018
    United States
    Ok I got it to work, I installed the WADs to the dumped NAND that was inside the EmuNAND folder with ShowMiiWADs.
     
  17. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    21
    Oct 27, 2002
    France
    Engine room, learning
    you made a full nand dump, and the wad installed using the loader doesn't work, but works fine if installed using showmiiwads?

    It's maybe a bad wad, or using a wrong ticket (some release group used the "common key" ID in the ticket to fake the signature, resulting sometime in the loader using the korean common key instead of the good one. I tried to fix that, but it can still happen in rare cases.
    but it's only a supposition, without seeing the wad by myself to understand what goes wrong with the loader.

    Greywolf : I didn't know the loader created a log file when installing a wad. I'll have to verify !
    it would be nice to see its content when trying to install that game.
     
    Last edited by Cyan, Jun 13, 2018
  18. drcrappants

    drcrappants Advanced Member

    Newcomer
    2
    Feb 1, 2010
    United States
    is there a reason to install wad games into emunand? why is this preferred?

    also, i used triiforce ages ago to install my wads, is that outdated now
     
Loading...