How do I compile QTwitGUI on Ubuntu?

Discussion in 'Wii - Hacking' started by alex.ap.pacman, Jan 29, 2012.

Jan 29, 2012
  1. alex.ap.pacman
    OP

    Member alex.ap.pacman GBAtemp Regular

    Joined:
    Sep 5, 2010
    Messages:
    133
    Location:
    Seattle, Washington
    Country:
    United States
    I need some instruction on how I would go about compiling the qtwitgui for Linux. No one seems to have posted anything telling me how or anyone else how, so I want to know how.
     
  2. giantpune

    Member giantpune GBAtemp Addict

    Joined:
    Apr 10, 2009
    Messages:
    2,860
    Country:
    United States
    http://code.google.com/p/qtwitgui/wiki/AboutThisProgram#Compiling

    you dont need to get the sdk from nokia's website. just get the qt4 dev packages from the ubuntu package manager.
     
  3. alex.ap.pacman
    OP

    Member alex.ap.pacman GBAtemp Regular

    Joined:
    Sep 5, 2010
    Messages:
    133
    Location:
    Seattle, Washington
    Country:
    United States
    So do I download the QT SDK from the Nokia Site first? then the Ubuntu Package Manager? or what?
     
  4. giantpune

    Member giantpune GBAtemp Addict

    Joined:
    Apr 10, 2009
    Messages:
    2,860
    Country:
    United States
    i dont know how to say it any better than this.
     
  5. alex.ap.pacman
    OP

    Member alex.ap.pacman GBAtemp Regular

    Joined:
    Sep 5, 2010
    Messages:
    133
    Location:
    Seattle, Washington
    Country:
    United States
    Would I be getting the Qt4-Dev-Tools package?
     
  6. alex.ap.pacman
    OP

    Member alex.ap.pacman GBAtemp Regular

    Joined:
    Sep 5, 2010
    Messages:
    133
    Location:
    Seattle, Washington
    Country:
    United States
    Okay, so now that I got all that installed what do I download for the GUI? The SVN says to get the .pro file, is that all I need?

    How do I download it? When I open it in Qt Creator and try to build it it gives me this error:

    Code:
    :-1: error: No rule to make target `mainwindow.ui', needed by `ui_mainwindow.h'.  Stop.
    
     
  7. alex.ap.pacman
    OP

    Member alex.ap.pacman GBAtemp Regular

    Joined:
    Sep 5, 2010
    Messages:
    133
    Location:
    Seattle, Washington
    Country:
    United States
    Okay, so here's what I've been able to do so far -

    installed qt4-dev-tools includes all the tools needed for QT4Creator

    Here's what I run into...


    I need to know how to get the source files for this program - http://code.google.c...isProgram#linux

    This is what I ran in terminal to download all the files:
    [​IMG]

    Then:
    [​IMG]

    Then: [​IMG]

    After that:

    [​IMG]

    And when I got into the qT4 Creator:

    [​IMG]

    And the point of error...

    [​IMG]
     
  8. raulpica

    Supervisor raulpica With your drill, thrust to the sky!

    Joined:
    Oct 23, 2007
    Messages:
    10,657
    Location:
    _____________ PowerLevel: 9001
    Country:
    Italy
    Do not create more than one thread on the same thing.

    Threads merged.
     
  9. Arras

    Member Arras ★02

    Joined:
    Sep 14, 2010
    Messages:
    5,714
    Location:
    The Netherlands
    Country:
    Netherlands
    That yellow error in the picture looks like a normal non-fatal warning. You should be able to ignore that. The error below that, however, seems to be a fatal one. Can you post another screenshot with the contents of that error message? (the qrc_resources.cpp Error 1)
     

Share This Page