How can I make my games run as smooth as my laptop when it's connected to my charger

Discussion in 'Computer Programming, Emulation, and Game Modding' started by Feras2002, Jun 6, 2016.

  1. Feras2002
    OP

    Feras2002 GBAtemp Regular

    Member
    141
    14
    Jan 13, 2016
    United States
    deez nuts
    When I plug my charger to my laptop the game runs so smooth but I want it to run on battery as smooth as the laptop connected to my charger

    My laptops species
    Intel I7 2.4
    Win 8.1 64-bit
    Amd r9 4GB dedicated
    16GB ram DDR3
     
  2. Luglige

    Luglige hiatus

    Member
    1,409
    1,520
    Jan 24, 2016
    Antarctica
    under your bed
    Get a new battery and post this in computer section next time.
     
  3. Feras2002
    OP

    Feras2002 GBAtemp Regular

    Member
    141
    14
    Jan 13, 2016
    United States
    deez nuts
    i bught this laptop since 2 weeks
     
  4. Luglige

    Luglige hiatus

    Member
    1,409
    1,520
    Jan 24, 2016
    Antarctica
    under your bed
    It could be defective, you should've built it yourself.
     
  5. MarcusD

    MarcusD nobody's hero

    Member
    1,171
    2,300
    Oct 16, 2015
    Hungary
    a pixel between life and death
    Try this out:
    Rightclick on the battery icon on the taskbar -> energy control center (or something like this, my windoze is not English)
    Click on "show more shemes"
    Select "performance-centric"

    Btw, I made a custom energy profile, but it should do the same :P

    Image

    Edit: ninja'd everyone :P :ninja:
     
    Last edited by MarcusD, Jun 6, 2016
    Subtle Demise likes this.
  6. Apextreme

    Apextreme Member

    Newcomer
    27
    9
    Sep 12, 2009
    Cote d'Ivoire
    Those are good specs. If the Laptop isnt performing as well as when it is connected, it might be because of your energy options.

    Go to Power options in Control Panel, and then further into advanced options of the energy plan you are using (typically High perfomance or Ballanced).

    Here adjust the processor max power to 100%, even when on battery. That shoudl do the trick.

    Also, if your laptop has any energy consumption friendly software, disable it or unninstall. That way, the laptop will always consume max power, thus giving more performance.

    Tell me how it goes. Cheers.
     
  7. Depravo

    Depravo KALSARIKÄNNIT

    Global Moderator
    GBAtemp Patron
    Depravo is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    5,235
    3,474
    Oct 13, 2008
    Purgatory
    Possibly some kind of battery saving mode activates when not connected to the mains.
     
    Subtle Demise, DrCrygor07 and migles like this.
  8. Luglige

    Luglige hiatus

    Member
    1,409
    1,520
    Jan 24, 2016
    Antarctica
    under your bed
    God I was wrong xD
     
    MarcusD likes this.
  9. migles

    migles Mei the sexiest bae

    Member
    GBAtemp Patron
    migles is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    6,814
    4,569
    Sep 19, 2013
    Saint Kitts and Nevis
    my dad works for nintendo.
    possibly?
    most likely...

    i am pretty sure it's the power save thing on options...
    @Feras2002 do as @MarcusD said, go into power options, select maximum performance, if that doesn't do much, go into settings and edit the profile..
    you can google how to go or change power settings..
     
    MarcusD likes this.