Hourglass9 Health and Safety Dump and Inject Failed, Help!

Discussion in '3DS - Flashcards & Custom Firmwares' started by 2xlogic, Nov 6, 2016.

  1. 2xlogic
    OP

    2xlogic Member

    Newcomer
    17
    0
    Nov 6, 2016
    United States
    Hi, I am currently working on installing Arm9loaderhax and Luma CFW by following this guide: https://plailect.github.io/Guide/installing-arm9loaderhax I accidentally did the health and safety dump before restoring my nandmin.nin and then updating. After updating, starting hourglass9, and then trying to dump and inject health and safety, they both fail with the error APP0 not found or fragmented! Please help, thanks.
     


  2. Altairseven

    Altairseven GBAtemp Regular

    Member
    124
    29
    Jan 21, 2016
    Argentina
    well.. i fragmentation of nand is a real issue. Thankfully nothing bad happen while installing a9lh.

    the whole failing to dump and inject H&S happened to me once, witha old non xl 3ds, the only way i managed to get arround it, it was because i had my old gateway cart, opened sysnand with gateway, installed fbi with using the .3ds version of fbi and delete the system title of the h&S app and reinstalled it from the 9.2 downgrade cia update, and after that hourglass9 could dump it successfully.

    I do realize that not everyone has a gateway cart available, and i hope that there is another way to fix this, but i got no idea.
     
  3. Quantumcat

    Quantumcat Dead and alive

    Member
    9,866
    5,180
    Nov 23, 2014
    Australia
    Canberra, Australia
    You can use homebrew FBI.3dsx to install FBI.cia. If you are on 9.0-9.2 it is easy, if you are on less you will need to find a way to update. If you have a cart homebrew entry point and a way to install it you can update with a cart and use the cart entry point to get homebrew (since cart updates do not include the browser). If not, you'll have to use freeway browser to get a basic CFW that will allow you to use sysupdater to update to a full 9.2 (the old version of the guide had this).

    This is all assuming you don't get anywhere with the troubleshooting section of the guide.
     
  4. 2xlogic
    OP

    2xlogic Member

    Newcomer
    17
    0
    Nov 6, 2016
    United States
    I do happen to have a gateway, after the update I'm on the most recent irmware, can I still do what you did? If so could you explain a little more in detail?
     
  5. Quantumcat

    Quantumcat Dead and alive

    Member
    9,866
    5,180
    Nov 23, 2014
    Australia
    Canberra, Australia
    Get any cia installer (eg bigbluemenu, devMenu, FBI) in .3ds format, put it in your Gateway's SD card, and use it to install FBI.cia.
     
  6. 2xlogic
    OP

    2xlogic Member

    Newcomer
    17
    0
    Nov 6, 2016
    United States
    Ok, but I no longer have gateway setup, so I should set it up again? If I do need to then how would I access gateway through luma cfw?
     
    Last edited by 2xlogic, Nov 7, 2016
  7. Quantumcat

    Quantumcat Dead and alive

    Member
    9,866
    5,180
    Nov 23, 2014
    Australia
    Canberra, Australia
    If your sysNAND is still on 9.0-9.2 you can use Gateway through homebrew (with Gateway.3dsx). If you want to use it in a more permanent way (or if you already updated sysNAND) then there is a post about using Gateway with v2 a9lh.
     
  8. Altairseven

    Altairseven GBAtemp Regular

    Member
    124
    29
    Jan 21, 2016
    Argentina
    there was a tutorial around of how yo run gateway on v2 a9lh, gonna search for it, it should help you to boot into gateway mode.

    — Posts automatically merged - Please don't double post! —

    Here it is!!!!
     
  9. 2xlogic
    OP

    2xlogic Member

    Newcomer
    17
    0
    Nov 6, 2016
    United States
    Thanks guys I got it to work :)
     
    Last edited by 2xlogic, Nov 7, 2016
  10. 2xlogic
    OP

    2xlogic Member

    Newcomer
    17
    0
    Nov 6, 2016
    United States
    Ok so I got FBI on emunand, how would I install the FBI to systemnand or would that only be possible if the injector worked?
     
  11. achuk

    achuk Member

    Newcomer
    32
    9
    Oct 3, 2016
    I once had issues like this so I just restored my nand backup I took during the plailect guide and redid the h&s steps. Worked a charm so that's another option
     
  12. 2xlogic
    OP

    2xlogic Member

    Newcomer
    17
    0
    Nov 6, 2016
    United States
    Did this now I get a black screen when trying to load into systemnand... hourglass and luma still works. Seems like you fucked me...
     
    Last edited by 2xlogic, Nov 7, 2016
  13. 2xlogic
    OP

    2xlogic Member

    Newcomer
    17
    0
    Nov 6, 2016
    United States
    I'm getting a blackscreen on systemnand after doing what achuk said, but gateway emunand still works, anyway to fix systemnand or is it fucked.
     
  14. sillyrabbit221

    sillyrabbit221 Newbie

    Newcomer
    9
    3
    Apr 28, 2012
    United States
    I followed this guide when I had blackscreen using luma, it worked 100% for me

    https://github.com/AuroraWright/Luma3DS/wiki/FAQ-and-Troubleshooting

    Grandted this is if your issue is an SvcBreak, which mine was
     
    Last edited by sillyrabbit221, Nov 7, 2016
  15. 2xlogic
    OP

    2xlogic Member

    Newcomer
    17
    0
    Nov 6, 2016
    United States
  16. Gow supremo

    Gow supremo I am playing my 2ds

    Member
    240
    12
    Jan 24, 2016
    Spain
    In the earth
    You have rxtools in that console? but inject emunand with rxtools to sysnand the hs.app is duplicate in sysnand memory.
     
  17. 2xlogic
    OP

    2xlogic Member

    Newcomer
    17
    0
    Nov 6, 2016
    United States
    I dont quite get what you are saying, sorry.
     
  18. Gow supremo

    Gow supremo I am playing my 2ds

    Member
    240
    12
    Jan 24, 2016
    Spain
    In the earth
  19. Quantumcat

    Quantumcat Dead and alive

    Member
    9,866
    5,180
    Nov 23, 2014
    Australia
    Canberra, Australia
  20. achuk

    achuk Member

    Newcomer
    32
    9
    Oct 3, 2016
    Hey dude don't get salty, I simply told you I'd done that with my n3ds and it worked for me.

    It clearly sounds like you got yourself in a mess because you didn't follow instructions correctly in the first place which is no one's fault but your own.

    Regardless I hope you get it sorted. As you have an intact nand backup worst comes to worst you can hard mod repair if you fuck it up massively so you have options.