Homebrew Emulators Freez & Crash After Going to 4.2U From 4.0U

Discussion in 'Wii - Hacking' started by wingzrow, Feb 21, 2011.

  1. wingzrow
    OP

    Member wingzrow GBAtemp Regular

    Joined:
    Oct 14, 2008
    Messages:
    256
    Country:
    United States
    Just as described. I followed this guide & made my wii up to date with everything in the guide. Now every time I load up FCEUX or SNESX9, the emulators either freeze, or give me a RET error & black screen.

    Guide I followed was the sticky here.

    http://gbatemp.net/index.php?showtopic=171...t=0&start=0

    Does anyone know what could be causing this? They worked fine before I did the safe 4.2 update.
     
  2. Lacius

    Member Lacius GBAtemp Psycho!

    Joined:
    May 11, 2008
    Messages:
    3,912
    Location:
    St. Louis, Missouri
    Country:
    United States
    There is no reason why they shouldn't work. Are you using the latest version of FCE Ultra GX (3.2.3) and Snes9x GX (4.2.5)? Do you have the latest version of the Homebrew Channel installed (1.0.8)? Do you have IOS58 installed? Is your Homebrew Channel running with IOS58? Run sysCheck and paste the results here.
     
  3. wingzrow
    OP

    Member wingzrow GBAtemp Regular

    Joined:
    Oct 14, 2008
    Messages:
    256
    Country:
    United States
    How would I copy it? I can type it out by hand if you guys want. I have system check and am familiar with it.
     
  4. wingzrow
    OP

    Member wingzrow GBAtemp Regular

    Joined:
    Oct 14, 2008
    Messages:
    256
    Country:
    United States
    HOMEBREW CHANNEL: 1.0.8
    IOS58 v24.31

    Both emulators are the current versions




    sysCheck v2.0.1 by Double_A
    ...runs on IOS58 (rev 6175).

    Region: NTSC-U
    System Menu 4.2U (v481)
    Hollywood v0x11
    Console ID: ( secret )
    Boot2 v4

    Found 103 titles.
    Found 45 IOS on this console. 2 of them are stub.

    IOS4 (rev 3): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS9 (rev 1034): No Patches
    IOS11 (rev 10): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS12 (rev 526): No Patches
    IOS13 (rev 1032): No Patches
    IOS14 (rev 1032): No Patches
    IOS15 (rev 1032): No Patches
    IOS16 (rev 257): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS17 (rev 1032): No Patches
    IOS20 (rev 12): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS21 (rev 1039): No Patches
    IOS22 (rev 1294): No Patches
    IOS28 (rev 1807): No Patches
    IOS30 (rev 1040): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS31 (rev 3608): No Patches
    IOS33 (rev 3608): No Patches
    IOS34 (rev 3608): No Patches
    IOS35 (rev 3608): No Patches
    IOS36 (rev 3608): No Patches
    IOS37 (rev 5663): No Patches
    IOS38 (rev 4124): No Patches
    IOS41 (rev 3607): No Patches
    IOS43 (rev 3607): No Patches
    IOS45 (rev 3607): No Patches
    IOS46 (rev 3607): No Patches
    IOS48 (rev 4124): No Patches
    IOS50 (rev 5120): Stub
    IOS51 (rev 4864): Stub
    IOS53 (rev 5663): No Patches
    IOS55 (rev 5663): No Patches
    IOS56 (rev 5662): No Patches
    IOS57 (rev 5919): No Patches
    IOS58 (rev 6175): No Patches
    IOS60 (rev 6174): Trucha Bug
    IOS61 (rev 5662): No Patches
    IOS70 (rev 6687): Trucha Bug, NAND Access
    IOS80 (rev 6944): No Patches
    IOS202 (rev 65535): Trucha Bug, NAND Access, USB 2.0
    IOS222 (rev 65535): Trucha Bug, ES Identify, NAND Access, USB 2.0
    IOS223 (rev 65535): Trucha Bug, NAND Access, USB 2.0
    IOS224 (rev 65535): Trucha Bug, NAND Access, USB 2.0
    IOS236 (rev 65535): Trucha Bug, ES Identify, NAND Access
    IOS249 (rev 21): Trucha Bug, NAND Access, USB 2.0
    IOS250 (rev 65535): Trucha Bug, NAND Access, USB 2.0
    IOS254 (rev 65281): BootMii
    BC v2
    MIOS v5

    Report generated on 2011/02/20.
     
  5. Tantric

    Member Tantric GBAtemp Regular

    Joined:
    Feb 8, 2007
    Messages:
    185
    Country:
    Canada
    I would bet you don't have net enabled on your Wii. Try removing the no_ios_reload line from the meta.xml. There's an HBC bug that causes the crash you're describing.
     
  6. wingzrow
    OP

    Member wingzrow GBAtemp Regular

    Joined:
    Oct 14, 2008
    Messages:
    256
    Country:
    United States
    Net enabled? You mean the internet? I have an Ethernet adapter if that's what you're talking about.

    Where would I find meta.xml? Could you guide me through this?
     
  7. Lacius

    Member Lacius GBAtemp Psycho!

    Joined:
    May 11, 2008
    Messages:
    3,912
    Location:
    St. Louis, Missouri
    Country:
    United States
    When you use sysCheck, it outputs a file to your SD card. You can then copy and paste the contents of that file here. Are you sure your sysCheck is current? Try using the version I linked to you (2.1.0 beta5) if the advice below does not help.

    After doing some research, I noticed that some people claim to have gotten these to work when they otherwise wouldn't by being connected to the internet. Also, are you using a forwarder channel? If so, that might be your problem. If I were you, I would also try deleting the emulators off your SD card and re-downloading them, backing up any games or saves of course.

    If you still cannot get it to work, try previous versions of the emulators. You're bound to find one that works as you go down the list.
     
  8. wingzrow
    OP

    Member wingzrow GBAtemp Regular

    Joined:
    Oct 14, 2008
    Messages:
    256
    Country:
    United States
    Alright, I just switched back and forth between having my ethernet adapter connected and they DO infact work when I am connected to the internet. HOWEVER, this is a huge inconvenience for me. Could someone guide me through what I need to do to fix this bug?
     
  9. wingzrow
    OP

    Member wingzrow GBAtemp Regular

    Joined:
    Oct 14, 2008
    Messages:
    256
    Country:
    United States
    Success!

    I found the meta.xml ( it was in the app folder ) and removed it and the nintendo emulator works perfectly now. I cannot thank the kind people on GBtemp ENOUGH. Someone should notify the creators of these apps about this error though. It's a huge oversight on their part.
     
  10. Taleweaver

    Member Taleweaver Storywriter

    Joined:
    Dec 23, 2009
    Messages:
    5,125
    Location:
    Belgium
    Country:
    Belgium
    *cough*

    Tantric is the creator of FCEUX and SNES9Xgx, so...I think he already knows about it. [​IMG]
     
  11. wingzrow
    OP

    Member wingzrow GBAtemp Regular

    Joined:
    Oct 14, 2008
    Messages:
    256
    Country:
    United States
    Hah, I knew I heard that name somewhere before.

    Thanks for the emulator tantric.
     
  12. Jacobeian

    Member Jacobeian GBAtemp Advanced Maniac

    Joined:
    May 15, 2008
    Messages:
    1,879
    Country:
    Cuba
    and as he said to you a few post above, the bug is in homebrew channel, not the apps
     

Share This Page