1. GFam

    OP GFam Newbie
    Newcomer

    Joined:
    Feb 22, 2019
    Messages:
    4
    Country:
    Canada
    Info:
    System is a WiiU accessing the Wii Menu
    I used the SmashStack method to put it all together.
    - //bootmii.org/download/
    - //wiibrew.org/wiki/Smash_Stack
    My Homebrew Channel and Homebrew Browser work just fine.
    - Ive changed the setting_server from 0 to 1.
    My Channel Installers report Wii has IOS: 58
    - Snes9xGX
    - FCEUltraGX
    - VBAGX

    SD card root looks like this:
    \apps
    \apps\homebrew_browser
    \apps\fceugx
    \apps\snes9xgx
    \apps\vbagx
    \fceugx
    \snes9xgx
    \vbagx

    I am able to manually put the emulators on the SD card, and the Homebrew Browser Lists them for me. Conversely, Im able to use the Homebrew Browser to select and download the emulators I want, and that works fine.
    I am able to pick those 3 Channels from the Homebrew Browser and they install. They also display on my Wii menu afterwards.
    When I launch the emulators from within the Homebrew Browser they work. Load the games I want and they play.

    Problem
    When I try to use the channels in Wii, I click the channel, press "Start" in the Wii menu, then it goes to a black screen, the Wiimote turns off, and the WiiU system becomes unresponsive. You cant power off the WiiU using the front power button (hold for 10 seconds for example), have to remove the power plug from the back of the unit. The channel doesnt load the emulator and totally locks up the Wii. Each one of these emulator channel loaders dont work for me right now: FCEUltraGX, Snes9xGX, VBGAGX. They all create the same "freeze lock" problem.

    Ive checked the readme files to make sure the path on the SD card for the boot.dol is where they want it to be. I have tried to uninstall and reinstall both the emulator and the channel. Thru the Homebrew Browser I "installed" emulator first, then ran the channel install. I verified my versions, my paths. etc. I brainstormed what I could and tried what I could to resolve it.

    There's obviously some piece I'm missing since all 3 of these freeze with the same problem, but the other stuff works. I really dont know what else to look at to resolve this, so Im hoping someone might know or observed it in the past. Ive included pics to show information for versions, whatever else I thought would help. I would really like the convenience of being able to use the Wii menu, it such a polished feature, so great. And from what I understand the channels allow the emulators to be played "offline" which would be a great contingency.

    Thanks in advance.
     

    Attached Files:

  2. fledge68

    fledge68 GBAtemp Advanced Maniac
    Member

    Joined:
    Jan 30, 2012
    Messages:
    1,789
    Country:
    United States
    You have to use vwii forwarder channels. Normal wii forwarder channels do not work on wiiu vwii.
     
  3. GFam

    OP GFam Newbie
    Newcomer

    Joined:
    Feb 22, 2019
    Messages:
    4
    Country:
    Canada
    Hey thanks for the quick reply. Once you told me I needed a different kind of loader I was able to move ahead. I had seen mentions of *.wad files when I was looking around before, but I didnt make the connection. I wouldnt have figured that out, thank you.

    Resolution
    After I knew I needed to get vWii loaders when trying to set up a WiiU accessing the Wii menu, I was able to search. I found instructions and followed CJB100 instructions here:
    gbatemp.net/threads/the-definitive-vwii-hacking-guide.425852/#33

    I got the 3 wad files from the suggested links in the "Link to some great forwarded channels" in this same document.
    Got what I wanted for the nes, snes, and gameboy loaders.
    Made a folder called WAD put them in there.
    Downloaded "Yet another wad manager mod" and put it on the SD card as listed by the instructions.
    From there I was able to load the homebrew channel, use the YAWMM to install the 3 vWii Channels.

    I tested them out and all works now without a problem. It's really great having the opportunity to load these from the Wii menu itself.
     
    fledge68 likes this.
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Homebrew, Emulator, Channels