Homebrew Channel doesn't see my hard drive

Discussion in 'Wii - Hacking' started by dwmyke, Jan 21, 2010.

Jan 21, 2010
  1. dwmyke
    OP

    Newcomer dwmyke Member

    Joined:
    Oct 5, 2009
    Messages:
    26
    Country:
    United States
    Hey, I've got an interesting problem. The homebrew channel doesn't see my usb hard drive. It won't let me select "usb device." The drive has an active fat32 partition and a wbfs partition. USBLoader GX plays games fine from the wbfs part. There's a triiforce mod that reads images from the fat32 part.. I copied everything from my sd card to the hard drive exactly. I'm not sure if I'm missing something, or what. Can anybody help?
     
  2. giantpune

    Member giantpune GBAtemp Addict

    Joined:
    Apr 10, 2009
    Messages:
    2,860
    Country:
    United States
    did you mark the FAT partition active and then mark the wbfs one active? that would mess it up.

    what if you start HBC with no sd card inserted? does it still not see the usb drive?
     
  3. dwmyke
    OP

    Newcomer dwmyke Member

    Joined:
    Oct 5, 2009
    Messages:
    26
    Country:
    United States
    No, WBFS isn't active. Homebrew channel just has bubbles if I take out the sd card. Also ftpii and wiibrowser won't recognize the drive.. I'm not sure why some things see it and others don't.
     
  4. blitzer320

    Member blitzer320 GBAtemp Fan

    Joined:
    Sep 29, 2008
    Messages:
    370
    Location:
    NYC
    Country:
    United States
    do you have the sd card in cause i think if it sees the sd card itll ignore the usb
     
  5. jceggbert5

    Member jceggbert5 Check out my hack, New Retro Mario Bros.

    Joined:
    Dec 1, 2008
    Messages:
    989
    Location:
    USA, Earth, MilkyWay
    Country:
    United States
    ...
     
  6. dwmyke
    OP

    Newcomer dwmyke Member

    Joined:
    Oct 5, 2009
    Messages:
    26
    Country:
    United States
    Still won't see it if I take out the sd card. [​IMG]
     
  7. nitrostemp

    Member nitrostemp GBAtemp Maniac

    Joined:
    Mar 15, 2009
    Messages:
    1,265
    Country:
    Australia
    did you bring up the homebrew channel menu and switch to usb?
     
  8. dwmyke
    OP

    Newcomer dwmyke Member

    Joined:
    Oct 5, 2009
    Messages:
    26
    Country:
    United States
    It won't allow me to select it. :/
     
  9. nitrostemp

    Member nitrostemp GBAtemp Maniac

    Joined:
    Mar 15, 2009
    Messages:
    1,265
    Country:
    Australia
    sounds like its time to delete all partitions and retry
     
  10. dwmyke
    OP

    Newcomer dwmyke Member

    Joined:
    Oct 5, 2009
    Messages:
    26
    Country:
    United States
    Yeah... I'll leave that as a last resort. Hopefully there is some simple (or I'd even take complicated) thing I'm missing.
     
  11. blitzer320

    Member blitzer320 GBAtemp Fan

    Joined:
    Sep 29, 2008
    Messages:
    370
    Location:
    NYC
    Country:
    United States
    did you format it in windows
     
  12. DunkrWunkah

    Member DunkrWunkah GBAtemp's Official Dunkr

    Joined:
    Nov 21, 2008
    Messages:
    582
    Country:
    United States
    Make sure that your USB drive is connected to the Correct USB port on the back of your Wii. The correct port to connect to is the one that is closer to the ground when you lie the Wii on its side. Hope this helps! [​IMG]

    I don't know why, but my USB devices seem to work only when I use that port. :\
     
  13. smf

    Member smf GBAtemp Advanced Fan

    Joined:
    Feb 23, 2009
    Messages:
    839
    Country:
    United Kingdom
    Thats only when using backup loaders, homebrew channel will use either port.
     
  14. linuxares

    Member linuxares GBAtemp Maniac

    Joined:
    Aug 5, 2007
    Messages:
    1,387
    Country:
    Sweden
    Format it in RAW, that works the best =)
     
  15. dwmyke
    OP

    Newcomer dwmyke Member

    Joined:
    Oct 5, 2009
    Messages:
    26
    Country:
    United States
    The only thing I can think of is that the drive is using a split usb cable-- a 2 in 1 thing that uses data and power. USBloader GX needs it to be plugged in a certain way for it to see the drive. Of course I tried swapping the way it's plugged to see if the homebrew channel would see it that way.. But no dice. Nothing would see it that way. I suppose I'll have to get one of those usb to wall adapters..
     
  16. smf

    Member smf GBAtemp Advanced Fan

    Joined:
    Feb 23, 2009
    Messages:
    839
    Country:
    United Kingdom
    Power & data y cables are not a problem, HBC doesn't care which usb port you are plugged into. I've run with a FAT32 in one slot and an NTFS in the other (HBC only sees the FAT32 one), it freaked usbloader gx out though.

    It might be ios dependant. If you press home it should tell you which ios it's using, if you reinstall then it might pick a different one (I had to do this when I installed the latest before updating). You might get lucky. CIOS 222/249 both have different compatibility to each other and to Nintendos IOS. There are some drives that won't work with HBC but will work with usb loaders.

    It could be the partitions, I only have a single fat32 partition for everything and HBC works ok with that (no matter which port). The order of the partitions can be a problem for some applications, a single FAT32 partition is alot less hassle.
     
  17. dwmyke
    OP

    Newcomer dwmyke Member

    Joined:
    Oct 5, 2009
    Messages:
    26
    Country:
    United States
    Cool. I'll try reinstalling hbc and moving everything to a single fat32 partition. Will post results. Thanks!
     
  18. dwmyke
    OP

    Newcomer dwmyke Member

    Joined:
    Oct 5, 2009
    Messages:
    26
    Country:
    United States
    Ok, well.. it appears to be the ios. HBC is only using ios 61 (??) for some reason. It doesn't matter how many times I reinstall. I really wish I could just pick which one to use. Oh well, maybe some time in the future that'll be an option. I'll just have to run homebrew from the sd card for now. Not that big of a deal, I suppose.
     

Share This Page