Homebrew Channel and MFE-Wii

Discussion in 'Wii - Hacking' started by redmozzie, May 25, 2008.

  1. redmozzie
    OP

    redmozzie Newbie

    Newcomer
    7
    0
    Sep 24, 2007
    United States
    In the HBC package thread, teonintyfive posted:

    I didn't want to clog up that thread, so I'll post my question here:

    Has anyone got MFE-Wii to work with the new Homebrew Channel? It runs perfectly when the elf is in the root, but both the Homebrew Loader and the Homebrew Channel cause it to freeze about 30 seconds into playback, and the common denominator is that they store the elf in a subdirectory.

    Am I missing something obvious?
     
  2. thepspgamer

    thepspgamer Advanced Member

    Newcomer
    70
    0
    Jul 30, 2007
    The Depths of Hell!
    i have heard of this bug, at the moment i dont think it works properly using the homebrew channel, so for the time being, we will have to do without it, which is a shame, as this is an awesome piece of homebrew
     
  3. redmozzie
    OP

    redmozzie Newbie

    Newcomer
    7
    0
    Sep 24, 2007
    United States
    Hmm. In that case, is it possible to install both the official Homebrew Channel and the old Hombrew Channel (No Limit)? They seem to use the same ID so they save over each other. If I can install them both I can use the old No Limit one to load MFE-Wii (from the root), and the new channel for everything else (from /apps/).
     
  4. WiiCrazy

    WiiCrazy Be water my friend!

    Member
    2,391
    1
    May 8, 2008
    Istanbul
    The problem is not related to mfe being in the root or in a subdirectory. It was failing with the earlier homebrew channel too. It runs fine when launched directly by TP hack though, but I don't know the reason why.
     
  5. jan777

    jan777 motion control..? srsly? so 2008. 3DS is teh bombz

    Member
    2,829
    36
    Jan 4, 2008
    i just watched naruto movie 2 perfectly using the new channel
     
  6. ganons

    ganons GBAtemp Addict

    Member
    2,166
    20
    Jun 12, 2005
    what did u watch narto with (bushy brows, lol) and what format was it?
     
  7. samsam12

    samsam12 Test

    Banned
    818
    0
    May 13, 2008
    United States
    A House
    i watched a episode of the angry video game nerd, about 9 minutes, .mov format, with the new homebrew channel. it worked fine.
     
  8. Linguist

    Linguist Member

    Newcomer
    18
    0
    May 14, 2008
    Gambia, The
    hm, no problem here, it's working for me with some example files (mov, avi, mpg) without glitches.
     
  9. teonintyfive

    teonintyfive GBAtemp Advanced Fan

    Member
    791
    0
    Oct 20, 2006
    Greece
    Greece, Somewhere in Macedonia
    It worked perfectly for me.
    If you just can't get it to work, wait for Wii Miidia, which will be hundreds of times better.
     
  10. SpaceJump

    SpaceJump Where's my new 2D-Metroid?

    Member
    3,672
    213
    Aug 18, 2005
    Gambia, The
    Zebes
    It crashes for me too when booted through either the new HBC, the old HBC or HBLauncher.

    My hopes lie on Wii Miidia because this problem persists for weeks and no update has shown up yet.

    Edit: Did anyone try to make a MFE-channel to see if that doesn't crash?
     
  11. jinxvorheeze

    jinxvorheeze GBAtemp Advanced Fan

    Member
    572
    0
    May 13, 2008
    United States
    I believe WiiMiidia will be based around the same MFE Distro. The problem isn't with the MFE, if you run it off of Twilight hack, then it runs perfect. It must have something to do with the Wii itself. Maybe running the HBC (old or new) causes too much of the system memory to be used and it doesn't allow the MFE to properly buffer the video. Just in theory of course, so don't flame me for not knowing exactly how the program works. If I knew that, I would have already tried to fix it since it's an open-source project. Smaller video files don't freeze because they require less to buffer.
     
  12. ganons

    ganons GBAtemp Addict

    Member
    2,166
    20
    Jun 12, 2005
    hmm i might try this, so every1 still think wiimiidia is gonna be released.........
     
  13. teq

    teq GBAtemp Maniac

    Member
    1,232
    0
    May 13, 2008
    United States
    Well, you're close, but it's actually problematic for a couple reasons:

    As you mentioned, one problem is bad memory management. When the MFE is launched from the Twilight hack, there is no MEM2 reservation. Apparently, when the Homebrew channel(or any of its clones) loads, doesn't flush the memory when it starts an ELF.


    Secondly, the MFE has an issue with long file names. Sometimes shortening the name to one word fixes it entirely.
     
  14. cobain76

    cobain76 Member

    Newcomer
    19
    0
    Nov 15, 2006
    I think this is not completely true, since the first time I've used the hombrew channel (old) to load MFE. I've seen lots of TV series chapters (from 20 to 50 minutes) and full movies (1 hour and half),including dovx, mov, FLV and haven't had problems.

     
  15. redmozzie
    OP

    redmozzie Newbie

    Newcomer
    7
    0
    Sep 24, 2007
    United States
    Thanks, teq.

    Well, that brings me back to square one. Is there some way to edit the "Homebrew Channel (No Limits)" wad to alter the ticket ID so that it is installed in a different slot?
     
  16. jan777

    jan777 motion control..? srsly? so 2008. 3DS is teh bombz

    Member
    2,829
    36
    Jan 4, 2008
    i watched the movie 2 700mb avi format
     
  17. Venko

    Venko GBAtemp Regular

    Member
    159
    1
    Feb 16, 2007
    England
    So how does your set-up vary from ours? [​IMG]
     
  18. WiiCrazy

    WiiCrazy Be water my friend!

    Member
    2,391
    1
    May 8, 2008
    Istanbul
    Well I tested again using HBC with no luck. Even tested using the tcp loading mechanism. It just freezes at the exact places in videos I tried. No name issues, no codec issues and such. It's either related to inner workings of mfe or hbc.
     
  19. jan777

    jan777 motion control..? srsly? so 2008. 3DS is teh bombz

    Member
    2,829
    36
    Jan 4, 2008
    i dont know i just have this

    x:\apps\boot.elf
    x:\mfe\mfe.(somthing)