Homebrew Browser: "This is not a valid Wii app"

Discussion in 'Wii - Hacking' started by Outsider506, Nov 1, 2008.

  1. Outsider506
    OP

    Newcomer Outsider506 Member

    Joined:
    Oct 22, 2008
    Messages:
    39
    Country:
    Canada
    Went to the Homebrew Browser tonight and I'm getting an error message saying "This is not a valid Wii application". I get the same error message when I try to launch Gecko OS. I haven't updated the firmware on the Wii in ages. I'm somewhat of a noob to this so I'm not sure what to do next. I was thinking of trying to do it all over again from scratch, but my MPlayer Wii still launches.

    To clarify I have been using Gecko OS and the Homebrew Browser with no problems up to today. I do think the last time I went into the Browser though it asked me if I wanted to update and I did. That wouldn't be it would it?
     
  2. djdynamite123

    Banned djdynamite123 Master Of Hardcore!

    Joined:
    Sep 21, 2008
    Messages:
    3,791
    Location:
    Redcar, England UK
    Country:
    United Kingdom
    its the new hbc9 doesnt support old ELF files nomore, only supports sane elfs ie GEEXBOX, you will have to convert all your elfs to dol, there are many exe files that do it for you check wiibrew, also dont edit geexbox, if you mess with that turning it into a dol, it will not work!
     
  3. ComplicatioN

    Member ComplicatioN Broken Barriers

    Joined:
    Aug 23, 2008
    Messages:
    844
    Location:
    Thousand Sunny
    Country:
    Australia
    convert them to dol files
     
  4. djdynamite123

    Banned djdynamite123 Master Of Hardcore!

    Joined:
    Sep 21, 2008
    Messages:
    3,791
    Location:
    Redcar, England UK
    Country:
    United Kingdom
    already mentioned above
     
  5. Outsider506
    OP

    Newcomer Outsider506 Member

    Joined:
    Oct 22, 2008
    Messages:
    39
    Country:
    Canada
    Thanks for the quick reply guys. I'm relieved to say the least... my first reaction to that error message was "How the fuck did Nintendo update my Wii?!" LOL
     
  6. GhostSonic

    Member GhostSonic GBAtemp Regular

    Joined:
    Oct 12, 2008
    Messages:
    188
    Country:
    United States
    You can use this to automatically convert all the elf files in your apps folder. You should back them up first, though.
     
  7. Outsider506
    OP

    Newcomer Outsider506 Member

    Joined:
    Oct 22, 2008
    Messages:
    39
    Country:
    Canada
    Wow thanks. The quick help here is crazy.

    I got another problem. I just walked a guy through installing the Homebrew Channel on his system (no updates) and then Gecko OS. When he tries to load a game through Gecko OS it just stays on "Launching Game" forever. Does that sound like a problem with his Wii/Modchip? He can load other games just fine... just not recent ones like Wii Music and GHWT, hence why he's trying to use Gecko OS.
     
  8. GhostSonic

    Member GhostSonic GBAtemp Regular

    Joined:
    Oct 12, 2008
    Messages:
    188
    Country:
    United States
    Maybe it requires an update or something.
     
  9. DarK_HumOuR

    Newcomer DarK_HumOuR Member

    Joined:
    Aug 1, 2008
    Messages:
    20
    Location:
    Thessaloniki
    Country:
    Greece
    excuse me.
    just a simple question.

    i make all the steps included in the readme file..
    i put the two files in my apps folder.. i run the bat file.. it says "press any key to continue.."
    i press enter and nothing happens..
    the application closes.. [​IMG]
    what goes wrong?

    i have 3.2European an i accidentally update my HBC before i convert my elf files..

    ps sorry for my bad English.. [​IMG]
     
  10. killplaystation

    Member killplaystation GBAtemp Fan

    Joined:
    May 23, 2008
    Messages:
    467
    Country:
    United States
    If you have a TV on in the room, it can cause the conversion process to be skipped and the window will just close. Just shut off any tv in the room. If it still happens, shut off any other tvs in the house
     
  11. DarK_HumOuR

    Newcomer DarK_HumOuR Member

    Joined:
    Aug 1, 2008
    Messages:
    20
    Location:
    Thessaloniki
    Country:
    Greece
    lol!

    any serious answer pls!?
     
  12. DaveMode

    Newcomer DaveMode Advanced Member

    Joined:
    Oct 29, 2007
    Messages:
    72
    Country:
    United States

    Hey I had the same problem with the one linked above, the script is bad. Use this one and it should work:

    http://wiibrew.org/w/images/e/ef/ELF-DOL_C...ter_windows.rar
     
  13. AetherMaster

    Member AetherMaster Aether

    Joined:
    Sep 8, 2007
    Messages:
    168
    Country:
    United States
    That's the same one linked above. I couldn't get it working either, so I made my own. The link is in my signature and, unlike others, it actually works [​IMG]
     
  14. DarK_HumOuR

    Newcomer DarK_HumOuR Member

    Joined:
    Aug 1, 2008
    Messages:
    20
    Location:
    Thessaloniki
    Country:
    Greece

    nothing yet..

    [​IMG]

    i try all the files..
    always the same error " powerpc-gekko-objcopy.exe has encountered a problem and needs to close."
    something seems to happen with reading of my sd card ..

    any ideas? [​IMG]
     
  15. GhostSonic

    Member GhostSonic GBAtemp Regular

    Joined:
    Oct 12, 2008
    Messages:
    188
    Country:
    United States
    Copy the apps folder to PC

    Run converter

    Copy apps folder back to SD
     
  16. DarK_HumOuR

    Newcomer DarK_HumOuR Member

    Joined:
    Aug 1, 2008
    Messages:
    20
    Location:
    Thessaloniki
    Country:
    Greece
    i tried yesterday but i cant do it..

    when i copy all the apps folder and try to paste it, the process stuck. probably when paste the elf files.
    they dont allow me to do it... [​IMG]

    p.s. also, when i try to rar the apps folder, the winrar stuck.. again at the same point... when zipping elf files..

    [​IMG]


    p.s2
    well
    i tried to backup all the sd card folder and it fails:

    "Backup started on 2/11/2008 at 9:45 ??.
    WARNING: Portions of "\boot.elf" cannot be read. The backed up data is corrupt or incomplete.
    This file will not restore correctly."


    the same warning appears in every elf and dol file when tried to copy from my sd card..

    any ideas?
     
  17. korn16ftl3

    Newcomer korn16ftl3 Member

    Joined:
    Nov 15, 2008
    Messages:
    30
    Country:
    United States
    i dunno what is going on here im trying to use homebrew browser and getting the same msg that its not a valid wii application but i looked in the SD card and its .DOL like you guys say to convert to wii system version 4.2u HBC v 1.0.6 on IOS61 v21.29 what is my issue any one have any ideas?

    EDIT: NVM i had a .elf ase well as the .DOL in the /app/hombrew_browser folder deleted that and all ran fine accept the fact it dosent want to unpack a .zip file or something now i get white lines up and down and some error code on the screen......sigh
     

Share This Page