HOME Menu app icons and badges take longer to load on post-9.0 firmware

Discussion in '3DS - Console, Accessories and Hardware' started by CatmanFan, Jul 7, 2017.

  1. CatmanFan
    OP

    CatmanFan nope

    Member
    1,284
    406
    Aug 14, 2016
    Morocco
    I've been wanting to post this for a few months now, but I realized that apparently it takes a bit longer for the application icons and badges to load on HOME Menu during boot if the 3DS is on firmware 9.0 or newer. These firmwares apparently use a new stylized version of the HOME Menu, similar to the New Xbox Experience or the PS3 3.0 update. On older firmwares, almost all the icons would appear immediately, while the icons of the apps that are on an SD card take a big longer to load. From 9.0, though, the icons do not appear immediately, and the menu would appear empty for a while before all the app icons start popping up one by one from the current location of the selection cursor. The same goes for badges. If you were on a folder, the icons and badges outside of the folder wouldn't load until you exited out of the folder.

    For the information provided above, the same goes if you go to the POWER Menu by pressing the POWER button once before pressing the HOME button to return to the HOME Menu.

    If you do set a language from System Settings and then exit to the HOME Menu, it would remain on a black screen for a bit longer before showing up, and all the icons would appear almost immediately, similar to pre-9.0 firmwares.

    Now, I know this is just something stupid to post on GBAtemp, but I just wanted to share it with you.

    If you don't believe me, here is some YouTube proof.

    Old 3DS with launch firmware (JAP)


    Old 3DS with new firmware (JAP)


    (skip to 0:23 on the top video, and 0:58 on the bottom video)
     
  2. jimmyj

    jimmyj Official founder of altariaism. Copyright jimmyj

    Member
    773
    200
    May 26, 2017
    Italy
    Hyrule
    Intresting, thx for sharing!