HOLY CRAP HAX 2.5 IS OUT!!!

Discussion in '3DS - Homebrew Development and Emulators' started by FM360, Oct 26, 2015.

  1. Megalegacy98

    Megalegacy98 GBAtemp Advanced Fan

    Member
    3
    Aug 11, 2015
    United States
    United States
    This is so frustrating, for some reason HANS doesn't detect my ROMFS even though the first 0x1000 hexadecimal are cut and I put it in the "sd:/hans/" folder with the titleid and the extension .romfs.

    (Btw I'm using Pokemon X, and when i cut it, the first hex number is 28)
     
    Februarysn0w likes this.
  2. hippy dave

    hippy dave BBMB

    Member
    14
    Apr 30, 2012
    United Kingdom
    Btw, HolyCrapHax is the best hack name so far.
     
    KingVamp, Februarysn0w and zoogie like this.
  3. CrystalForce

    CrystalForce I'm gonna "fix" that spaghetti.

    Member
    2
    Feb 10, 2015
    United States
    Geez I haven't been here in a while. I've got a question: Just to be completely sure, this DOES work with Ironhax, correct?
    Edit: Wait... there's eShop spoofing!? Looks like I'm never updating again.
     
    Last edited by CrystalForce, Oct 29, 2015
  4. MassiveRican

    MassiveRican GBATemp's Unofficial Vigilante

    Member
    7
    Aug 2, 2011
    Creeping in the Shadows
    Hey guys quick question since I'm seeing contradicting information. I have an N3DS on 9.9, currently running HB through Ironhax with game version 1.1.

    So question is if I update to 10.2, does Ironhax still work? I ask because clearly on http://smealum.github.io/3ds/ it states that ironhax works through 10.1
    However I see here a few users have stated and gone as far as making a FAQ that says Ironhax works on 10.2, so which is true? I'm one to listen to Smea as he's the dev of course but if users have found a way that is confirmed I'm definitely willing to try it out. I'd like to be able to d/load some DLC I purchased on Smash and I might have to do a System transfer tomorrow if I decide to pick up the N3DS triforce model that comes out. Thanks for any help provided.
     
    Last edited by MassiveRican, Oct 29, 2015
  5. kbmarinha

    kbmarinha Life sucks...

    Member
    5
    May 21, 2009
    Brazil
    Yep it works on 10.2 Im using ironhax and ninjhax. But DO NOT update ironfall. Nintendo has patched it to load homebrew

    — Posts automatically merged - Please don't double post! —

    Yes ironhax will work. You can spoof eshop but sadly there is no way to buy dlc in-game without update your 3ds
     
    Last edited by kbmarinha, Oct 30, 2015
    MassiveRican likes this.
  6. SomeGamer

    SomeGamer GBAtemp Guru

    Member
    13
    Dec 19, 2014
    Antarctica
    You mean IronFall.

    — Posts automatically merged - Please don't double post! —

    Now I only need Theme Shop spoofing! ;)
     
  7. kbmarinha

    kbmarinha Life sucks...

    Member
    5
    May 21, 2009
    Brazil
    Edited. Thanks
     
    SomeGamer likes this.
  8. epicmartin7

    epicmartin7 GBAtemp Fan

    Member
    4
    Aug 5, 2015
    United States
    I know this probably isn't the place for it, but is there anywhere I could find the Ironhax 2.1 download at? I need that so I can re-install the exploit for Ironhax 2.5.
     
  9. fmkid

    fmkid Just another GBATemp's random guy

    Member
    4
    Apr 23, 2015
    Colombia
    ATM, no more IronHax 2.1 possible, because Smealum updated all older 2.1 payloads. Then, now is only possible to install IronHax 2.5.
     
  10. ~Poke~

    ~Poke~ GBAtemp Regular

    Member
    2
    Aug 18, 2015
    The 2.5 boot.3dsx will load fine on 2.1 hax if that's what you're looking for, you just won't be able to use HANS.
     
  11. epicmartin7

    epicmartin7 GBAtemp Fan

    Member
    4
    Aug 5, 2015
    United States
    So... I just tried that and my 3DS gives me the message "An Error Has Occurred". Am I doing anything wrong?

    EDIT: Wait... I might have forgot to update from Ironhax 2.0. I think that might have been patched...
     
  12. kraan

    kraan Advanced Member

    Newcomer
    1
    Dec 12, 2014
    Merowe
    Hi y'all. Glad to see how much progress has been made! Just installed ninjhax 2.5 and trying to get the eshop to load. I keep running into trouble, however. Whenever I try to enter the eshop, it logs me in, gives me a popup. If I accept, the screen blacks out, and if I decline, it asks me to return to the home menu. In both cases, it crashes and forces me to reset the console. Not sure if anyone else has the same problem, it might be my shitty internet.

    Anyone has had the same problem?
     
  13. SomeGamer

    SomeGamer GBAtemp Guru

    Member
    13
    Dec 19, 2014
    Antarctica
    What is written in the popup?
     
  14. kraan

    kraan Advanced Member

    Newcomer
    1
    Dec 12, 2014
    Merowe
    Hmmm, it's a nintendo error code 022-2503 (only noticed that it's an error code now), telling me that I have to agree with Nintendo's Privacy things. After that I get the choice to go to Nintendo network ID options. Cancelling crashes and asks me to return to home menu, agreeing gives me a black screen. Both force me to hard reset.

    I'm currently trying to fix it by accepting them through my console itself (leaving eshop and ninjhax out of it). This might solve the issue, I'll update this post with relevant information if something changes.
     
    Last edited by kraan, Oct 31, 2015
  15. SomeGamer

    SomeGamer GBAtemp Guru

    Member
    13
    Dec 19, 2014
    Antarctica
    Make sure you'be accepted it without HANS, set region in HANS to -- and turn FW spoofing on.
     
    kraan likes this.
  16. kraan

    kraan Advanced Member

    Newcomer
    1
    Dec 12, 2014
    Merowe
    Edit: It worked! Thanks a bunch ;x
     
    Last edited by kraan, Oct 31, 2015
    SomeGamer likes this.
  17. alexman

    alexman Newbie

    Newcomer
    1
    Oct 28, 2015
    Mexico
    I have exactly the same question. Themhax works without this file present, is it safe to delete it permanently?
     
  18. Ammako

    Ammako GBAtemp Guru

    Member
    10
    Dec 22, 2009
    Antarctica
    screenshots_raw.bin is used by *hax 2.5 to store screenshots you take. If you delete it it'll just come back anyway :P
    It isn't related to themehax itself.
     
  19. alexman

    alexman Newbie

    Newcomer
    1
    Oct 28, 2015
    Mexico
    A concrete and clear response, sir! Thank you. :D
     
  20. L4RC

    L4RC Newbie

    Newcomer
    1
    Nov 1, 2015
    United States
    Hi guys! I ran around town all day yesterday trying to find cubic ninja and ocarina of time to do the exploit for homebrew, as i extracted the boot.3dsx file into the root of my SD I was reading the tutorial for Ninja 2.5, it stated that it works with 10.2, so i gave it a go, and as soon as it came to scanning the QR Code in cubic ninja, the game kept crashing and giving me errors, please help me! i wasted so much time and $$ for this to not work, I am running on 10.2.0-28U, i have tried everything and scanned the QR code for my N3DS like 40 times and still no budge :(