help with updating Japanese 3.3J wii, homebrew & backup loader ena

Discussion in 'Wii - Hacking' started by tommitek, Aug 29, 2009.

  1. tommitek
    OP

    Newcomer tommitek Advanced Member

    Joined:
    Aug 17, 2009
    Messages:
    69
    Country:
    Japan
    i have been scouring the net for information regarding japanese wii firmware updating, and all i have found have been warnings attached to 4.0 updaters saying it wont work on japanese wii's. and any other information i find seems to contradict other pieces of info i have found. i havent hacked my wii for a while, and to be honest i am starting to get confused.

    As the title says i have a japanese wii. I live in japan and i bought it here. I buy both Japanese original games here, and also import some games from the US (particullarly rpgs, where understanding the story perfectly is essential to enjoying the game to the max). I have the homebrew channel installed, and also the backup loader channel installed aswell. I did this all just after buying it. Which was about the time the 3.3 firmware fix to be able to install homebrew was released. Since then, i have had no problems playing my japanese original games as per usual, my american import games using region free apps (such as gecko region free 1.5 or menu loader) through the homebrew channel. Also up until recently, i have had only a few problems using the backup loader channel to play backed up copies of my japanese and american games. That is until recently.

    I have bought a couple of new games over the past half year or so, and when i tried to get around to playing them, many problems have arose. It first started with the backup loader channel, many backups i made of some of my games would not work. Japanese or american ones. I thought maybe the way i was making copies might be the problem (even though it worked fine before), so i found and downloaded copies of one or two of these games off the net and tried them to see if they worked. But they also didnt. anyway, i figured it didnt matter so much for the time being, because i could play the originals anyway, it just would have been nice to be able to make working backups of them. So, i decided not to pursue it any further. However, things got progressively worse, and i realised i need to do something otherwise my gaming life (although not a time consuming as it used to be) is essentially over on the wii. It all came to a head when I bought a japanese copy of wii sports resort. An original japanese game for an original japanese wii, and it would not play.

    Obviously i need to update my firmware. However i still want to be able to use homebrew, my homebrew region free apps (to be able to play my import games), and also i still want to be able to play backups of my games (japanese and american titles) using backup loader channel or whatever its substitute may be.

    I have been looking all over the net, and i havent found anything that is making it clear to me. All i have found are downgrading instructions, and any info about updating homebrew friendly firmware have had a warning attached that it wont work on a japanese or korean wii.

    I am hoping someone here can spell it out for me in a simple easy to understand way. I havent really been keeping up to date with hacking stuff much these days, so its best to treat me like a child for the time being


    my system is as follows.

    Japanese wii (no modchip installed. ie. soft modding only)

    japanese wii firmware 3.3J

    Homebrew channel installed 1.01 IOS36 v4.18 (i got this info all from the homebrew channel)

    backup loader channel installed - this boots up backup launcher 0.3 gamma, IOS249 (again, i got all this info after starting the bakup loader channel)


    so i need to find a way to update my firmware to 4.0, or 4.1 if possible on the japanese wii, but still be able to do all the things i could do on my wii up until now. ie. play original japanese games as per usual, use homebrew, play us original games via region free, play back ups of us and japanese games using backup loader channel.


    I am hoping someone can help me with the info (and also preferably links to files i need..... i know i am being greedy, but i dont have much time to play games nowadays, let alone search for files to modify my wii.... i think my dedicated hacking days are over .....) so that i can use my wii to play all my japanese original games, and all the stuff i used to be able to do before (as mentioned above), and more (ie. new firmware 4.0/4.1 sd card good things you can do, get more of my backed up games working)

    anyway, i would really appreciate some help with this, and hopefully this ageing gamer can enjoy his wii to the maximum once more

    anyway, hope to hear some replies soon.

    thanks in advance.

    ciao

    tommi
     
  2. isamux

    Member isamux Advanced Member

    Joined:
    Dec 25, 2005
    Messages:
    63
    Location:
    Downtown Canada
    Country:
    Japan
    I modded two virgin Japanese Wii's which had 4.0J installed as well as a launch day US Wii. All setups work fine.

    I recommend that you follow any of the stickied guides. They will help to get your system up to date and still enjoy all the benefits that you have and more. *[​IMG]*

    Just where it says to install US versions, change them to JAP versions and you'll be fine.

    Go slow, step by step and you can't go wrong.

    In fact, you can even upgrade right now to 4.1J using your Wii's update and still be able to downgrade/softmod your wii.

    Hope this helps, but really, just follow any of the tutorial at the top of this forum. They are stickied for a reason. *[​IMG]*
     
  3. tommitek
    OP

    Newcomer tommitek Advanced Member

    Joined:
    Aug 17, 2009
    Messages:
    69
    Country:
    Japan
    stickied? i dont follow. could you provide a link to one for me please?
     
  4. isamux

    Member isamux Advanced Member

    Joined:
    Dec 25, 2005
    Messages:
    63
    Location:
    Downtown Canada
    Country:
    Japan
    "STICKY" or stickied (past tense) means that a post that someone has written was deemed important or worthwhile that it should remain at the top of a forum so that all people can have quick and easy access to the information contained within.

    here is the link.

    http://gbatemp.net/index.php?showforum=108

    And you can choose any of the softmodding tutorials at the top. I can't really say which one is best, I used the one by xzxero and that can be found here: http://gbatemp.net/index.php?showtopic=171901

    If your Wii has internet access then use the ONLINE method.

    Hope that helps.
     

Share This Page