Help with offline LU64+ Wii Offline Upgrade

Discussion in 'Wii - Hacking' started by SoraK05, Jun 24, 2009.

Jun 24, 2009
  1. SoraK05
    OP

    Member SoraK05 GBAtemp Regular

    Joined:
    Aug 24, 2007
    Messages:
    148
    Country:
    Kenya
    Hi.
    There is so much information on the LU64+ Wiis on these forums, and everyone seems to have answers but I can't figure out a concrete answer to these questions myself!
    Can anyone please help me answer these questions?

    I wanted to know how to upgrade an LU64+ Wii Offline, and how to go about softmodding it at the same time.
    It has never had the Homebrew Channel or anything installed on it, and is at 3.4.

    I want to:
    * Update it to 4.0
    * Install cIOS38 rev 13a
    * Install some kind of cIOS of IOS60
    * Install PreLoader 0.29

    How can I go about it?

    I have read something about cBoot2. I know that I install the HackMii Installer and install HBC and BootMii as IOS, and then install cBoot2.
    Then I know something about using a custom WAD Manager at that point, but I'm not sure what to do from here.

    I know I cannot downgrade anything on the Wii, but I can install same or higher versions of stuff.
    I want to get cIOS38 rev 13a installed, so I can install a trucha patched and cIOS version of IOS60, and then install the 4.0 WAD as well. I also wanted to install PreLoader on the Wii.

    What do I do once I reach the point where cBoot2 is installed?
    Will PreLoader 0.29 work on these Wiis? I read something about it not working. How can I get it to work, even if it involves installing custom WADs of some sort (to get the necessary files onto the Wii)..?
     
  2. nknave

    Member nknave GBAtemp Regular

    Joined:
    Jun 23, 2009
    Messages:
    154
    Country:
    Mexico
    I've been asking the same there in this thread of mine: http://gbatemp.net/index.php?showtopic=163264

    I still don't get a fully solid confirmation.

    I don't want to brick my LU64, cause it's too much money, and I can't update any other way.


    Now, I think you may use the WADs found in game discs, but I don't have a game that will update to v417(SM4.0U), PunchOUt will only go upto v385(SM 3.4U).


    How much info do you have on your side?
     
  3. SoraK05
    OP

    Member SoraK05 GBAtemp Regular

    Joined:
    Aug 24, 2007
    Messages:
    148
    Country:
    Kenya
    I know that NUSDD can get the 4.0 WAD and pack it, and should install with cIOS38 rev 13a installed and WAD Manager 1.4.

    I know that it should be safe to install any WAD which is the same or higher version as the one on the Wii, so installing patched IOS' of higher or the same as the one on the Wii should be OK, but NEVER LESS - NO DOWNGRADING AT ALL.

    I'm not sure what to do once reaching the cBoot2 stage and what to use the custom WAD Manager for, but I strongly believe that once cIOS38 rev 13a is on the Wii (I like 13a more than 13b [​IMG]) then it's possible to install any same or higher IOS, including a patched IOS60 and the 4.0 System Menu WAD.

    I just need to know what to do at that stage, and whether PreLoader 0.29 works (and with tinkering with custom patched IOS60 or other kind of customized WADs if necessary).
     
  4. SoraK05
    OP

    Member SoraK05 GBAtemp Regular

    Joined:
    Aug 24, 2007
    Messages:
    148
    Country:
    Kenya
    I'm not sure if there is a policy for double posting, and I'm sorry for doing anything wrong if so.

    It seems dude that you can install a cIOS WAD straight away after getting cBoot2 on the Wii, so after the cIOS is installed then you can probably (from what I understand) install IOS60 and the 4.0 WADs with WAD Manager v1.4 at that point without any problems - just same or higher version WADs only, and make sure the cIOS is rev 11 or higher, since anything lower is not compatible with the LU64 type Wiis..

    Hope that helps!

    I just need to know if PreLoader works... :S
    Also, if AnyRegion Changer works, to change the region of the Wii (only the region - and maybe install a System Menu WAD if it's a higher version..)
     
  5. Scarfish

    Member Scarfish GBAtemp Regular

    Joined:
    Jan 5, 2009
    Messages:
    101
    Country:
    Netherlands
    If you're on 3.4 you could use Wad Manager instantly to install ios16 (v257 I believe) and after that use the custom wad manager (for IOS16) for installing the wad for cIOS rev11 instead of the cboot2 story.

    Does PreLoader work: No

    For whats left I dont know if you can change the region safely and I also dont know if its going to work with the cIOS 60 but I'm would like to know also [​IMG].
     
  6. SoraK05
    OP

    Member SoraK05 GBAtemp Regular

    Joined:
    Aug 24, 2007
    Messages:
    148
    Country:
    Kenya
    Has anyone tried installing a patched IOS60 which has been patched by PreLoader, or finding some way to install those extra files that come with PreLoader in order to 'get them onto the Wii'..?
     
  7. Scarfish

    Member Scarfish GBAtemp Regular

    Joined:
    Jan 5, 2009
    Messages:
    101
    Country:
    Netherlands
    The main problem is that Preloader wants to use a version of IOS36 with the trucha bug in it (v1042 for example). Since we cant downgrade these its not possible to install it (yet).
     
  8. SoraK05
    OP

    Member SoraK05 GBAtemp Regular

    Joined:
    Aug 24, 2007
    Messages:
    148
    Country:
    Kenya
    Anyone managed to convince Crediar for a version that works on something else, for us LU64 people? Like cIOS IOS249 for example.? [​IMG]
    Or maybe hack the PreLoader 0.29 DOL file to change the bytes from IOS36 v1040 to IOS249.. that might be extremely difficult though..
     
  9. SoraK05
    OP

    Member SoraK05 GBAtemp Regular

    Joined:
    Aug 24, 2007
    Messages:
    148
    Country:
    Kenya
    I think I understand what is different about the newer LU64 type Wiis, and this is for people who may not know (and I can't seem to find the answer here on these forums, even if it is already here).

    I was told that there is a hardware difference in the newer Wiis, and that the newer IOS files (the ones with 3.4, or at least the ones that come on those Wiis) are able to be used on those Wiis. The reason Wiis cannot use older IOS' from downgrading is because the IOS' can't be used on these Wiis with slightly different hardware. This is like the difference between the EZ-Flash 3-in-1 and EZ-Flash 3-in-1+, which use different hardware and need tweaked software for accommodating, in the Nintendo DS Flash Cart world..

    Supposing someone figured out how to add this hardware support into older IOS', or wanted to make CIOSCORP with the newest IOS', that should work as far as I know. Applying the CIOS patches (not the trucha one) to the 5X and 6X IOS' will be hard as far as I know, but supposing they were applied to the newer IOS', they should work on the newer Wiis since the hardware difference would be accomodated.

    Anything that works on any Wii can work on these Wiis as well just as normal - the only thing is that it can only work with newer IOS', and Waninkoko's cIOS rev 11 and higher (which supports the newer hardware).

    That's how I see it - Region Changing, WAD Updating, and so forth are absolutely fine - the only thing is that it cannot use the older IOS files without the hardware support.

    Hope that clears things up, and if my source is correct (which I believe it is), that should help clear up the LU64 issue for people.. hope this isn't OFN [​IMG]
     
  10. nknave

    Member nknave GBAtemp Regular

    Joined:
    Jun 23, 2009
    Messages:
    154
    Country:
    Mexico
    I have to agree with the level of this point of view.


    Hey, Thanks to the BootMii boot2 install on older Wiis, I mess arround with a Wii once in a while to find stuff.

    And I found out that you can uninstall IOS36.WAD and the will will run fine anyways.

    And best of all, yes you can install and run preloader0.29......... now this is not a LU64/65, So I don't know how this will affect the newer hardware.

    I tested this by Installing all newer IOS into this wii, and I did get that no signbug ios found error, but after uninstalling, it worked fine. [​IMG]

    Hey, what Wii game Disc comes with Update 4.0??? PunchOut is the newest I have and it comes with 3.4. I'm NTSC USA btw.


    Thanks.
     
  11. SoraK05
    OP

    Member SoraK05 GBAtemp Regular

    Joined:
    Aug 24, 2007
    Messages:
    148
    Country:
    Kenya
    Just use NUSD to get a 4.0 WAD, and even an IOS60 WAD, although try get the WAD patched for Trucha so you can use fakesigned Wii Games and even Channels (from the SD Manager)..
    It works fine to install the 4.0 WAD made by that program using WAD Manager 1.4 and cIOS38 rev 13a (haven't done it personally, but I've installed NUS IOS' which I downloaded as an experiment, which weren't being used by the System Menu, and they all worked, as well as system channel NUS WADs and MIOS)..
     
  12. Scarfish

    Member Scarfish GBAtemp Regular

    Joined:
    Jan 5, 2009
    Messages:
    101
    Country:
    Netherlands
    Reading the other thread about the LU64+ Wii's it looks fairly simple to install Preloader on these Wii's.

    The most simple ways would be to just download the latest IOS36, trucha patch it and pack it up so that the the only changed things would be the patch and the (trucha) signature. Now install Preloader. I don't know if this will go that well since Preloader makes changes in IOS60 and I don't know what happens at that point. Does it make changes in the ticket so that the 'secret' version would be messed up or not.

    To avoid messing up IOS60 I thought that it would be wise to download IOS60, patch trucha bug back in and patch the ES_DIVerfiy part which Preloader should do. Now that we have a good patched IOS60 ready, we could install it (if it has no problems with the same version number and the same 'secret' version number or we could just raise these). Now rename the system menu dol and take the dol that Preloader places instead of the system menu and put it right there. If Preloader puts some other files in places we need to do that too. Would this work? I dont know.

    What I need right now is a Wii without Preloader ever installed (not LU64) and look at what files are exactly placed on the Wii and on which places. Next is to take the dol and try running it with the Homebrew Channel on a LU64 Wii and look if this will do anything.
     
  13. mtb-bfh

    Newcomer mtb-bfh Advanced Member

    Joined:
    Apr 8, 2009
    Messages:
    97
    Country:
    United States
    Curious why so many people recommend custom wad manager for IOS16 instead of just using a WM1.4 variant and selecting IOS16...why have multiple wad managers? Does 1.4 not work on older firmwares or something?

    As far as preloader goes...I've definitely tried fakesign patching the newer IOS36 and had no luck. Preloader's either checking specifically for version 1042 or the error message is somewhat of a lark and it actually wants an ES_Identify patch, not a fakesign patch (it DOES say "failed to get root" after all). I'm not sure if the ES_ functions can be patched into newer IOS36 somehow...if so, I haven't found an application to do it, and I just don't have the time to start disassembling IOS files and trying to figure it out myself. IOS36 is used by too much stuff for me to feel very safe fiddling with it, at any rate.

    Startpatch could probably be fixed to work on LU64 just by putting in an IOS_Reload call to use cIOS, but here again I just haven't had the time or the motivation to try yet.

    Bytepatching Preloader's installer to just call a different IOS sounds like an option, but I think executables are checksummed somehow? That would make this ever-so-slightly non-trivial. Several people are working on hacks to give us control over IOS reloads, and that right there seems like it would solve the problem as well.

    By far the easiest option would be if somebody could just get crediar to roll a slightly modified version, I can't imagine it would require a huge change or much development time. One way or another I think we just need somebody that really knows what they're doing to give this issue some attention. I really wish I could help out myself, but I haven't done this kind of reverse-engineering in a few years and just haven't had the time or inclination lately to study up on ARM/PPC and how things are handled by the Wii.

    One way or another the solution to this can't be far off. As more of these new Wiis are purchased eventually somebody with half a clue will be forced to take a look at this issue and toss us all a bone. [​IMG]
     
  14. mtb-bfh

    Newcomer mtb-bfh Advanced Member

    Joined:
    Apr 8, 2009
    Messages:
    97
    Country:
    United States
    There's no problem whatsoever with IOS60, so far as I know. It's just the Preloader installer itself seeming to only want IOS36-1042..trucha-patching newer versions still gives the fakesign error.
     

Share This Page