[Help] Wii crashes with NSMBWii

Discussion in 'Wii - Hacking' started by Shpingle, Nov 23, 2016.

  1. Shpingle
    OP

    Shpingle Member

    Newcomer
    11
    2
    Nov 23, 2016
    United States
    I have a homebrew'd Wii with 4.3U installed. I have already made a syscheck,
    Warning: Spoilers inside!

    If anyone can help me, that'd be greatly appreciated.
     
  2. Zonta85

    Zonta85 GBAtemp Fan

    Member
    333
    23
    Nov 9, 2007
    Italy
    Ascoli Piceno
    You don't tell us if you are running an original disc, a backup disc via modchip, ora backup game trough an usb loader (what usb loader and wich version).

    Regarding your syscheck, the cIOSes seems to be very old, i think you need to update them.

    First of all download the d2x cIOS installer from here https://sites.google.com/site/compl...d2x-cIOS-Installer-Wii.zip?attredirects=0&d=1

    Then extract it and place the eight folder on your sd/apps, boot it trough hbc.
    Once on the installer, press any button to continue after the disclaimer.
    Press right on the dpad until you select "v10 beta 52" on the first line.
    Using down on the d pad, move to the second line and select 56 as cIOS base
    Use the default 249 as cIOS slot in the third line
    Use the default 21010 as cIOS revision in the fourth line
    Press Home to add this to the cIOS batch installing and you will see a green confirmation line.
    Now some values should have changed.
    They should be from the first to the fourth line: v10beta52, 57, 250, 21010, press home to add to batch. The green confirmation line will appear.
    Now the values should have changed again: change the cIOS base to 37 to have, from the first to the fourth line: v10beta52, 37, 251, 21010, press Home to add to batch, the green cpnfirmation line will appear.
    Now press A button to continue, and a cIOS slot map will appear, press again A to begin the installation.
    Wait with patience, because it can take a while: the IOS must be downloaded from Nintendo servers, then patched and only in the end installed.

    Let me know ;)
     
  3. Shpingle
    OP

    Shpingle Member

    Newcomer
    11
    2
    Nov 23, 2016
    United States
    I did not have v10 beta 52 as an option.
     
  4. Zonta85

    Zonta85 GBAtemp Fan

    Member
    333
    23
    Nov 9, 2007
    Italy
    Ascoli Piceno
    You have to, the options in the first line (that you can change with the dpad) should be "v10 beta52" and "v10 beta53".
     
  5. Shpingle
    OP

    Shpingle Member

    Newcomer
    11
    2
    Nov 23, 2016
    United States
    It does not have v10 beta 52 or v10 beta 53, only d2x v4, v5, and v6.
     
  6. Zonta85

    Zonta85 GBAtemp Fan

    Member
    333
    23
    Nov 9, 2007
    Italy
    Ascoli Piceno
    I've attached a screenshot.
     

    Attached Files:

  7. Shpingle
    OP

    Shpingle Member

    Newcomer
    11
    2
    Nov 23, 2016
    United States
    Mine does not have the option for the betas, only the ones I have mentioned.

    — Posts automatically merged - Please don't double post! —

    This is as high as the cIOS will go for me.
     

    Attached Files:

  8. Zonta85

    Zonta85 GBAtemp Fan

    Member
    333
    23
    Nov 9, 2007
    Italy
    Ascoli Piceno
    It seems that you don't have the correct ciosmaps.xml into your d2x installer folder.
    Try with this package, overwrite the files that you installed previously.
    https://sourceforge.net/projects/d2x-cios/files/d2x-v10-beta52.zip/download

    If it does'nt work, i will attach here my folder
     
  9. Shpingle
    OP

    Shpingle Member

    Newcomer
    11
    2
    Nov 23, 2016
    United States
    Zonta85 likes this.
  10. Zonta85

    Zonta85 GBAtemp Fan

    Member
    333
    23
    Nov 9, 2007
    Italy
    Ascoli Piceno
    I need to sleep, right now in Italy is very very late :)
    If thatblink does'nt work too, use this attached file, it comes directly from my wii's sd card
     

    Attached Files:

  11. Shpingle
    OP

    Shpingle Member

    Newcomer
    11
    2
    Nov 23, 2016
    United States
    Will try now, thank you for your help.
     
  12. Zonta85

    Zonta85 GBAtemp Fan

    Member
    333
    23
    Nov 9, 2007
    Italy
    Ascoli Piceno
    Let me know, now they MUST work :D
     
  13. Shpingle
    OP

    Shpingle Member

    Newcomer
    11
    2
    Nov 23, 2016
    United States
    I only had 53, not 52 :/

    — Posts automatically merged - Please don't double post! —

    Some files where named the same, so I had to replace them.

    — Posts automatically merged - Please don't double post! —

    ok, I retried and read the steps carefully. All of the cIOS installed perfectly, but NSMBWii does not work.
     
  14. Zonta85

    Zonta85 GBAtemp Fan

    Member
    333
    23
    Nov 9, 2007
    Italy
    Ascoli Piceno
    It happened something similar to me the last wee while i was doing some tests, it let me crazy and i lost one hour of mynlife.
    Instead of replace, delete the entire folder, the unzip again the files into sd/apps and try again.
    If it doesn't work too, for now install beta 53 with the istructions that i gave to you befo

    — Posts automatically merged - Please don't double post! —

    Ok. Can you tell me if is an original disc, a backup, and if it is a backup, what kind of? Disc loaded trough hardmod, disc loaded trough softmod?
    Or a game iso loaded with an usb loader? If is an usb loader, please, name of thenloader and his exact number of version/revision.
     
  15. Shpingle
    OP

    Shpingle Member

    Newcomer
    11
    2
    Nov 23, 2016
    United States
    Thank you for your help, but I tried running NSMBWii through Usb Loader and gecko, but the disc just crashes my wii entirely. Oh, It's a game disc. I think my wii is soft modded, all I have is Homebrew channel, with a few games
     
    Last edited by Shpingle, Nov 24, 2016
  16. Zonta85

    Zonta85 GBAtemp Fan

    Member
    333
    23
    Nov 9, 2007
    Italy
    Ascoli Piceno
    As i told you, if you want more help tell me if is an original disc, a backup, and if it is a backup, what kind of? Disc loaded trough hardmod, disc loaded trough softmod?
    Or a game iso loaded with an usb loader? If is an usb loader, please, name of thenloader and his exact number of version/revision.

    Tou talked about a disc. Original or backup? Maybe is simply scatched or it is a bad burning.
     
  17. Shpingle
    OP

    Shpingle Member

    Newcomer
    11
    2
    Nov 23, 2016
    United States
    It is an original bought NSMBWii disc.
     
  18. Zonta85

    Zonta85 GBAtemp Fan

    Member
    333
    23
    Nov 9, 2007
    Italy
    Ascoli Piceno
    Ohhh wiat if it is original is a disc fault, because when you load a game from the disc channel the softmod or any other homebrew isn't involved, the game runs trough an unmodified wii mode, Tthings like cIOS aren't involved at all.
    Probably the game disc is a little scratched or your dvd drive is suffering because of his age.
     
  19. Shpingle
    OP

    Shpingle Member

    Newcomer
    11
    2
    Nov 23, 2016
    United States
    It can't be my disk drive, because it runs other games just fine, and it cannot be the game disc either, because It worked on my Wii U.

    EDIT: I tried putting the disc into my wii again, and it was taking forever to register, so I took it out. As soon as I took it out, It started playing the channel opening. I tried putting it back in, but then said the disc cannot be read.
     
    Last edited by Shpingle, Nov 24, 2016
  20. Zonta85

    Zonta85 GBAtemp Fan

    Member
    333
    23
    Nov 9, 2007
    Italy
    Ascoli Piceno
    But i can tell you that i'm 100% sure that this is'nt a softmod issues. Maybe your wii drive (even if works correcrly with other discs) has some issues with this specific disc that the wiiu drive hasn't because is younger or for other reasons that we don't know.

    And if it was a softmod issue, instead of the black screen you should see a message error after the disc loading that is a piracy prevention chack that says "error 001" or "error 002" but your games just crashes, is a reading erro, trust me :)