Homebrew Homebrew app [Help Wanted] Moonshell2 playlist feature almost figured out

1creeperbomb

New Member
OP
Newbie
Joined
May 19, 2021
Messages
1
Trophies
0
Age
21
XP
11
Country
United States
So for those that are unaware, Moonshell 2 has support for M3U, WPL, and MPL playlists. However so far the only known use was the auto-generated MPL playlists you can make with the builtin playlist editor. However those playlists are limited to a single folder and have no definable order.

I have wasted the past 2 months of my life trying to get m3u and wpl to work and now I am very close. This post will highlight what I have discovered and tested so far.

(Examples are all in UTF-8, both on computer and on DS)

So for starters, M3U files will actually read properly but only if they don't have M3U tags. A typical M3U file looks like this:

#EXTM3U
#EXTINF: (info stuff)
/folder/file1.mp3
#EXTINF: (info stuff)
/folder/file2.mp3
#EXTINF: (info stuff)
/folder/file3.mp3

If Moonshell tries to read this it will freeze. However if you remove all the tags and leave only the file paths:

/folder/file1.mp3
/folder/file2.mp3
/folder/file3.mp3

Moonshell will read this and only throw an error of "Unable to locate any music files in the specified folder"

Another interesting thing I discovered is Moonshell will automatically ignore drive letters as well so a file like this:

F:/folder/file1.mp3
F:/folder/file1.mp3
F:/folder/file1.mp3

will also read fine and show the same dialog box error.

WPL files will also read, but they must not have meta tags or child tags of any kind. so for example:

<?wpl version="1.0"?>
<smil>
<head>
<meta name="Generator" content="Microsoft Windows Media Player -- 11.0.5721.5145"/>
<meta name="AverageRating" content="33"/>
<meta name="TotalDuration" content="1102"/>
<meta name="ItemCount" content="3"/>
<author/>
<title>Bach Organ Works</title>
</head>
<body>
<seq>
<media src="/folder/file1.mp3"/>
<media src="/folder/file1.mp3"/>
<media src="/folder/file1.mp3"/>
</seq>
</body>
</smil>

Will not read, but:

<media src="/folder/file1.mp3"/>
<media src="/folder/file1.mp3"/>
<media src="/folder/file1.mp3"/>

will read just fine.

If Moonshell still freezes when reading with the correct format, try opening as a regular text file to see if it displays properly. I had this issue and when I changed my sd card cluster size to 64kb and enabled slow disk access in moonshell.ini, text files appeared as normal and playlists files started being read.

Now that I've made it this far, I am stumped on how to get Moonshell to actually play a file. It doesn't seem to make a any distinction between / or \ in the file path, and I even tried placing a music file at the root directory, but it always gives the same error which states "Unable to locate any music files in the specified folder". The logbuff.txt hasn't revealed anything either even with debug log on. It only shows the "empty playlist" error. If anyone still uses Moonshell, please try it out and see what you get. Supposedly Moonlight had some non standard format for playlists so i am convinced this isn't just an unfinished feature.

Also attached a screenshot of the Moonshell error to see what it looks like:

moonshell.jpg
 
  • Like
Reactions: zfreeman
General chit-chat
Help Users
  • No one is chatting at the moment.
    AkiraKurusu @ AkiraKurusu: Though the bed in the Guest Bedroom is so large there's ironically not much space leftover...