1. Ian San Miguel

    OP Ian San Miguel Member
    Newcomer

    Joined:
    Aug 12, 2013
    Messages:
    15
    Country:
    United States
    Hi all
    I wonder if any of you gurus can please help.
    I have a switch in sxos emunand which is on 7.x.
    It has sysnand 4.1 which has never been touched. I do EVERYTHING in emunand.

    I was recently playing dragon marked for death with a friend on his legit online switch. After a recent update we couldn't play together so I used the feature "Match Version with Local Users" which supposedly allows you to download a software update from another switch.

    BIG MISTAKE. Looks like it also updates firmware as well. My friend had 8.1 so I assume it updated my switch emunand to 8.1 also.
    I was hoping it would be a simple fix and that all I would need to do is update my SXOS version to 2.8 (which supports 8.1).
    However, after copying the new boot.dat to my sd card and booting up, it looked like it was going to work OK. Saw the nintendo logo, but then got a black screen that says:
    'An error has occured. Please press the power button and restart the console'

    Is there anyway to rescue this? Or am I screwed. I know it's only emunand and I can just create a new one, but I'd prefer not to lose all my saves and installed NSPs.....

    I know this was stupid of me, but hopefully somebody has experience this.
     
  2. jajamundo

    jajamundo GBAtemp Regular
    Member

    Joined:
    Aug 28, 2009
    Messages:
    292
    Country:
    United States
    Try to use another SD Card, maybe your just get corrupted and let me know of it works
     
  3. Ian San Miguel

    OP Ian San Miguel Member
    Newcomer

    Joined:
    Aug 12, 2013
    Messages:
    15
    Country:
    United States
    Hi jajamundo
    Thanks for taking the time to reply.
    I don't have a spare memory card to test with, but I'm sure it would work. Point is, I could easily just erase my emunand if I wanted a quick fix to get this working. Booting into sysnand works just fine too so mem card seems fine.

    I was really asking if somebody has had any experience with this scenario to see if my existing emunand could be rescued...

    thanks again.

    — Posts automatically merged - Please don't double post! —

    SOLVED!! hope this helps anybody stupid enough to do what I did ;)

    I remembered I was using a custom theme which probably wouldn't be compatible with 8.1.

    Deleted 'Titles' Folder under Root:\SXOS\

    Booted into SXOS emunand first time.
     
  4. jajamundo

    jajamundo GBAtemp Regular
    Member

    Joined:
    Aug 28, 2009
    Messages:
    292
    Country:
    United States
    Glad to know you already fix your Nintendo Switch
     
    Ian San Miguel likes this.
  5. PHiLiPZ

    PHiLiPZ GBAtemp Regular
    Member

    Joined:
    Mar 8, 2019
    Messages:
    162
    Country:
    Slovakia
    What logic is behind this? OFW would start even without a card, right?
     
  6. Ian San Miguel

    OP Ian San Miguel Member
    Newcomer

    Joined:
    Aug 12, 2013
    Messages:
    15
    Country:
    United States
    Because the profile on my sd for sysnand - the nintendo folder, was working fine. Games I had installed on sysnand appeared and were launching.
    And my hunch was right, because as described above it was purely down to layeredFS and an incompatible theme.
     
  7. PHiLiPZ

    PHiLiPZ GBAtemp Regular
    Member

    Joined:
    Mar 8, 2019
    Messages:
    162
    Country:
    Slovakia
    Ok, but booting sysnand and starting officially bought games, stored on sd, from ofw are not the same thing.
     
  8. kit__

    kit__ Newbie
    Newcomer

    Joined:
    Jul 5, 2019
    Messages:
    8
    Country:
    United States
    Well... have you consulted GaryOPA about this? He is the sxos creator and all...
     
  9. Slim45

    Slim45 GBAtemp Regular
    Member

    Joined:
    Aug 6, 2018
    Messages:
    143
    Country:
    United Kingdom
    another satisfied sxos user
     
    Zeryac likes this.
  10. Ian San Miguel

    OP Ian San Miguel Member
    Newcomer

    Joined:
    Aug 12, 2013
    Messages:
    15
    Country:
    United States
    Wow what's with the snide/sarcastic comments? Rather then help you turn your nose up at sxos users because they're don't have your l33t skilllz. I figured out what was wrong, no thanks to anybody on this supposedly knowledgeable board. I've been modding my consoles since the PS1 days and am pretty clued up on all the different console scenes. Come back to the adults' table when you've got something useful to contribute.
     
  11. Slim45

    Slim45 GBAtemp Regular
    Member

    Joined:
    Aug 6, 2018
    Messages:
    143
    Country:
    United Kingdom
    well somebody has to represent the trolls.
    If you were on reinx or atmo I'm sure you'd have gotten people jumping over each other to help. But sx is a cluster fuck of code that is one good day away from a brick, that not a lot of people on here have time or the desire to troubleshoot. You could try the tx discord. Actually we did help you. you got the issue sorted didnt you?
    All thanks to our L33t skills. Imagine whwre ud be without us. :P
     
    Last edited by Slim45, Jul 9, 2019
    PHiLiPZ likes this.
  12. Ian San Miguel

    OP Ian San Miguel Member
    Newcomer

    Joined:
    Aug 12, 2013
    Messages:
    15
    Country:
    United States
    "Cluster fuck of code that is one good day away from a brick" Looool. I love how people make comments like that around here, when they have no programming experience whatsoever. Thanks for laughs guys.
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - matching, emunand, version