ROM Hack Help rebuilding .3ds of a Level-5 game?


New Member
Jul 22, 2019
Hello there, this is the first time I really use this site so excuse me if it's written in a weird and unstructured manner or something...
I was feeling bored so I decided to play some games on my old 3DS and as a big Level-5 fan I played some of their games, including Yo-Kai Watch, including some of the untranslated games.
I thought that maybe I could try translating one of those japan-only games, because...well why not. But looking online how that works made me realize that Level-5 games are apparently a little difficult to work with.
But I still managed to do it, somehow. With "3DS Rom Tools" I managed to get the romfs (and exefs/exheader). So I edited some things (the yw_a.fa file), felt rather proud and decided to test it.
And then the issues started appearing...:unsure:
I tried multiple things but I don't seem to be able to rebuild a working .3ds file.

1. Try I downloaded the RomFS Builder and tried building the romfs into one file. Then I used the HackingToolkit V9 to extract the other files from the .3ds file like the Header, banner and such. I noticed that the file from the RomFS Builder wasnt a .bin file it was...just a file. Slightly confused I made it into a .bin file, put the file with the other files I extracted from the 3ds file and used the HackingToolkit to rebuild them all into one new .3ds file. I started Citra and...loading it crashes Citra.
2. Try I used the 3DSBuilder that was in the ExtraTools folder. Selected the RomFS folder, the ExeFS folder and the ExHeader. I didnt know the Serial Number, so I just put whatever in... And well, to nobodies surprise the file that got made didn't work either.

So here I am, a little hopeless. I'm pretty sure I did something wrong, because I tried extracting the romfs and such and instantly rebuilding, just with the original files, and that didn't work either.
I never did something like this so...I hope someone here can help me! :wacko::(
  • Like
Reactions: florflor
General chit-chat
Help Users
  • No one is chatting at the moment.
    WiiWare @ WiiWare: Did that yesterday , however nobodies replied