Help please - Playing out of region games on Luma3DS

Discussion in '3DS - Flashcards & Custom Firmwares' started by Ariel7, Feb 15, 2017.

  1. Ariel7
    OP

    Ariel7 Newbie

    Newcomer
    6
    1
    Dec 7, 2016
    Hi all :)

    I need help with getting non-EU region (USA & JPN) self created CIA files working on Luma 3DS.

    I was under the impression that Luma3DS was region-free, yet I always seem to encounter a black screen with self made USA/JPN CIAs.

    I made the CIA using a backup of 'Busta-a-Move Universe' USA. Upon loading the game I get the Nintendo 3DS logo and then a black screen.

    I guess theres a step in the conversion process that I am missing but not sure what that step is, despite trying to dig around for an answer.

    Any help would be greatly appreciated.
     
  2. Meliodas2255

    Meliodas2255 common sense guy

    Member
    222
    74
    Jan 4, 2017
    United States
    have you tried freeshop?
     
  3. THEELEMENTKH

    THEELEMENTKH GBAtemp Advanced Fan

    Member
    944
    589
    May 31, 2016
    Spain
    Hell
    Are you on new 3ds?
    What version of luma are you using?
    Have you tried language/region emulating?
     
  4. Joshwraith

    Joshwraith GBAtemp Fan

    Member
    318
    54
    Jun 4, 2009
    Mexico
    I tested one physical game that is out of my region and Luma load it fine, in the case of .cias I think they need region free patch.
     
  5. ScarletDreamz

    ScarletDreamz [Debug Mode]

    Member
    2,659
    1,151
    Feb 16, 2015
    United States
    California
    no.
     
  6. Majickhat55

    Majickhat55 The Red Woman

    Member
    3,986
    1,865
    Mar 28, 2016
    United States
    Asshai
    Region free works fine on Luma regardless of your region. You can try adding a locale.txt file (emulating another region) to see if that fixes it. I.E If the game is USA, change it's region to USA EN. If that doesn't work then it's probably your .cia builds. Not sure what tools you're using to rebuild them but it's most likely a user error. Just download the games and you won't have this problem.
     
  7. Ariel7
    OP

    Ariel7 Newbie

    Newcomer
    6
    1
    Dec 7, 2016
    Thanks all for replying.

    Sorry I thought that I copied and pasted my set up in the original post. Info as follows:


    O3DS XL (EUR)

    arm9loaderhax

    Luma3DS v6.6 - 88db5940 nightly build

    Sysnand 11.2.0-35E

    Emunand 11.3.0-36E


    I have tried converting my .3ds backup files using both Decrypt9WIP and also Simple CIA converter.

    I have backed up my EUR games and converted them to CIAs and they play fine so just confused as to why my US and JP backups wont play :(

    Someone mentioned Freeshop which I havent used before. Might be a silly question (!) but am I still able to use Freeshop with games that have only been released as a physical cart and not on Nintendos eShop? ><

    I did read up about the 'Enable game patching' option in the Luma3DS wiki but assumed that this was not required as it states that it is for out-of-region DLC. I suppose I could still try it in any case.

    Thanks in advance
     
    Last edited by Ariel7, Feb 16, 2017
  8. Distrance

    Distrance 矢澤にこ

    Member
    1,146
    426
    Nov 23, 2008
    Finland
    No. freeShop's game selection is identical to the selection available at e-shop so it won't work for you if the game you're wanting to play does not exist in the e-shop. As far as your actual problem goes though .. I've no idea, sorry.
     
    Ariel7 and Meliodas2255 like this.
  9. Ariel7
    OP

    Ariel7 Newbie

    Newcomer
    6
    1
    Dec 7, 2016
    Ah, I thought as much, thanks for clearing that up.

    On a separate note, I turned on the 'Enable game patching' setting and followed the instructions on the Luma3DS wiki for producing the .txt file for Bust-a-Move but still no luck.. Black screen on loading.

    I may just have to accept that this will not work for me which is frustrating >>

    Thanks
     
  10. Omegadrien

    Omegadrien GBAtemp Advanced Maniac

    Member
    1,713
    530
    Nov 4, 2015
    France
    Pokéland
    The Luma3DS wiki is not up to date. If you use the latest compiled version of Luma3DS, do that->

    You have to place the *.txt at that location : sd/luma/titles/TitleIDofTheGame/locale.txt
    https://github.com/AuroraWright/Luma3DS/blob/master/injector/source/patcher.c#L384-L385
     
    Last edited by Omegadrien, Feb 16, 2017
    Ariel7 likes this.
  11. Ariel7
    OP

    Ariel7 Newbie

    Newcomer
    6
    1
    Dec 7, 2016

    Managed to get chance to create the locale.txt as you advised and.. It worked!

    Thanks so much all for your help, really happy now :hrth:

    Thanks,

    Ariel
     
    Omegadrien likes this.