Help needed with FFCC ring of fates

Discussion in 'NDS - Console and Game Discussions' started by lazyo, Jul 28, 2008.

Jul 28, 2008
  1. lazyo
    OP

    Newcomer lazyo Newbie

    Joined:
    Jul 27, 2008
    Messages:
    8
    Country:
    Romania
    im on sinners isles in the last room( the room beyond the save point and right before the boss room,the rider thingy)i managed to get to the last part with the lilty square....okay i have to say thats the most annoying piece of shit i've ever encountered...its the reason why my knuckles hurt beacuse i just had to hit something to releave the stress..there was one before when i had to glide to open a target with meeth i was lucky that my pot stayed on the platform and it hit the target,but now its just retarded no matter how many times i try. i need to "glide" over to the teleport thingy to get to the boss,but meeth simply gets stuck right at the edge and looses hp cuz she can't swim in lava(duh).i wa sjust wondering if it ever happened to anyone else is this a glitch or just my problem?i've tried walkthroughs but it didnt matter so im asking for a .sav file beyond this point or maybe a tip on what i need to do or some cheats (like flying or stuff like that)
    P.S. i also tried grabbing the pot then jumpng and gliding,didnt work
     

Share This Page