Help needed please - Rock Band \ Band Hero

Discussion in 'Wii - Backup Loaders' started by craigfoot, Dec 29, 2009.

Dec 29, 2009
  1. craigfoot
    OP

    Newcomer craigfoot Newbie

    Joined:
    Dec 29, 2009
    Messages:
    8
    Country:
    United Kingdom
    I know this is mentioned in loads of posts and forums but I am really struggling to get Lego\Beatles Rock Band and Band Hero working on my wii.

    Here is what I have, V3.2e Wii, Softmod running IOS249v14. I have neogamma R7 and also Cfg USB Loader. I have a USB drum set.

    I have installed various IOS files including IOS38 \ IOS50 \ IOS53 \ IOS55 \ IOS56.

    I have also followed various instructions around installing IOS222 and 223 and merging IOS 37 and 36 etc, I have the games on backup disc and also loaded onto a USB memory stick.

    I can load Lego Rock Band on disc via neogamma but drums not recognised. When booting from USB using CFG loader and selection IOS222-mload it just hangs, Softchip gives a Exception: loct1 error (DI_ReadID) error message.

    I am losing track of what I have tried now and running out of ideas, the drum kit was a christmas present and I have spent days now but having no luck, Would really appreciate it if anyone is able to offer any additional advice.

    Cheers
     
  2. Eddie_Brock

    Member Eddie_Brock GBAtemp Fan

    Joined:
    Apr 15, 2009
    Messages:
    341
    Location:
    Vancouver Island
    Country:
    Canada
    From my experience, this error is caused by an incorrect cIOS for loading. Make sure that you have installed the latest (v4) Hermes cIOS to either 222 or 223. You may have an old version of Hermes that's causing this error. Make sure to have Softchip use the selected IOS, and I believe you need the 002 fix enabled as well. I hope this helps...
     
  3. craigfoot
    OP

    Newcomer craigfoot Newbie

    Joined:
    Dec 29, 2009
    Messages:
    8
    Country:
    United Kingdom
    Thanks for your advice, I am pretty sure I have the V4 Hermes, And also selected the 222\223 in Softchip, also got the 002 fix enabled.

    I will double check all that tommorow, but pretty certain thats all been done.

    Anything else this may be?
     
  4. Eddie_Brock

    Member Eddie_Brock GBAtemp Fan

    Joined:
    Apr 15, 2009
    Messages:
    341
    Location:
    Vancouver Island
    Country:
    Canada
    Just be sure that you are using the proper IOS's merged together. (I can't remember off the top of my head, so I will let you find that)

    As a side note, I also have MulticIOS installed to 223 (Hermes to 222). Perhaps look into installing multi to a seperate IOS and trying that
     
  5. craigfoot
    OP

    Newcomer craigfoot Newbie

    Joined:
    Dec 29, 2009
    Messages:
    8
    Country:
    United Kingdom
    Thanks... Think I will take a look at it all with a fresh head in the morning.. I am sure I have done something with multicios and also done the merging (but will check for the instructions again)

    This all sounds so easy from the tutorials I have read but is causing me so much frustration.

    Can you just let me know are should I boot from disc or USB? Or should it not matter?
     
  6. wiistarter

    Member wiistarter GBAtemp Fan

    Joined:
    Apr 11, 2009
    Messages:
    385
    Country:
    United Kingdom
    In your original post you say you merged 36 with 37... Is this option not defunct in V4 of hermes... I thought 38 took the place of 36
     
  7. craigfoot
    OP

    Newcomer craigfoot Newbie

    Joined:
    Dec 29, 2009
    Messages:
    8
    Country:
    United Kingdom
    I'll review that also tommorow, thanks for the advice
     
  8. craigfoot
    OP

    Newcomer craigfoot Newbie

    Joined:
    Dec 29, 2009
    Messages:
    8
    Country:
    United Kingdom
    OK, I hope someone has the paitience to read this... Here is a log of what I have done this morning, Still with no success...

    Any Title Deleter - Deleted IOS222, 223

    CIOS Installer - "Custom IOS37 with

    IOS36 rev7 dip as IOS249"

    Installed CIOS222.wad

    Softchip (Band Hero \ Lego Rock Band)

    Use IOS222, 002 Protection, Fake IOS

    Enabled, Load Requested IOS Enabled

    Exception: Loct1 Error (DI_ReadID)

    Cios Installer (Hermes V4)

    Install using IOS249

    Install CIOS222 - Merged 38 and 37

    Install CIOS223 - Merged 38 and 60

    Softchip (Band Hero \ Lego Rock Band)

    Use IOS223, 002 Protection, Fake IOS

    Enabled, Load Requested IOS Enabled

    Exception: Loct1 Error (DI_ReadID)

    Use IOS37 (Rev 3609)

    Exception: Loct1 Error (DI_ReadID)

    CFG USB Loader (V48) - Band Hero

    IOS222-mload
    Block IOS Reload - On
    002 Fix - On

    "booting wii game, please wait..."
    "IOS(222) mload ....."
    "IOS Reload: Blocked"
    Then blue light on Disc Drive
    Hangs....

    IOS223-mload
    Block IOS Reload - On
    002 Fix - On

    "booting wii game, please wait..."
    "IOS(223) mload ....."
    "IOS Reload: Blocked"
    Then blue light on Disc Drive
    Hangs....

    CFG USB Loader (V48) - Lego Rock Band
    "WBFS Error: Not a Wii Disc"

    NeoGamma R6 - IOS249 Rev14 (Band Hero)
    Blank Screen

    Lego Rock Band Loads - Drums not recognised (Red LED on When connected to USB, Tried both slots)

    Multi CIOS - Load IOS37 and IOS37 as IOS232

    Softchip (Band Hero \ Lego Rock Band) Using IOS232
    This time had more progress than previously, Lots of white text (Disc ID, Disc Title, Etc..)
    Then Exception: Loct1 Error (DI_ReadID)

    Uloader V3.0c "Error: Could not initialise USB Subsystem! (ret= -121)"
     
  9. craigfoot
    OP

    Newcomer craigfoot Newbie

    Joined:
    Dec 29, 2009
    Messages:
    8
    Country:
    United Kingdom
    Just got a bit further with Softchip.. Set IOS to 232, Disabled "Load Requested IOS" this time got loads of white text as if it was loading then a blank screen...
     
  10. ClockWorK

    Member ClockWorK GBAtemp Regular

    Joined:
    May 10, 2009
    Messages:
    150
    Country:
    United States
    All Guitar Hero and Rock Band work for me using USB Loader GX and USB HDD, though I've not tried USB instruments.

    I installed IOS 222 as 38 + 37.
    I installed IOS 223 as 38 + 60.
    I load the game with IOS 222.

    i think Guitar Hero 5 required IOS 56 be installed. I don't know if any other music-based games require any particular IOS.

    Things I don't think I've ever touched:
    CIOS222.wad
    IOS 232


    I don't know if thumb-drive compatibility is 100%.

    Also, with SoftChip, are you using verbatim DVD-R burned at the slowest speed? Since you seem to get to different spots with SoftChip before getting the same error, I wonder if it's a bad burn.

    And lastly, I don't think Block IOS Reload should be on.
     
  11. craigfoot
    OP

    Newcomer craigfoot Newbie

    Joined:
    Dec 29, 2009
    Messages:
    8
    Country:
    United Kingdom
    I am getting Lego Rock Band and Band Hero booting via SoftChip now, I had to disable Block IOS and 002 Protection.

    Using verbatim DVD-R recorded at 4x speed.

    Problem now is the games dont recognise my USB drums...

    Cheers
     
  12. craigfoot
    OP

    Newcomer craigfoot Newbie

    Joined:
    Dec 29, 2009
    Messages:
    8
    Country:
    United Kingdom
    All sorted, had to re-boot with drums plugged in bottom usb port!

    Cheers everyone for your help and advice
     

Share This Page