HELP ME!!!!

Discussion in 'Wii - Console and Game Discussions' started by LuigisTheMan, Sep 5, 2007.

Sep 5, 2007

HELP ME!!!! by LuigisTheMan at 10:18 PM (793 Views / 0 Likes) 2 replies

  1. LuigisTheMan
    OP

    Newcomer LuigisTheMan Newbie

    Joined:
    Sep 5, 2007
    Messages:
    7
    Country:
    United States
    So i got to the part where your supposed to take the lift down to mines in the pirate home world. I went up the spider ball track and and deactivated the to boost switches. BUT THE LIFT WONT FALL!!! IT GOT STUCK!!! Please tell me i missed something or is this really a glich or something?
     
  2. xbandaidx

    Member xbandaidx GBAtemp Regular

    Joined:
    Mar 18, 2007
    Messages:
    240
    Country:
    United States
    This is the first I've heard of this. Did it make a noise and do a short cut scene to watch that it "dropped" or something. I really can't think of what you could do there than other do a bomb. (you said boost, but I think that part was a bomb?)

    If that fails, you'll probably just have to restart from last save?
     
  3. Don Andy

    Member Don Andy GBAtemp Regular

    Joined:
    Aug 11, 2007
    Messages:
    196
    Location:
    Germany, duh
    Country:
    Germany
    They really are two boost switches. You turn them a bit, the "lock" opens, and the platform falls down a bit. Then you "boost" the other switch, the other lock opens and the thing goes a looong way down.

    Only thing I could think of is messing up the boosting, but if you really did both switches COMPLETELY, I'd really try again from the last savepoint. Or try to get yourself killed and get to a control point or something.
     

Share This Page