[Help] Injecting FBI into sysNAND 4.5.0-10U

Discussion in '3DS - ROM Hacking, Translations and Utilities' started by amaru007, Dec 9, 2015.

  1. amaru007
    OP

    amaru007 Newbie

    Newcomer
    9
    2
    Aug 12, 2007
    My parents bought my 2 sons a 3DS each when they were on holiday in the States a few years back. Because the damn things are region locked, they've been using DS games ever since. Now that I've successfully managed to install a CFW on mine, wanted to do the same for them.

    My 3DS was a EUR version on 4.4. Following this guide: https://gbatemp.net/threads/tutorial-installing-rxtools-custom-firmware-3ds-and-2ds.390867
    Managed to setup the sdcard, install emuNAND, install rxtools, Inject FBI into emuNAND and sysNAND. Update emuNAND to 10.3. Install sysupdater to sysNAND and update it to 9.2
    And finally install themehax to coldboot directly into the emuNAND.
    So I know it can be done!

    3DS 1: Had the original 1.0.0 FW. No browser, and camera has no QR scanner. Updated with a game cart to 4.5.0. Because it had never accessed the net, still no browser or QR mode.
    Messed up and ended up upgrading to 10.3.
    Sky3ds+ ordered.

    3DS 2: Is on fw 4.5.0-10U. Managed to use the MSET exploit, Install Rxtools, Inject FBI into Emunand, Update Emunand to 10.3.
    I can't inject FBI into Sysnand. Keep getting a "Health & Safety missing!" error message.
    Have tried rxtools 2.5.2, 2.6 and 3.0.

    Followed: https://gbatemp.net/threads/release...ect-generator-jpn-usa-eur-chn-kor-twn.391525/
    Kept getting "Input FAT16 XORpad file is not valid" error. Until I realised that I needed to dump the sysNAND via rxtools and not use the Gateway NAND backup.
    Managed to run everything, and now have a NAND.bin with FBI injected. Injected this NAND into my emuNAND, and it works fine.

    I can't seem to figure a way to write it to the sysNAND.
    Gateway gives me a "NAND.BIN error" message. I'm guessing it can't recognise it as it's not been dumped by GW.

    Tried doing all this with linked and unlinked NANDS .
    Using GW, flashed the original NAND backup and tried FBI Injection again, still getting the Health & Safety missing error.

    Any suggestions?