Help/Guide needed to update emunand to highest compatible version [as of April 2016]

Discussion in '3DS - Homebrew Development and Emulators' started by Elbarto1, Apr 5, 2016.

  1. Elbarto1
    OP

    Elbarto1 Member

    Newcomer
    15
    3
    Mar 25, 2016
    United States
    Hello, first off, thank you for this great community and all of your hard work and contributions. Please forgive my ignorance, I am returning to the 3ds scene after a long while away and am trying to learn a lot of what has been happening the last few years. Its sometimes tough to tell the difference between current active methods and older outdated methods so please bare with me.

    My issue: I am currently running o3ds with 9.2.0U sysnand and 9.2.0U EmuNand. I am interested in updating my emunand to 10.3 (or higher if not blocked) but am unsure of how to do so.
    I've read that I can boot into emunand and update normally with systemupdater but that would take me to 10.6, and if i am understanding this properly, that would block many homebrew apps from loading.

    Is there a way to update emunand without going through the internet/nintendo servers?
    could i load a firmware update on my SD card and install it that way?
    please forgive me if this is common knowledge, i was unable to find any current answers to this issue and dont want to lose homebrew access because of a outdated or patched method.

    Also, how do I "UNLINK" the 2 nands before applying any updates?

    Thank you!
     
  2. Minnow

    Minnow GBAtemp Fan

    Member
    462
    710
    Oct 5, 2015
    Canada
    Use TinyFormat to unlink NAND's. Update emuNAND normally in System Settings. That's about it.
     
  3. Elbarto1
    OP

    Elbarto1 Member

    Newcomer
    15
    3
    Mar 25, 2016
    United States
    Thank you.
    And updating emunand to the current firmware won't lock me out of any homebrew options?
     
  4. bi388

    bi388 GBAtemp Advanced Fan

    Member
    752
    326
    May 29, 2015
    United States
    If you have fbi installed you can install a homebrew launcher cia to run homebrew, so no it won't. Some homebrew can only be run on <=9.2 firmware but your sysnand will still be 9.2 for them
     
  5. Quantumcat

    Quantumcat Dead and alive

    Member
    11,821
    6,349
    Nov 23, 2014
    Australia
    Canberra, Australia
    What Elbarto said plus many homebrews can be installed as CIA as well (making it a bit faster to launch).
     
  6. wurstpistole

    wurstpistole N3DS B9S

    Member
    2,667
    971
    Nov 19, 2015
    Gambia, The
    Update your cfw, make emunand backup with Emunand9, go to system settings in Emunand and update. Done.
     
  7. Salamencizer

    Salamencizer Cute Hot Whatever

    Member
    795
    714
    Oct 3, 2015
    India
    In your heart
    You are on 9.2? Nice. GET INTO THE A9LH MASTER RACE ASAP
     
  8. Uziskull

    Uziskull Picture may not be real

    Member
    269
    179
    Nov 15, 2015
    Portugal
    Somewhere, probably
    Off-topic. Don't.
     
  9. Joom

    Joom  ❤❤❤

    Member
    4,285
    2,944
    Jan 8, 2016
    United States
    Why do people say this to the obviously inexperienced? It's really annoying.
     
    GBAFail likes this.
  10. bi388

    bi388 GBAtemp Advanced Fan

    Member
    752
    326
    May 29, 2015
    United States
    Or at all. If someone wants to use menuhax let them, it's like PC master race except with less legitimacy.
     
    GBAFail likes this.
  11. Elbarto1
    OP

    Elbarto1 Member

    Newcomer
    15
    3
    Mar 25, 2016
    United States
    What are the pros/cons of A9LH?
    And thank you for the tips. I'll try tiny format and update normally.
     
  12. Quantumcat

    Quantumcat Dead and alive

    Member
    11,821
    6,349
    Nov 23, 2014
    Australia
    Canberra, Australia
    Read the introductory pages at https://github.com/Plailect/Guide/wiki and the FAQ. The pros are numerous - everything that comes from basically having a brick-proof legit system with CFW on top of it. The cons are the length of time it takes to set up, and also it makes Gateway more difficult to use (not a con if you don't own a Gateway cart).
     
  13. Elbarto1
    OP

    Elbarto1 Member

    Newcomer
    15
    3
    Mar 25, 2016
    United States
    Sounds interesting, I'll look into that. Thank you.
    Question: I managed to update emunand to 10.7 but now I can't access the eshop through homebrew launcher without it prompting me for a update.
    I've tried on both sysnand 9.2 and emunand 10.7
    Should I allow the eshop update?
    Is that normal or did I error somewhere?
    Thank you.
     
  14. Joom

    Joom  ❤❤❤

    Member
    4,285
    2,944
    Jan 8, 2016
    United States
    Why are you trying to run it through the HBL?
     
  15. Elbarto1
    OP

    Elbarto1 Member

    Newcomer
    15
    3
    Mar 25, 2016
    United States
    Because I don't know what the hell I'm doing I guess, lol.
    Should I just be launching it normally while in emunand?
    I am always over cautious when messing around with stuff I don't fully understand to avoid bricks.
    I won't ever just accept a update without being sure it will not lock me out or brick.
    So, forgive my ignorance, is it ok to just use eshop on 10.7 emunand as if it were a normal 3ds and not a cfw?
    Thank you.
     
  16. Margen67

    Margen67 Dirty entited pirate

    Banned
    1,100
    4,589
    Nov 3, 2014
    United States
    Why not?
    If a newb does research they should be able to follow the guide.
    The problem with that is people are paranoid about bricking with A9LH when they shouldn't be.
    These delusions of bricking, or having the Sysnand CFW magically be patched need to end. They're just silly.
     
  17. Quantumcat

    Quantumcat Dead and alive

    Member
    11,821
    6,349
    Nov 23, 2014
    Australia
    Canberra, Australia
    Yes you can just use the eShop normally. Using the homebrew thing is for when you're trying to access the eShop on a lower firmware than the current one.
     
  18. Elbarto1
    OP

    Elbarto1 Member

    Newcomer
    15
    3
    Mar 25, 2016
    United States
    Great! Thank you for explaining.

    If that is the case, why does it prompt me for a update when I'm on 9.2 sysnand now though when it worked before?
    Is that because I formatted with tinyformat?
    Should I never update that one?
    Does it even matter if I can now access with 10.7 emunand?

    Thanks!
     
  19. Joom

    Joom  ❤❤❤

    Member
    4,285
    2,944
    Jan 8, 2016
    United States
    It never asked because you had linked NANDs (I assume). And yes, never update SysNAND, only EmuNAND.
     
  20. Elbarto1
    OP

    Elbarto1 Member

    Newcomer
    15
    3
    Mar 25, 2016
    United States
    Understood. Thank you all for your help so far. It is appreciated immensely!

    — Posts automatically merged - Please don't double post! —

    Well this is strange, I boot into emunand 10.7 with rxtools.
    I check the system settings to be sure and it shows rx-e 10.7
    BUT, when I exit the system settings it kicks me back to sysnand 9.2
    That doesn't sound normal, does it?
     
    Quantumcat likes this.