HELP! Cyan! Anyone! Sneek and USB Loader Gx to run Virtual Console Games - PAL system

Discussion in 'Wii - Hacking' started by azraellives, Dec 20, 2018.

  1. azraellives
    OP

    azraellives Newbie

    Newcomer
    1
    Dec 20, 2018
    United Kingdom
    Hello,

    This is my first post and the very first question that I am asking on this site. Its a great community and I hope that someone can help me out with my Wii modding situation.

    I have a Wii that I have soft modded and it runs Wii and Gamecube games using usb Loader GX and Nintendont. I am trying to get Virtual Console Games to work. None of the NES, SNES, Neo-Geo or GENESIS games work. I have tried installing a few PAL games to see if the region was an issue, but all I get is a black screen when I try running them through USB Loader gx. I have tried installing them with the emu wad manager in usb loader gx and with Multi Mod Manager.

    I have tried to install SNEEK-DI and have followed an excellent guide here on GBAtemp called 'Creating and using EmuNAND with USBLoaderGX
    cIOS - Neek - Neek2o'
    to use an Emu-nand and Sneek, but all I get when booting sneek from USB Loader GX is a black screen with a flashing blue light from the Wii.

    I have an 8GB SD card and the nand folder with the dumped Emunand is in the root of the SD Card. There is a usb hard disk (500 GB NTFS) with a wbfs folder with all my wii games and they run just fine. A whole bunch of Wiiware games are working like Arkanoid Plus, Contra Rebirth Puzzle Bobble Plus. These are NTSC Virtual Console wads that work after switching ciOS to 250 in the game Settings menu.

    Here is the sysCheck Report :

    Warning: Spoilers inside!

    I would really appreciate some help with this as I have spent more than a month trying to get this to work.

    Cheers!
     
  2. AceyBwoi

    AceyBwoi GBAtemp Regular

    Member
    4
    Feb 9, 2014
    Bedroom
    I am not sure but on my wii and wii u i have installed a ntsc version of bubble bobble vc and it loads fine via usb loader gx
     
  3. azraellives
    OP

    azraellives Newbie

    Newcomer
    1
    Dec 20, 2018
    United Kingdom
    'Bubble Bobble Plus!' works fine, its the NES SNES and NEOGEO ones for example that aren't running at the moment.
     
  4. azraellives
    This message by azraellives has been removed from public view by Cyan, Dec 21, 2018, Reason: be patient.
    Dec 21, 2018
  5. AmandaRose
    This message by AmandaRose has been removed from public view by Cyan, Dec 21, 2018, Reason: reply to a deleted post.
    Dec 21, 2018
  6. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    22
    Oct 27, 2002
    France
    Engine room, learning
    you made a copy of your NAND first?
    installing wad on an empty folder will not work, you need to copy all your console's memory into a folder for the loader to use it as if it was your real console's content.
    it's using a redirected file access using the cIOS emuNAND module.


    don't put the dumped folders to the root of SD card.
    put it here :
    sd:/nands/01/ all dumped folders here.
    then go to usbloadergx and edit the path.

    OR
    edit the path first, then choose "dump nand" from the features menu.
    then it'll work.

    Do not use neek mode by default, it's not required.
    neek is needed mostly for neogeo and N64. not for snes, nes, or other consoles.
    first, you need to have the cIOS mode working before wanting to use neek mode.


    like you might have noticed, you are missing cIOS 249 ! if you use it, it'll black screen or reboot.
    go to your loader's setting and set the game's IOS to 250.


    To me, you did a random mixing setup, while it could be easier.

    1. you miss 249
    2. you choose 250 in the "game settings" which means individually ? you can do it globally
    3. you use root of SD (neek2o requires 2 subfolders)
    4. you probably tried to change some video mode or random settings to fix issues you shouldn't have if you setup correctly from the beginning.

    I recommend:
    1. install d2x base57 r52 in slot 249
    2. reset USBLoaderGX settings
    3. set emuNAND path to nands/01/ (wait, if you use r1271 it'll use that path ! no need to edit it anymore if you reset it'll do it for you)
    4. make a new nand dump full in that path

    that's all. now, try your VC/WiiWare. if one is not working, look on that page to see if it's a known issue and you need neek or not :
    http://wiki.gbatemp.net/wiki/Wii_cIOS_EmuNAND_Compatibility_List

    Do not try neek if not needed.
    if you need neek, only enable it individually, not globally.

    if you need neek, it's very easy but there's no proper guide. You'll have to follow one of my old outdated guide.
    apparently, you didn't even managed to follow it properly, so please, don't try again. Ask first.
     
    Last edited by Cyan, Dec 21, 2018
    scooby74029 likes this.
  7. azraellives
    OP

    azraellives Newbie

    Newcomer
    1
    Dec 20, 2018
    United Kingdom
    Thanks for replying, Cyan. I do appreciate it. That was a good shout, I didnt have IOS 249! I installed IOS249[57] (rev 21010, Info: d2x-v10beta52), thats what the sysCheck says btw.

    The NES and GENESIS Virtual Console games still don't work. After installing ISO249, the VC/Wiiware games that I did have installed, disappeared. That doesn't matter, as I can install them again. I thought it was a point worth noting and might help in investigation.

    I installed Super Mario Bros. 3 (PAL) and Wonder Boy Monster World (NTSC) using usb-loader gx's wad manager.
    These give me a black screen when loading and I have to perform a hard reset the wii.

    I installed Contra Rebirth (PAL), which was working as before. Now I do not need to select IOS 250 in the game settings menu. Thank you for that recommendation!
    This is the same situation as before. I'm pretty new to Wii modding so please excuse me if I have made some mistakes as some of the guides are over 7 years old! Searching and piecing together information as I started with short youtube videos made my situation unique and did not help.

    I have also tried the Sneek option from the features menu after dumping the emunand to sd:/nands/01 like you recommended. This still gave me a black screen.

    If you have any more suggestions, I am all ears as I really want to get the Virtual Console games working.
     
  8. lurkerer

    lurkerer Advanced Member

    Newcomer
    1
    Jan 12, 2016
    Took me a while to get it working, but I used a region changer on my PAL Wii to get ntsc titles working at 60hz- I'll find the instructions I wrote for myself in a bit.
     
  9. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    22
    Oct 27, 2002
    France
    Engine room, learning
    enabling the neek option is not enough, you need additional files on your SD or USB.

    I'm not sure why your old games disappeared, it shouldn't happen. maybe a wrong setting in the loader (favorite, category, parental control level, different path, etc.)
    without all the informations at the same time, it's hard to find what's wrong. it's easier if I have all the devices, data, and files myself, but it's harder when helping someone else without seeing what's been done, what appears on screen, etc.
     
Quick Reply
Draft saved Draft deleted
Loading...