Heavy corruption on GBA only games, GBC games play fine

Discussion in 'GBA - Hardware, Devices and Utilities' started by Cuelhu, May 13, 2017.

  1. Cuelhu
    OP

    Cuelhu GBATemp's Pepelatz Driver

    Member
    547
    15
    May 19, 2010
    Brazil
    Fantasy Land
    Guys, I've got this faulty GBA cheap in hope to repair it, but this problem I've never heard of. The system plays GB and GBC games like it should, but when I try to play GBA games, It loads the tiles ramdomly, making the screen garbled, very messed up. The sound is terrible as well (watch out, headphone users). The GBA carts play on other systems, as I have 1 AGS-101, 2 AGS-001, and 1 AGB-001 to test.
    Ez-Flash IV doesn't even boot on it, I get just a blank screen.

    I've got a video of it, so you can see what happens:



    Though, the mess is random. The screen where you should choose your save slot sometimes have a dying Mario (instead of the one swimming on the video). I thought of BIOS corruption, but the GAMEBOY logo from the boot up is OK, and GBC games work fine (tried the two aspect ratios as well).

    GBATemp, you're my only help!

    Thanks for your attention.
     
    Last edited by Cuelhu, May 13, 2017 - Reason: warning for terrible sound
  2. Dionicio3

    Dionicio3 Some Cool Skiddo

    Member
    3,198
    5,286
    Feb 26, 2017
    United States
    Hollister, CA
    Open it up and send nudes pictures of the mother board
     
  3. Shadow#1

    Shadow#1 Wii & 3DS Softmod Expert

    Member
    3,993
    1,127
    Nov 21, 2005
    United States
    Yea good idea
     
  4. Cuelhu
    OP

    Cuelhu GBATemp's Pepelatz Driver

    Member
    547
    15
    May 19, 2010
    Brazil
    Fantasy Land
    Sorry for the delay, as I was at work, but I'm at home already.
    Pics can be seen here or inside the spoiler.
    Warning: Big images! Broadband only.
    Warning: Spoilers inside!

    As you can see, there is a lot of manual solder, and the cartridge slot was probably replaced.
     
    Last edited by Cuelhu, May 13, 2017 - Reason: hgnnn
  5. Coto

    Coto GBAtemp Addict

    Member
    2,379
    419
    Jun 4, 2010
    Chile
    I had a GBA SP that didnt load flash/sram/eeprom, while carts were OK.

    turns out I had to resolder ARM AGB CPU pins, everything is fine now.

    If the GBA bios shows up then it's likely what I said!
     
    Last edited by Coto, May 13, 2017
  6. Dionicio3

    Dionicio3 Some Cool Skiddo

    Member
    3,198
    5,286
    Feb 26, 2017
    United States
    Hollister, CA
    Also, just to let you know, the reason why GB&GBC games work fine is because they use the CPU AGB arm chip, which is completely different from the chip GBA games use
     
  7. Coto

    Coto GBAtemp Addict

    Member
    2,379
    419
    Jun 4, 2010
    Chile
    [​IMG]
     
    Dionicio3 likes this.
  8. Cuelhu
    OP

    Cuelhu GBATemp's Pepelatz Driver

    Member
    547
    15
    May 19, 2010
    Brazil
    Fantasy Land
    Gosh, if I'd have to solder such tiny spots, I have to buy a smaller pointer.

    Just wanted to rule out video issues, as the screen works OK with them, so GBC part is fine.