Hacking HBL and large SD cards - issues

jhonnypolak

Active Member
OP
Newcomer
Joined
Oct 2, 2008
Messages
39
Trophies
0
XP
324
Country
Using HBL 2.0 on switch 3.0.0 and ive tried two cards:
Lexar 200GB and Evo 256GB.
I've tried formatting both to FAT32 and ExFAT and both 256k and 32k block size, and I always get HBL menu showing me there are no apps on the SD card.
However, when i setup a 32GB samsung card identically to the two above, it works flawlessly.

Is there a limit for HBL and its support for larger SD cards ?
 

Loke

Well-Known Member
Member
Joined
Jan 7, 2014
Messages
321
Trophies
0
XP
682
Country
Netherlands
Yes, the switch needs a patch to run SDXC.
Use a smaller card, there no use for large cards anyway.
 

leonmagnus99

Well-Known Member
Member
Joined
Apr 2, 2013
Messages
3,695
Trophies
1
Age
31
Location
Seinegald
XP
2,755
Country
Iraq
hey mate, i use a fat32 formatted sandisk mSD 200gb and it seems to work fine with hbl/and shows the nros within it e.g vba.
but it is quite unstable, both hbl/and the homebrew.

it is just fun for the first few times you get it running, wait for it to become more stable.
 
  • Like
Reactions: jhonnypolak

jhonnypolak

Active Member
OP
Newcomer
Joined
Oct 2, 2008
Messages
39
Trophies
0
XP
324
Country
My switch is patched for SDXC as the switch itself recognises both 200gb and 256gb cards. The hbl menu wouldn't load otherwise.
So that's not the issue.
 

leonmagnus99

Well-Known Member
Member
Joined
Apr 2, 2013
Messages
3,695
Trophies
1
Age
31
Location
Seinegald
XP
2,755
Country
Iraq
My switch is patched for SDXC as the switch itself recognises both 200gb and 256gb cards. The hbl menu wouldn't load otherwise.
So that's not the issue.
try the trick where you directly extract the hbl zip into the root of your mSD.
i did that and it launched fine and shows the stuff within the hbl.
 

RichKK

Well-Known Member
Member
Joined
Apr 26, 2015
Messages
113
Trophies
0
Age
53
XP
811
Country
United Kingdom
I am using a 128GB SanDisk SDXC microSD card with my 3.0.0 Switch running HBL and it works just fine.
I used a third party app to format the card called 'guiformat' if that helps. (Can't post links as a newbie, sorry)
I bought the switch second hand so I have no idea if the previous owner installed the small update to enable the use of SDXC cards but since I got it, it has never been connected to the internet.
I read in another thread here that the update to use the card is not the same as a system update and you will stay on your current FW after the card update, maybe research that option a little bit :-)
 

jhonnypolak

Active Member
OP
Newcomer
Joined
Oct 2, 2008
Messages
39
Trophies
0
XP
324
Country
Ok so what I did was (on Mac):
- Used Paragon Hard Disk Manager (10 day trial) to REMOVE the existing partition off the microsd card. That's right. I didn't set a new partition or format it into ExFAT or FAT32, i just remove the partition and left the card unformatted.
- I then inserted the microsd card into the switch. The switch automatically said this card needs to be formatted. I said yep, go ahead. The switch then restarted.
- Once the switch came back up, i turned it off completely.
- Took out the microsd card
- Put it in the PC and extracted hblmenu and ftp directly from zip files to the microsd card (which the switch formatted into exFAT by the way)
- Inserted the card back into the switch and installed pegaswitch as per usual.
- Console restarted
- I then tried to run pegaswitch activation and two times i got the 0002 error but then third time it launched perfectly fine seeing all apps :)

So I'm up and running :)
 
  • Like
Reactions: lordelan

JoseUg

Member
Newcomer
Joined
Oct 2, 2015
Messages
18
Trophies
0
Age
28
XP
91
Country
Mexico
hi , im having some issues with the hbl , the thing is that is not recognizing the card at all , i already try with fat32 , exfat and the clusters but it says that there are no apps on the sd card i dont know what to do
 

Draxzelex

Well-Known Member
Member
Joined
Aug 6, 2017
Messages
18,030
Trophies
1
Age
28
Location
New York City
XP
11,952
Country
United States
hi , im having some issues with the hbl , the thing is that is not recognizing the card at all , i already try with fat32 , exfat and the clusters but it says that there are no apps on the sd card i dont know what to do
Have you tried the following?
Connect your sd card to a windows PC and select everything inside.
Right click, properties, advanced, disable "folder/file is ready for archiving". Done.
 
General chit-chat
Help Users
    Halbour @ Halbour: lol