HBC keeps asking to upgrade to version 1.0.5?

Discussion in 'Wii - Hacking' started by melodical, Oct 2, 2009.

  1. melodical
    OP

    melodical GBAtemp Regular

    Member
    181
    0
    Jul 8, 2009
    Hi all,

    I let my mate borrow my wii about a week ago who has no wifi connection and have now just got it back.

    I have been out of the scene for about a week now and have read through quite a few posts on gbatemp and have noticed there were a few issues arising i.e system menu 4.2 and a new hbc and hackmii stuff.

    I'm NOT going to be updating to 4.2 just yet but have noticed that my hbc channel v.1.0.3 keeps prompting me to update to the latest hombrew channel version 1.0.5 everytime i reboot the wii into hbc and have previously said 'no'.

    I realise that it is important to istall the new hbc and do the new hackmii updates before updating using Waninkoko's SM_4.2 system menu updater!

    Do i currently need to update new hbc installer? Is it important as for now i'm staying on 4.1. (for a few weeks anyway! untill the whole 4.2 thing blows over!)

    What functionality would i lose i.e preloader & preloader hacks?
    Any other functionality?

    Would old & original .nand backup files still work?

    Lastly.......Is Waninkoko's SM update region specific? i.e do i need a pal version of his updater?

    Thanks in advance! [​IMG]

    System Menu: 4.1E
    Homebrew Channel: V1.03 (current!)
    Bootmii V: recent version:
    Preloader V: 0.29
    Waninkokos cIOS 38Rev14(249)
    Hermes V (for guaitar hero games)
    CIOSCORP has NOT BEEN INSTALLED!
     
  2. antonkan

    antonkan GBAtemp Maniac

    Member
    1,063
    8
    Jun 13, 2009
    Canada
    Burlington, ON
    The new version of HackMii Installer works in system menu 4.1 (including the new version of The Homebrew Channel). It won't brick your Wii.
     
  3. gamerjr

    gamerjr GBAtemp Regular

    Member
    247
    3
    Jan 7, 2008
    United States
    Im having the same problem but for some reason it wont let me update because it says that there is no vulnerable IOS's
     
  4. melodical
    OP

    melodical GBAtemp Regular

    Member
    181
    0
    Jul 8, 2009

    Not that i have installed CIOSCORP but!


    I just read that the error of 'no vulnerable IOS's' is normal it also said something about dopios. maybe linked to Cioscorp stuff, cant remember which post!
     
  5. KiiWii

    KiiWii GBAtemp Psycho!

    Member
    3,928
    1,438
    Nov 17, 2008
    United Kingdom
    http://www.gbatemp.net/index.php?showtopic=182894 im sure one of these will help.
     
  6. gamerjr

    gamerjr GBAtemp Regular

    Member
    247
    3
    Jan 7, 2008
    United States
    Tried it didnt work at all.
     
  7. longtom1

    longtom1 Keep an eye on my posts cause I quick edit frequen

    Member
    2,641
    0
    Jan 12, 2009
    Honey Oils inc.
    did you try the without cIOScorp method??
     
  8. KiiWii

    KiiWii GBAtemp Psycho!

    Member
    3,928
    1,438
    Nov 17, 2008
    United Kingdom
  9. longtom1

    longtom1 Keep an eye on my posts cause I quick edit frequen

    Member
    2,641
    0
    Jan 12, 2009
    Honey Oils inc.
    IOS36-64-v1042.wad is the original ios36 file from nintendo. Its vunerable and will allow bootmii
     
  10. bosman

    bosman GBAtemp Regular

    Member
    216
    0
    Nov 15, 2008
    I would update to 1.0.5 but I'm waiting for preloader to be fixed as I have read its looking for the HAXX channel ID.

    I also will be staying on 4.1e for now.
     
  11. technosexual

    technosexual Member

    Newcomer
    49
    0
    Dec 1, 2008
    United States
    rather than installing a clean ios3x, just install a clean ios61(dop-ios, wad from nusd) and if your hbc isnt using ios61(you can check by hitting home in hbc and checking the top right, bottom left if its flipped) uninstall and reinstalling hbc via hackmii installer

    it should then use ios61, which is only used by the shop channel and doesnt really need to be trucha or anything patched