Having some complications running Trucha Bug Restorer

Discussion in 'Wii - Hacking' started by web01, Jul 25, 2009.

  1. web01
    OP

    Newcomer web01 Newbie

    Joined:
    Dec 1, 2008
    Messages:
    6
    Country:
    United States
    Ok so i succesfully completed the first step of downloading IOS15.
    Im having trouble during the second step of installing a patched IOS36 as IOS249

    I get the following error message after it begins to install:

    Installing...
    .
    ES_AddTitleStart returned: -1035
    Has your installed IOS36 have a higher revision than 30947
    IOS36 Installation Failed
    Press any button to exit


    Any help or suggestions would be greatly appreciated.
     
  2. zektor

    Member zektor GBAtemp Maniac

    Joined:
    Nov 29, 2005
    Messages:
    1,325
    Country:
    United States

    Downgrade IOS15, exit TBR. Load it up again, and *change* it to load IOS15. Now go ahead and patch IOS36.
     
  3. web01
    OP

    Newcomer web01 Newbie

    Joined:
    Dec 1, 2008
    Messages:
    6
    Country:
    United States
    Thanks for the quick reply however thats what i have been doing all along so thats not the issue.
     
  4. Jeomite

    Member Jeomite GBAtemp Regular

    Joined:
    Jun 16, 2006
    Messages:
    215
    Location:
    United States
    Country:
    United States
    Do you have the necessary WADs in your root of your SD card for IOS36?
     
  5. web01
    OP

    Newcomer web01 Newbie

    Joined:
    Dec 1, 2008
    Messages:
    6
    Country:
    United States
    Yes have all the wad files on my SD card and my wii is connected to the internet so i tried downloading them from nintendo also just to be sure they were not faulty.

    My wii is version 4.1U if that helps.
     
  6. Jeomite

    Member Jeomite GBAtemp Regular

    Joined:
    Jun 16, 2006
    Messages:
    215
    Location:
    United States
    Country:
    United States
    Are the wads named the way Trucha Bug Restorer expects to be?

     
  7. zektor

    Member zektor GBAtemp Maniac

    Joined:
    Nov 29, 2005
    Messages:
    1,325
    Country:
    United States
    Did you previously have anything else on this Wii, or is it a brand new untouched (other than HBC installed of course) 4.1U Wii?
     
  8. web01
    OP

    Newcomer web01 Newbie

    Joined:
    Dec 1, 2008
    Messages:
    6
    Country:
    United States
    I had previously installed homebrew channel, boot mii and IOS249 using cIOS38_rev13-Installer.dol

    I was originally on 3.2U however i have since upgraded to 4.1 and now want to restore the trucha bug.

    Look at this video:
    http://www.youtube.com/watch?v=ltrd3oq8hPc...re=channel_page

    and skip to 2:10 thats exactly where my error occurs after if finds all the wad files my comment is first on top
     
  9. nabster92

    Member nabster92 GBAtemp Advanced Maniac

    Joined:
    Apr 16, 2009
    Messages:
    1,631
    Country:
    United States
    What are you trying to achieve by installing a patched IOS36 to IOS249 with this if you already installed cIOS rev13. I see no point in doing that at all. You have the trucha bug in IOS249 already if you installed rev13. You have no use for this unless you need to patch IOS36 itself for preloader or something.

    Edit: also in the video he is installing that to IOS36, not IOS249.
     
  10. web01
    OP

    Newcomer web01 Newbie

    Joined:
    Dec 1, 2008
    Messages:
    6
    Country:
    United States
    Since upgrading to 4.1 i can no longer install wads so that what i want to fix.
     
  11. nabster92

    Member nabster92 GBAtemp Advanced Maniac

    Joined:
    Apr 16, 2009
    Messages:
    1,631
    Country:
    United States
    If you really did install cIOS rev13 correctly before you should still be able to use wad manager 1.4 and have it use IOS249 to install wads.

    If not then properly follow the video and install an IOS36 with the trucha bug to IOS36, not IOS249. Then run the cIOS rev13 installer again and have that use IOS36 to install (automatically to IOS249).
     
  12. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    If you can't install wads anymore, your cIOS got corrupted somehow. The error message is wrong, thanks for the hint, the next version will fix that. But anyways, the Trucha Bug Restorer can't overwrite a cIOS, it installs as IOS249 revision 1, so it would be a downgrade, but i did not implement downgrade code for that yet. I'm considering doing that right now for the next version.

    How to fix that:
    Install a patched IOS36 and use AnyTitle Deleter to delete IOS249. And then do a clean reinstall with the cIOS installer.
     
  13. web01
    OP

    Newcomer web01 Newbie

    Joined:
    Dec 1, 2008
    Messages:
    6
    Country:
    United States

    Ok thanks I will try that solution and hopefully it works.

    Just one more question will I need to do anything extra to get installed wad channels to run from from the SD card option in the wii main menu? From what I have tried from some existing games i installed i get a failed to launch message when running from the SD.
     

Share This Page