1. rdsport323

    OP rdsport323 Member
    Newcomer

    Joined:
    Mar 1, 2007
    Messages:
    10
    Country:
    United States
    I bought a PS4 3 years or so ago with the intent of keeping it in my closet waiting for the day it can be hacked. Now that it's possible, I plugged it in and its 3.0 Firmware.

    Should I update to 4.55 or 5.05 firmware to hack it? Or is there any reason to keep it at 3.0? Are there any downsides from either one?

    Are there limitations to any of these firmwares?

    Thanks guys, sorry for the newb questions, this is all new to me.
     
  2. MostlyUnharmful

    MostlyUnharmful GBAtemp Fan
    Member

    Joined:
    Feb 8, 2018
    Messages:
    407
    Country:
    Italy
    If you want to tinker with it (researching PS4 internal) I think you can have some advantages with FW 4.05/4.55 as sometimes after FW 4.55 introduced some kind of SMEP/SMAP, also some people have the opinion that 4.55 was the most stable exploit evar. ^__^

    And trivially, recent titles can't run on older FWs unmodified (theoretically as I haven't seen such modifications myself), but you can runs some 4.55 titles on 4.05 though.
     
    rdsport323 and KiiWii like this.
  3. spotanjo3

    spotanjo3 GBAtemp Legend
    Member

    Joined:
    Nov 6, 2002
    Messages:
    10,870
    Country:
    United States
    You should. I had a 2.57 FW and I didnt regret update to 5.05. Are there limitations to any of these firmwares ? Well, the games up to 5.05 are fully playable. Any games that are above 5.50 are not playable. Right now, they have 5.50-5.55 fully exploitable in private. We dont know when they are release it yet.
     
  4. KiiWii

    KiiWii Reporter
    Reviewer

    Joined:
    Nov 17, 2008
    Messages:
    12,708
    Country:
    United Kingdom
    IIRC after 4.50 dumping PSID is not possible with flat z’s normal method.

    Game dumps can be downgraded using SDK of version you want to downgrade to as long as there are sufficient modules comparably. So 5.05 game can be downgraded to 4.55, if it doesn’t use anything too new from newer SDK than 4.55 compatible.

    Not many games can handle this.

    Imho 5.05 is the one to go for if you just want the biggest variety of games to play.
     
    Hayato213 likes this.
  5. rdsport323

    OP rdsport323 Member
    Newcomer

    Joined:
    Mar 1, 2007
    Messages:
    10
    Country:
    United States
    Thanks for the response. I read that PS4HEN is very buggy at 5.05, is that true?

    And once I jailbreak at 5.05, will I be able to downgrade to 4.55 if I wanted to? I think that was how the PS3 worked... once you have a CFW you are able to jump firmwares...
     
  6. KiiWii

    KiiWii Reporter
    Reviewer

    Joined:
    Nov 17, 2008
    Messages:
    12,708
    Country:
    United Kingdom
    In my experience: 5.05 is fantastic, never had an issue, especially if you use 5.05 X-Project Host v1.5 ;)
    (Link: https://gbatemp.net/threads/release-x-project-5-05-self-host.512046/ )

    You cannot downgrade, yet.
     
    Last edited by KiiWii, Sep 12, 2018
    Robhood19 likes this.
  7. Garou

    Garou GBAtemp Maniac
    Member

    Joined:
    Jan 13, 2015
    Messages:
    1,213
    Country:
    I thought 5.05 still has issue with USB devices. that's why I stick with 4.55
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - firmware, sitting, should