Has the 1.4 killed the DSTTi forever?

Discussion in 'DSTT' started by thilixD, Aug 28, 2009.

Aug 28, 2009
  1. thilixD
    OP

    Newcomer thilixD Advanced Member

    Joined:
    Apr 4, 2009
    Messages:
    52
    Country:
    United States
    My friend bought a dstti some months ago (whith is the only option in brazil for the time being), and now, with this nem update, he simply "lost" the flashcard? Is it killed? It will never have a fix?

    Thanks for the attention! [​IMG]
     
  2. Jacinto009

    Member Jacinto009 GBAtemp Regular

    Joined:
    Aug 4, 2009
    Messages:
    110
    Location:
    New York
    Country:
    United States
    I don't think so. I have been waiting for a long time to, and I came across this site that has version 1.18 for another DSTTi called TTi revolution upgrade or something like that. The 1.18 firmware doesn't work work on DSi FW 1.4, but this card seems to be getting more updates. Apparently the 1.18 firmware doesn't work on the DSTTi with the white cartridge (the one with the white cartridge and black sticker with the DSi in the background). You can check it out here nds-tti.com
     

Share This Page