Has Luma 6.2.3 broken some Region/Language settings for certain games?

Discussion in '3DS - Flashcards & Custom Firmwares' started by retrofan_k, Sep 22, 2016.

Thread Status:
Not open for further replies.
  1. retrofan_k
    OP

    retrofan_k GBAtemp Advanced Maniac

    Member
    1,818
    1,114
    May 31, 2013
    Belarus
    Caves
    Been experimenting tonight and updated one of my consoles, which was a EU old 3ds (a9lh) to 11.1 fw and Luma to the current latest 6.2.3.

    However, one particular title "Rhythm Heaven Megamix" that needs USA/EN enabled in order for it to boot on EU and JP consoles, otherwise it black screens, worked perfectly fine on Luma 6.01

    This game no longer boots with Luma 6.2.3 (black screen) even with the correct Region and Language setting and the setting enabled on boot (select)

    I reverted back to 6.0.1 (using the old backup payload) and it works again. So the question is, has some sort of compatibility been broken? I don't want to jump to conclusions and some more testing needs to be done, yet if others could test this, it be great.

    Thanks
     
    JCCG1989 likes this.
  2. Autz

    Autz GBAtemp Advanced Fan

    Member
    565
    264
    Feb 18, 2016
    Venezuela
    Luma right now is like a Wiki editing page.
     
    MelonGx likes this.
  3. hippy dave

    hippy dave BBMB

    Member
    2,598
    1,809
    Apr 30, 2012
    United Kingdom
    Rhythm Heaven Megamix is still working fine on my EUR N3DS, a9lh, 11.1, and luma 6.2.3 dev version. I set the region for the game when I installed it with Luma Locale Switcher and it's worked ever since.
     
  4. retrofan_k
    OP

    retrofan_k GBAtemp Advanced Maniac

    Member
    1,818
    1,114
    May 31, 2013
    Belarus
    Caves
    That's weird, as I have only noticed this now on 6.2.3 and nothing different was changed or added. I'll try the dev version anyway.
     
  5. retrofan_k
    OP

    retrofan_k GBAtemp Advanced Maniac

    Member
    1,818
    1,114
    May 31, 2013
    Belarus
    Caves
    Well, just had a look at my other console, which is a JP N3DS and a USA version of Zelda Majaora's mask doesn't work on 6.2.3, yet is fine on 6.0.1. All other CIA installed games that require the region & language applied seem to be okay on 6.2.3, so something is not right to why these two games in question are not booting for me.

    Edit: Any version above 6.1.2 will not work for me with these titles.
     
    Last edited by retrofan_k, Sep 23, 2016
  6. hippy dave

    hippy dave BBMB

    Member
    2,598
    1,809
    Apr 30, 2012
    United Kingdom
    Did you try the dev version? And you did reconfigure Luma's options on boot after changing Luma version, right? Besides that I can't think of anything.
     
  7. retrofan_k
    OP

    retrofan_k GBAtemp Advanced Maniac

    Member
    1,818
    1,114
    May 31, 2013
    Belarus
    Caves
    I tried the dev versions, deleted the config.bin, reconfigured luma's settings on boot on two separate consoles EU/JP, yet still no joy on anything above 6.1.2:unsure: Strange thing is, other titles work on the latest, so I'm stumped to why these two are giving me trouble on anything above 6.1.2. I even deleted them and re-download them via Freeshop, which made no difference either. :(
     
  8. Lilith Valentine

    Lilith Valentine GBATemp's Wolfdog™ ☠️Grunt☠️

    Member
    20,197
    21,576
    Sep 13, 2009
    Antarctica
    Between insane and insecure
    Have you tried asking on the official thread?
     
  9. retrofan_k
    OP

    retrofan_k GBAtemp Advanced Maniac

    Member
    1,818
    1,114
    May 31, 2013
    Belarus
    Caves
    I didn't no, as I made this thread last night before sleep and forgot to post there. I could ask a mod to merge this over instead of making a new one.
     
  10. Lilith Valentine

    Lilith Valentine GBATemp's Wolfdog™ ☠️Grunt☠️

    Member
    20,197
    21,576
    Sep 13, 2009
    Antarctica
    Between insane and insecure
    I mean, you could just ask to lock and then ask on that thread instead. If this is an actual bug, then it's best to be addressed on the official thread and submitted as a bug report so it can be properly addressed.
    It helps the project grow if the devs know there is a problem
     
  11. retrofan_k
    OP

    retrofan_k GBAtemp Advanced Maniac

    Member
    1,818
    1,114
    May 31, 2013
    Belarus
    Caves
    I just asked a mod about it. Thanks
     
    Lilith Valentine likes this.
Thread Status:
Not open for further replies.