Has anyone encountered this Skyward Sword glitch, when first entering Lanayru...

Discussion in 'Wii - Emulation and Homebrew' started by warpio, Nov 11, 2012.

  1. warpio
    OP

    warpio Member

    Newcomer
    11
    1
    Dec 22, 2008
    Canada
    I'm playing on Hero Mode, using the same emulator and settings I used for the first playthrough, but I must've did something different to make it glitch out. I can't enter Lanayru! When I dive down there for the first time, Fi asks me to select a bird statue. There are none, the Lanayru map hasn't been drawn yet and I'm stuck on that screen and can't do anything...

    Could my save file be messed up, or is there a known fix for this?
     
  2. OriginalHamster

    OriginalHamster UStealthy

    Member
    3,381
    641
    Nov 2, 2008
    Cote d'Ivoire
  3. Arras

    Arras GBAtemp Guru

    Member
    5,821
    2,637
    Sep 14, 2010
    Netherlands
    Sounds like a different problem from the OPs description.
     
  4. kylster

    kylster mich weich töten

    Member
    1,395
    32
    Sep 11, 2010
    United States
    Fr33D0M R1N6
    Nice that nintendo actually made a fix for something like this :) Reminds me of 1/2 ass'd PS3 titles being released that make us wait for patches to the obvious glitches in game lol
     
  5. warpio
    OP

    warpio Member

    Newcomer
    11
    1
    Dec 22, 2008
    Canada
    I managed to fix it by using this "Wii king 2" save file editor I found on google.
    http://forums.wiiking2.com/?topic=4.0

    Swapped out my current location with the location of the first save point in Lanayru... Even though I still don't know what caused it, oh well problem solved!
     
  6. OriginalHamster

    OriginalHamster UStealthy

    Member
    3,381
    641
    Nov 2, 2008
    Cote d'Ivoire
    Strange indeed, I've not seen it reported before, did you use ocarina cheats by chance?
     
  7. warpio
    OP

    warpio Member

    Newcomer
    11
    1
    Dec 22, 2008
    Canada
    I did try out various ocarina cheats that didn't end up working, and turned them off after. I guess those cheats might have screwed up my game somehow...