Has anyone else been having problems with L4D lately?

Discussion in 'Xbox 360 - Games & Content' started by War, Jan 22, 2009.

  1. War
    OP

    Member War Take it easy~

    Joined:
    Oct 26, 2007
    Messages:
    5,409
    Location:
    California
    Country:
    Japan
    Xcali and I were trying to play yesterday and it was HORRIBLE. In every single game we tried, campaign or versus, there would be this horrible lag. Players kept dropping out because of it, and the NPCs were non-responsive. We tried making new rooms, I tried hosting, he tried hosting, we even tried joining a different person's game and this stuff continued. Is it just us, or anyone else?
     
  2. nin10do

    Member nin10do GBAtemp Fan

    Joined:
    Dec 22, 2007
    Messages:
    471
    Location:
    UK
    Country:
    Taiwan
    hasn't happened to me.

    is your internet running fine? try running a speed test or something.
     
  3. Gaisuto

    Former Staff Gaisuto Lose 2 Levels.

    Joined:
    Oct 27, 2002
    Messages:
    5,925
    Location:
    Palm Coast
    Country:
    United States
    It happened to us yesterday too. I'm pretty sure it has to do with us being in North America while he's in Europe. [​IMG]
     
  4. War
    OP

    Member War Take it easy~

    Joined:
    Oct 26, 2007
    Messages:
    5,409
    Location:
    California
    Country:
    Japan
    Thing is, I never had any problems with playing with him before. it just recently started lagging us... but it was working perfectly fine before :
     
  5. MystikEkoez

    Member MystikEkoez GBAtemp Fan

    Joined:
    Sep 5, 2006
    Messages:
    346
    Location:
    Georgia
    Country:
    United States
    Speaking of L4D, if anyone would like form a group, send me a message...
     
  6. Canonbeat234

    Member Canonbeat234 Redeemed Temper

    Joined:
    Sep 24, 2008
    Messages:
    2,278
    Country:
    Japan
    Why don't anyone believe I hadn't played Left 4 Dead?!? I got the game for crying out loud!! >_
     
  7. triassic911

    Member triassic911 Burst Mode

    Joined:
    May 9, 2007
    Messages:
    2,743
    Location:
    NYC, USA
    Country:
    United States
    Most likely server issues.
     
  8. pilotwangs

    Member pilotwangs GBAtemp Maniac

    Joined:
    Jan 20, 2008
    Messages:
    1,025
    Country:
    United Kingdom
    Versus was slightly laggy for me last night (got disconnected twice) but it's been fine for me today.
     

Share This Page