GW 2.0b1 Downgrade Issue (but not on 2.0b2)

Discussion in '3DS - Flashcards & Custom Firmwares' started by STANirvanaIND, Feb 20, 2014.

  1. STANirvanaIND
    OP

    STANirvanaIND Member

    Newcomer
    20
    1
    Aug 4, 2007
    United States
    Hey Everyone,

    With the whole bricking fiasco and GW's 2.0 Final (hopefully) on the way soon I decided to take a bit of a break from my 3DS with beta2 on it until things died down a bit. A couple of days ago I decided I wanted to pick it back up again but that I should probably downgrade to b1 just to be on the safe side.

    I have a working EmuNAND install and 3 MicroSD cards I use with games on them, the same cards that have been working fine on every gateway launcher from 1.0 to 2.0beta2. Before downgrading I opened a game and everything seemed to be fine with my GW. After downgrading however only one of my MicroSD cards could be read, the other 2 wouldn't display any game on them (although the icon would spin so the 3DS knew something was inserted). I tried rewriting roms to the other 2 to no avail (using the same method I always use, DiskImager). For giggles I then tried rewriting to the card that was working and after that the card would no longer be detected with any game on it.

    After even that card didn't work I then tried putting the 2.0beta1 launcher back on my SD in case there was corruption in that and it didn't help, with the file I had originally used when it got released as well as redownloading it that day. Since that didn't work, I then tried testing them all again on 2.0beta2 and everyone of them read and started just fine, no issues at all.

    I know its not any sort of SD or MicroSD corruption so that can be ruled out. Does anyone know why this might be? Thanks.
     
  2. Keylogger

    Keylogger GBAtemp Advanced Maniac

    Member
    1,721
    366
    May 3, 2006
    France
    I have the exact same issue.

    I can't get any game working with Gw2.0b1 but everything is working great with same SD cards and 2.0b2
     
  3. gamesquest1

    gamesquest1 Nabnut

    Member
    14,120
    9,456
    Sep 23, 2013
    if your emunand is still set up to 7.1 it breaks region free for b1, so you may be using roms from a different region, you can copy all your saves etc off the SD and set up emunand again but keep it on 4.x this time, your game compatibility will be the same as with b2 and your region free etc will work
     
    Keylogger likes this.
  4. Bimmel

    Bimmel ~ Game Soundtrack Collector ~

    Member
    1,543
    832
    Jan 28, 2014
    Gambia, The
    I did the exact same thing with the downgrade, only with 1 MicroSD-Card - and it worked just fine.

    A working EmuNand means..? What Firmware?
     
  5. Keylogger

    Keylogger GBAtemp Advanced Maniac

    Member
    1,721
    366
    May 3, 2006
    France
    I use a 7.1 emunand but EUR roms with an EUR firmware.
     
  6. Bimmel

    Bimmel ~ Game Soundtrack Collector ~

    Member
    1,543
    832
    Jan 28, 2014
    Gambia, The
    Hm, okay. Let's try it like that.

    I got a white Nintendo 3DS XL with NAND on 4.5 / EmuNAND on the latest 7.1 firmware.

    Using the 2.01b version of the launcher.dat together with official Gateway-Card I get into EmuNAND Mode.

    I use DiscImager to write one game on the MicroSD-Card, size 32 GB (format it before using in FAT32). Then I put the cartridge in the device and start the game, always EU-Version. Only "error" is: Games dont start in german, english only. Thats all.

    Any difference with your approach?
     
  7. gamesquest1

    gamesquest1 Nabnut

    Member
    14,120
    9,456
    Sep 23, 2013
    7.1 causes many errors if used with b1, including messed up languages, region free is broken, and some of the system apps wont work
     
    Bimmel likes this.
  8. Pong20302000

    Pong20302000 making notes on everything

    Member
    8,076
    1,932
    Sep 8, 2009
    One's inner self
    thats because b1 patches are made to be used with 6.1>6.3 NAND, b2 patches are 7.0>7.1 NAND
     
    Bimmel likes this.
  9. Keylogger

    Keylogger GBAtemp Advanced Maniac

    Member
    1,721
    366
    May 3, 2006
    France
    But if you missed the 6.X update train and want to use b1, you have no choice and have to use a 7.1 emunand with many errors :S
     
  10. gamesquest1

    gamesquest1 Nabnut

    Member
    14,120
    9,456
    Sep 23, 2013
    an use 4.x emunand on b1, has all the same feature...or just remove emunand all together
     
  11. Pong20302000

    Pong20302000 making notes on everything

    Member
    8,076
    1,932
    Sep 8, 2009
    One's inner self
    well thats peoples fault
    as you didnt need the card to setup emuNAND
    and you can backup the SD to have multiple NAND images
     
  12. gamesquest1

    gamesquest1 Nabnut

    Member
    14,120
    9,456
    Sep 23, 2013
    they can just use b1 with 4.5 it performs just the same, it doesnt really matter what version of emunand you have.....as long as it isnt 7.x
     
  13. Pong20302000

    Pong20302000 making notes on everything

    Member
    8,076
    1,932
    Sep 8, 2009
    One's inner self
    if you have a 6.1>6.3 NAND with the b1 files you can play the newer SDK games such as Zelda, Batman and other Region versions that use the higher SDK which you cannot do on 4.5 +b1 IIRC
     
  14. gamesquest1

    gamesquest1 Nabnut

    Member
    14,120
    9,456
    Sep 23, 2013
    nope newer games still work even on 4.x with b1

    UPDATE: just double checked and newer games work fine with no emunand set up even, so if you want you can just remove your emunand partition and stick to playing with 4.x
     
  15. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,084
    8,586
    Oct 27, 2002
    France
    Engine room, learning
    6.x ROMs are working fine with 4.x (SysNAND or EmuNAND) + b1
    if you want to play a 6.x Cartridge but didn't update to 6.3.0 when you could, you can still update to 6.2.0 using the cartridge update feature while in emuNAND. it will not update the eshop revision, but you can't use it on 6.x anyway.