1. reiyu

    reiyu Canadian, eh?
    Member

    Joined:
    Jan 8, 2008
    Messages:
    861
    Country:
    Canada
    at this point there's 2 ways of getting you out of 8.1J

    1. wait for gateway to perfect their update to 10.3, i heard in some posts that it doesn't work for n3DS
    2. get a cheap sky3ds and use CN with the SOAP method up to 9.2.

    not sure of any other way to get you out of there...
     
  2. CrispyYoshi

    CrispyYoshi GBAtemp Advanced Maniac
    Member

    Joined:
    Mar 20, 2010
    Messages:
    1,539
    Country:
    United States
    Yeah, those are definitely my only options (besides Gateway natively supporting A9LH installation for 8.1J directly, which might or might not be a desirable route depending on what they release in the coming months)

    I'll hope for Gateway to provide a free (given what I have) solution, but otherwise I'll resort to Sky3DS if I decide I care enough to shell out $30 or so for an orange card.
     
  3. reiyu

    reiyu Canadian, eh?
    Member

    Joined:
    Jan 8, 2008
    Messages:
    861
    Country:
    Canada
    my bad, i did say orange button earlier. but i meant was red button. orange is the newest one that has the AP protection bypassed, so doubt you'll find that for $30.
     
  4. CrispyYoshi

    CrispyYoshi GBAtemp Advanced Maniac
    Member

    Joined:
    Mar 20, 2010
    Messages:
    1,539
    Country:
    United States
    Ah, good to know. Well, we'll see what happens! Thank you for the suggestions!
     
  5. reiyu

    reiyu Canadian, eh?
    Member

    Joined:
    Jan 8, 2008
    Messages:
    861
    Country:
    Canada
    no problem. just in case gateway doesn't deliver, you should grab the pack in this post before *knock on wood* it gets taken down:
    http://gbatemp.net/threads/guide-upgrading-8-1-0-0j-to-9-2-0-20j.384960/page-31#post-5876022
    save the instructions too as it's really spoonfeeding everything and you can't go wrong if you follow it to the dot.
     
  6. CrispyYoshi

    CrispyYoshi GBAtemp Advanced Maniac
    Member

    Joined:
    Mar 20, 2010
    Messages:
    1,539
    Country:
    United States
    Ah, good idea! Thank you very much for reminding me to do that: This could be really important in the future if it ever went down!
     
  7. CrispyYoshi

    CrispyYoshi GBAtemp Advanced Maniac
    Member

    Joined:
    Mar 20, 2010
    Messages:
    1,539
    Country:
    United States
    Ah, good idea! Thank you very much for reminding me to do that: This could be really important in the future if it ever went down!
     
  8. cearp

    cearp 瓜老外
    Developer

    Joined:
    May 26, 2008
    Messages:
    8,229
    Country:
    Tuvalu
    i guess you could install it first using gw before you upgrade/downgrade.
     
  9. reiyu

    reiyu Canadian, eh?
    Member

    Joined:
    Jan 8, 2008
    Messages:
    861
    Country:
    Canada
    is there a way to run this on OFW?
     
  10. cearp

    cearp 瓜老外
    Developer

    Joined:
    May 26, 2008
    Messages:
    8,229
    Country:
    Tuvalu
    ofw 8.1? with no gw or anything? no i don't think so.
     
  11. reiyu

    reiyu Canadian, eh?
    Member

    Joined:
    Jan 8, 2008
    Messages:
    861
    Country:
    Canada
    what's the point of having it installed then? i'm quite confused here.
     
  12. cearp

    cearp 瓜老外
    Developer

    Joined:
    May 26, 2008
    Messages:
    8,229
    Country:
    Tuvalu
    me too lol
     
  13. reiyu

    reiyu Canadian, eh?
    Member

    Joined:
    Jan 8, 2008
    Messages:
    861
    Country:
    Canada
    inb4 magikarp's splash gets a confusion chance in sun and moon.
     
    MelonGx, CrispyYoshi and cearp like this.
  14. evilpdor

    evilpdor Member
    Newcomer

    Joined:
    Jul 25, 2016
    Messages:
    13
    Country:
    Italy
    For ofw i try this method, but ATM is usless, i need more time/help to continue the reserch.

    I used fiddler2 in proxy mode, and I analyzed the traffic during the firmware update.
    Obviously now (and probably forever) it is impossible to analyze the traffic in SSL/TSL.

    Basically I was able to replace the url with the update files with versions of the same update downloaded from 3dnus. The 3DS don't see any difference, and download all update files from my PC.
    So i try to modify an update patckage switching the original native_firm 11.0.0 to original native_firm 10.4.0, but the update stop, it happens with any files that isin't for 11.0.0
    Currently you can then only 'save bandwidth' downloading from your PC the update files.

    The hope its to find a way to update offline the 3ds to any firmware.
     
  15. sneef

    sneef GBAtemp Regular
    Member

    Joined:
    Apr 10, 2006
    Messages:
    128
    Country:
    United States
    am i the only one that can't enter the pid commands in ntr debugger as written in the guide? unless i change the " to ', it errors out.. and after entering the three commands and returning "null" and then "finished" for each, i continued to settings, to attempt to update the n3ds as written in the guide.. however, sometime immediately after opening settings, my n3ds screen blinked green, and then the pc debugger app spat out this:

    starting app: 0004001000020000
    loading plugin: /plugin/game/savetool.plg, size: 00005000, addr: 07012000
    expand pool addr: 07012000, size: 00005000
    FSUSER_OpenDirectory failed, ret=c8804478
    Unable to read data from the transport connection: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
    Server disconnected.

    sounds to me like if i continue the update itll likely get the files from nintendo not my computer, am i right? or wrong? so annoying
     
  16. sneef

    sneef GBAtemp Regular
    Member

    Joined:
    Apr 10, 2006
    Messages:
    128
    Country:
    United States

    ok. i'm so gutted right now.. I followed instructions perfectly... i was having some issue with my own apache server, so i decided to use yours. I proceeded to

    connect ('192.168.1.82',8000) *that's my japanese n3ds IP address*
    listprocess ()

    nim was at 25, so i continued with the patching, using your server, cut and paste from your instructions and this is how it looked on my PC:

    > write(0x14E4F4, tuple(map(ord, "http://us92.jp81to92update.tk/\0")), pid=0x25)
    null
    finished
    > write(0x14E1BC, tuple(map(ord, "http://us92.jp81to92update.tk/\0")), pid=0x25)
    null
    finished
    > write(0x14E533, tuple(map(ord, "http://us92.jp81to92update.tk/\0")), pid=0x25)
    null
    finished
    starting app: 0004001000020000
    loading plugin: /plugin/game/savetool.plg, size: 00005000, addr: 07012000
    expand pool addr: 07012000, size: 00005000
    FSUSER_OpenDirectory failed, ret=c8804478
    Unable to read data from the transport connection: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
    Server disconnected.

    i proceeded to update, and MY N3DS is now at 11.0.0-33J!!! :(

    i have a NAND backup, but i'm pretty depressed right now.. i don't really have extra cash to pay for a hardmod etc., and I fail to see how this happened.

    I did the patching while on the home menu with debugging enabled (obviously), and only after the patching did i enter system settings, and proceed with the update, and at no time did I leave settings, once i had entered. shouldn't those addresses have been patched when i ran the update? HELP.. oh wait.. its too late for help.. :( who can assist me now, considering that i have a NAND backup from when i was on 8.1.0-00J? thanks!
     
  17. Oishikatta

    Oishikatta GBAtemp Advanced Fan
    Member

    Joined:
    Oct 30, 2014
    Messages:
    971
    Country:
    United States
    This is a very old thread now, I only had the domain registered for 1 year. That is not what you did wrong though - it would have simply given an error message and not done anything.

    I don't know why you followed the wrong instructions... check the link in my post you quoted. The domain and all of the memory addresses to patch for 8.1J to 9.2J were all different than what you used. The one you used was for someone already on 9.2J to add 9.2U files for region changing. If you had used the ones from the link you quoted nothing would have happened.

    In the first post of the thread it has been edited at the very top to show in bold:

    You will need to host the actual files as well as the responses on your own server to do this if you decide to get a hardmod.

    Here is thread listing hardmod installers by region if you decide to pay to have that done: https://gbatemp.net/threads/list-of-hardmod-installers-by-region.414224/
     
  18. ashinnblunts

    ashinnblunts GBAtemp Regular
    Member

    Joined:
    Jun 25, 2012
    Messages:
    119
    Country:
    United States
    I wrote a guide on how to update from this firmware.

    http://gbatemp.net/threads/tutorial-update-3ds-8-1-to-9-x.406407/

    You can also downgrade without a hardmod if you buy a $5 eshop game and have another 3DS with CFW.

    https://github.com/Plailect/Guide/wiki/DSiWare-Downgrade
     
  19. Oishikatta

    Oishikatta GBAtemp Advanced Fan
    Member

    Joined:
    Oct 30, 2014
    Messages:
    971
    Country:
    United States
  20. ashinnblunts

    ashinnblunts GBAtemp Regular
    Member

    Joined:
    Jun 25, 2012
    Messages:
    119
    Country:
    United States
    Yeah I guess I overlooked that.

    "Legends of Exidia: Works for USA + EUR (JPN title pulled from eShop)"
     
  21. sneef

    sneef GBAtemp Regular
    Member

    Joined:
    Apr 10, 2006
    Messages:
    128
    Country:
    United States
    dammit... arrgh.. anyway if the method involves a system transfer, i wouldn't be able to anyway, as i don't have a second japanese 3ds. thanks though! hardmod for me i guess. or i may sell this 11.0.0-33J n3ds on ebay or something, an order a new one which will be 8.1.0-10.7.0 i guess..

    thanks
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Upgrading, [GUIDE],