1. MezBar

    OP MezBar Member
    Newcomer

    Joined:
    Feb 26, 2019
    Messages:
    22
    Country:
    Italy
    Hello guys! I had the same issue of this thread:
    Practically, my joy-con and pro controller weren't synched anymore between EMUnand and SYSnand because I connected them to another console... so when I was switching from SYSnand to EMUnand (and vice versa) I had to redo the controllers pairing

    In that thread, that's a way to re-sync the joy-con but you have to transfer a file from EMUnand to SYSnand and for me it's not very safe... So I found a way to transfer that file from SYSnand to EMUnand and keep the SYSnand clean!

    So here is the tutorial:


    WARNINGS:

    SOMETIMES THIS TUTORIAL CAN LEAD TO THE "RED FIRST SETUP SCREEN" BUT DON'T PANIC! YOUR GAMES AND SAVES ARE SAFE, JUST COMPLETE THE SETUP AND EVERYTHING SHOULD BE AS BEFORE


    WE FIGURED OUT THAT SOMETIMES THE SCRIPTS DOESN'T WORK PROPERLY WITH THE NEW HORIZONTAL MODE IF YOU HAVE YOUR JOYCONS ATTACHED SO IS PREFERABLE TO REMOVE JOYCONS BEFORE USING THE SCRIPTS.
    I THINK THAT'S A TEGRA EXPLORER BUG AND NOW OUR'S, SO IN THE NEXT DAYS I'LL TRY TO REPORT IT TO THE DEV

    I DON'T ASSUME ANY RESPONSIBILITY IF SOMETHING GOES WRONG SO PLEASE FOLLOW THESE STEPS ONLY IF YOU KNOW WHAT ARE YOU DOING


    Preparation:
    Download the latest version of Tegra Explorer from here: https://github.com/suchmememanyskill/TegraExplorer/releases
    Download the right script according to your emunand from the attached files (and make sure you choose it right)

    Now choose what CFW are you using:​

    ATMOSPHERE:
    MAKE SURE YOU ARE IN AIRPLANE MODE ON EITHER SYSNAND AND EMUNAND, THIS PROCESS CAN "BREAK" YOUR DNS BECAUSE AS I KNOW, THE 8000000000000050 FILE CONTAINS ALSO WIFI AND OTHER SETTINGS AND THIS CAN LEAD TO BAN.
    IF YOU'RE USING INCOGNITO MODE, YOU DON'T NEED TO BE IN AIRPLANE MODE. (BUT IS RACCOMANDED TO DO THAT)



    1. Launch TegraExplorer.bin trough whatever you want (RCM loader, TegraRCM ecc…)


    2. Go to [SD:/] SD CARD -> tegraeplorer -> syncfix -> Syncfix.te -> Launch Script
    and follow the script instructions!

    3. DONE!


    If you pair your joy-cons/controllers to another console or you format your NAND (SYS or EMU), you have to launch again Syncfix.te to fix the sync issue!


    SX OS EMUNAND AS HIDDEN PARTITION:
    IF YOU'RE USING SXOS STEALTH MODE OR INCOGNITO MODE, YOU DON'T NEED TO BE IN AIRPLANE MODE.
    ON THE CONTRARY, IF YOU ARE NOT USING THOSE, YOU HAVE TO BE IN AIRPLANE ON EITHER SYSNAND AND EMUNAND BEFORE PROCEDING.



    DON'T USE TEGRAEXPLORER V2, INSTEAD USE THIS VERSION: https://github.com/suchmememanyskill/TegraExplorer/releases/tag/2.0.5

    1. Launch TegraExplorer.bin trough whatever you want (RCM loader, TegraRCM ecc…)

    2. Go to
    [SD:/] SD CARD -> tegraeplorer -> syncfix -> Preparation.te -> Launch Script
    and follow the script instructions!

    3. REBOOT TO TEGRA EXPLORER

    4. Go to
    [SD:/] SD CARD -> tegraeplorer -> syncfix -> Syncfix.te -> Launch Script -> Launch Script
    and follow the script instructions!

    5. DONE!


    You have to launch Preparation.te only the first time you follow this tutorial.
    (Obviously, if you delete the emuMMC folder, you have to launch Preparation.te again but… dunno why you should delete it)

    This script will create the following path on your micro sd:
    sd:/emuMMC/emummc.ini
    sd:/emuMMC/ER00/raw_based

    This script is necessary to let Tegra Explorer read/write on your emunand and won’t affect it nowise.
    If you pair your joy-cons/controllers to another console or you format your NAND (SYS or EMU), you have to launch again ONLY Syncfix.te to fix the sync issue!


    SX OS EMUNAND AS FILE
    IF YOU'RE USING SXOS STEALTH MODE OR INCOGNITO MODE, YOU DON'T NEED TO BE IN AIRPLANE MODE.
    ON THE CONTRARY, IF YOU ARE NOT USING THOSE, YOU HAVE TO BE IN AIRPLANE ON EITHER SYSNAND AND EMUNAND BEFORE PROCEDING.
    THIS SCRIPT IS TESTED ONLY ON FAT32 FILE SYSTEM, SO I DON’T KNOW IF IT WORKS ALSO ON EXFAT, LET ME KNOW IF THE EMUNAND CONFIGURATION IS DIFFERENT FOR EXFAT


    DON'T USE TEGRAEXPLORER V2, INSTEAD USE THIS VERSION: https://github.com/suchmememanyskill/TegraExplorer/releases/tag/2.0.5

    1. Launch TegraExplorer.bin trough whatever you want (RCM loader, TegraRCM ecc…)

    2. Go to
    [SD:/] SD CARD -> tegraeplorer -> syncfix -> Preparation.te -> Launch Script
    and follow the script instructions!

    3. REBOOT TO TEGRA EXPLORER

    4. Go to
    [SD:/] SD CARD -> tegraeplorer -> syncfix -> Syncfix.te -> Launch Script
    and follow the script instructions!

    5. DONE!


    You have to launch Preparation.te every time you follow this tutorial.

    This script will create the following paths on your micro sd:

    sd:/emuMMC/emummc.ini
    sd:/emuMMC/EF00/file_based
    sd:/emuMMC/EF00/eMMC

    Then, the script will move and rename all your Sxos emunand files from sd:/sxos/emunand/ to sd:/emuMMC/EF00/eMMC like this:

    sd:/sxos/emunand/full.00.bin -> sd:/emuMMC/EF00/eMMC/00
    .
    .
    .
    sd:/sxos/emunand/full.07.bin -> sd:/emuMMC/EF00/eMMC/07
    sd:/sxos/emunand/boot0.bin -> sd:/emuMMC/EF00/eMMC/boot0
    sd:/sxos/emunand/boot1.bin -> sd:/emuMMC/EF00/eMMC/boot1


    As I said, if you’re using exfat as your file system, please let me know if you have seven “full.XX.bin” files or less (or even more)!

    This script is necessary to let Tegra Explorer read/write on your emunand.
    As you can imagine, after launching Preparation.te, you aren’t able to boot to Sxos emunand, SO DON’T DO IT, just REBOOT TO TEGRA EXPLORER and launch Syncfix.te.
    In Syncfix.te there’s a part that will revert the process so you can boot to Sxos Emunand again!

    If you pair your joy-cons/controllers to another console or you format your NAND (SYS or EMU), you have to launch again FIRST Preparation.te, REBOOT TO TEGRA EXPLORER and THEN Syncfix.te to fix the sync issue!

    A HUGE thanks to Neville_Shorttop for porting the atmosphere version of the script to tegraexplorer v2! I added it to the attachment so everyone can now see it and run it safely.

    Unfortunately, the Sxos version is still not running on tegragraexplorer v2... so please, if you want to run the script safely on sxos, use this version of tegraexplorer until i'll update it to a newer version: https://github.com/suchmememanyskill/TegraExplorer/releases/tag/2.0.5


     

    Attached Files:

    Last edited by MezBar, Feb 24, 2021
  2. tom2199

    tom2199 GBAtemp Regular
    Member

    Joined:
    Apr 23, 2015
    Messages:
    255
    Country:
    Germany
    Thanks for the write-up! I had this annoying problem too, your tutorial worked straight away. I wonder why this isn't a widespread problem.
     
    MezBar likes this.
  3. MezBar

    OP MezBar Member
    Newcomer

    Joined:
    Feb 26, 2019
    Messages:
    22
    Country:
    Italy
    Most people don't notice this as a problem and keeps to re-sync controllers everytime... For me was a pain in the ass...
     
    Last edited by MezBar, Apr 15, 2020
    flowlapache and MarkDarkness like this.
  4. cearp

    cearp 瓜老外
    Developer

    Joined:
    May 26, 2008
    Messages:
    8,438
    Country:
    Tuvalu
    thanks for the guide, I moved my emunand save to sysnand and forget the steps I took, but this way looks nice.
    it's only a problem if you reformat sysnand or emunand.
    if you create emunand from sysnand and don't ever reformat one of them afterwards, you won't get this problem.
     
    MezBar likes this.
  5. MezBar

    OP MezBar Member
    Newcomer

    Joined:
    Feb 26, 2019
    Messages:
    22
    Country:
    Italy
    It's also e problem if you pair your joy-con to another switch so i think is very a common issue
     
    Last edited by MezBar, Apr 15, 2020
  6. tom2199

    tom2199 GBAtemp Regular
    Member

    Joined:
    Apr 23, 2015
    Messages:
    255
    Country:
    Germany
    Yeah, this must be it because I never reformatted either of my nands.
     
    Broduskii and cearp like this.
  7. MezBar

    OP MezBar Member
    Newcomer

    Joined:
    Feb 26, 2019
    Messages:
    22
    Country:
    Italy
    Me too! BTW if in the next weekend i have time, i'll write a Tegra Explorer script to automate the steps so the only thing people have to do is to launch the script to solve the issue
     
    Broduskii, MarkDarkness and swutch like this.
  8. BlackOmegaTM

    BlackOmegaTM Member
    Newcomer

    Joined:
    Jul 2, 2019
    Messages:
    25
    Country:
    Brazil
    I have this problem, but I won't even attempt the fix, as I have 3 switches in the house and pairing joycons from one on another is a daily ocurrence...
     
  9. DCMaxxx

    DCMaxxx Member
    Newcomer

    Joined:
    Sep 10, 2019
    Messages:
    17
    Country:
    France
    Thanks a lot !! This really helped me !!
     
    Last edited by DCMaxxx, Apr 22, 2020
    MezBar likes this.
  10. MezBar

    OP MezBar Member
    Newcomer

    Joined:
    Feb 26, 2019
    Messages:
    22
    Country:
    Italy
    Good news guys! I wrote the script to automatize the process!
    Now, if you want, you have only to launch the script whenever you want and *puff*, your controllers will be synched!
    Enjoy!
     
    flowlapache and MarkDarkness like this.
  11. logandzwon

    logandzwon GBAtemp Regular
    Member

    Joined:
    May 2, 2007
    Messages:
    107
    Country:
    United States
    This is really awesome! Thank you!
     
    MezBar likes this.
  12. MezBar

    OP MezBar Member
    Newcomer

    Joined:
    Feb 26, 2019
    Messages:
    22
    Country:
    Italy
    I'm chatting with tegraexplorer dev, the 8000000000000050 file contains not only Bluetooth settings and wifi settings but also other settings... So take all precautions before proceeding to this tutorial.
    Also, the dev told me that in future he will try to pull out only Bluetooth settings from that file so we can have a more safe process!
    Btw, for now, this tutorial is the only way to sync our controllers between the two NAND but please be careful!
     
    Last edited by MezBar, Apr 20, 2020
    cearp likes this.
  13. AD2076

    AD2076 GBAtemp Regular
    Developer

    Joined:
    Feb 19, 2019
    Messages:
    160
    Country:
    Italy
    It works.
    But after I did it and booted the emuMMC I got the "red first setup screen" and got scared. It only reconfigured date/time settings.
    A warning about it would be nice.
     
    MarkDarkness likes this.
  14. MezBar

    OP MezBar Member
    Newcomer

    Joined:
    Feb 26, 2019
    Messages:
    22
    Country:
    Italy
    Uhm, really strange, I tried it multiple times and no "red first setup screen" but hell yes, I will add it to the first post, thanks!
     
    AD2076 likes this.
  15. AD2076

    AD2076 GBAtemp Regular
    Developer

    Joined:
    Feb 19, 2019
    Messages:
    160
    Country:
    Italy
    Grazie
     
    MezBar likes this.
  16. OvOvOv

    OvOvOv Advanced Member
    Newcomer

    Joined:
    Oct 7, 2018
    Messages:
    66
    Country:
    Spain
    Be careful is u are using SX emunand in SD files. Dont delete the folder emuMMC (step 12) from the root your sd card or u will lose everthing!!! It happens to me...
     
  17. MezBar

    OP MezBar Member
    Newcomer

    Joined:
    Feb 26, 2019
    Messages:
    22
    Country:
    Italy
    I'm very sorry for this... I'll add this to the first post, thanks a lot
     
    OvOvOv likes this.
  18. RedHunter

    RedHunter GBAtemp Fan
    Member

    Joined:
    Dec 12, 2014
    Messages:
    438
    Country:
    Italy
    When I click on system I get this error:

    Function: mount_mmc
    Errcode: 13
    Desc: No Fat

    It means that my sd card needs to be formatted in fat?
    Or I can try using that script?
     
    Last edited by RedHunter, Apr 24, 2020
  19. MezBar

    OP MezBar Member
    Newcomer

    Joined:
    Feb 26, 2019
    Messages:
    22
    Country:
    Italy
    Isn't your sd formatted yet in fat32 or exfat?
     
    Last edited by MezBar, Apr 24, 2020
  20. RedHunter

    RedHunter GBAtemp Fan
    Member

    Joined:
    Dec 12, 2014
    Messages:
    438
    Country:
    Italy
    It's formatted in exfat. I don't want to deal with splitting the games so that's why I use it.

    What if I use another SD card formatted in fat32? I'm using emunand on the system partition tho, don't know if it's safe doing so.
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - [GUIDE], Pairing, emunand