Tutorial [GUIDE] Pairing the joy-con on emunand and sysnand

MezBar

Active Member
OP
Newcomer
Joined
Feb 26, 2019
Messages
26
Trophies
0
Age
25
XP
252
Country
Italy
Hello guys! I had the same issue of this thread:
Practically, my joy-con and pro controller weren't synched anymore between EMUnand and SYSnand because I connected them to another console... so when I was switching from SYSnand to EMUnand (and vice versa) I had to redo the controllers pairing

In that thread, that's a way to re-sync the joy-con but you have to transfer a file from EMUnand to SYSnand and for me it's not very safe... So I found a way to transfer that file from SYSnand to EMUnand and keep the SYSnand clean!

So here is the tutorial:


WARNING:

SOMETIMES THIS TUTORIAL CAN LEAD TO THE "RED FIRST SETUP SCREEN" BUT DON'T PANIC! YOUR GAMES AND SAVES ARE SAFE, JUST COMPLETE THE SETUP AND EVERYTHING SHOULD BE AS BEFORE

WE FIGURED OUT THAT SOMETIMES THE SCRIPTS DOESN'T WORK PROPERLY WITH THE NEW HORIZONTAL MODE IF YOU HAVE YOUR JOYCONS ATTACHED SO IS PREFERABLE TO REMOVE JOYCONS BEFORE USING THE SCRIPTS.
I THINK THAT'S A TEGRA EXPLORER BUG AND NOT OUR'S.

I DON'T ASSUME ANY RESPONSIBILITY IF SOMETHING GOES WRONG SO PLEASE FOLLOW THESE STEPS ONLY IF YOU KNOW WHAT ARE YOU DOING


Preparation:
Download the latest version of Tegra Explorer from here: https://github.com/suchmememanyskill/TegraExplorer/releases
Download the right script according to your emunand type from the attached files (and make sure you choose it right)


ATMOSPHERE:

MAKE SURE YOU ARE IN AIRPLANE MODE ON EITHER SYSNAND AND EMUNAND, THIS PROCESS CAN "BREAK" YOUR DNS BECAUSE AS I KNOW, THE 8000000000000050 FILE CONTAINS ALSO WIFI AND OTHER SETTINGS AND THIS CAN LEAD TO BAN.
IF YOU'RE USING INCOGNITO MODE, YOU DON'T NEED TO BE IN AIRPLANE MODE. (BUT IS RACCOMANDED TO DO THAT)



1. Launch TegraExplorer.bin trough whatever you want (RCM loader, TegraRCM ecc…)


2. Go to [SD:/] SD CARD -> tegraeplorer -> syncfix -> Syncfix.te -> Launch Script
and follow the script instructions!

3. DONE!


If you pair your joy-cons/controllers to another console or you format your NAND (SYS or EMU), you have to launch again Syncfix.te to fix the sync issue!



SX OS EMUNAND AS HIDDEN PARTITION:
IF YOU'RE USING SXOS STEALTH MODE OR INCOGNITO MODE, YOU DON'T NEED TO BE IN AIRPLANE MODE.
ON THE CONTRARY, IF YOU ARE NOT USING THOSE, YOU HAVE TO BE IN AIRPLANE ON EITHER SYSNAND AND EMUNAND BEFORE PROCEDING.



DON'T USE TEGRAEXPLORER V2 OR LATER, INSTEAD USE THIS VERSION: https://github.com/suchmememanyskill/TegraExplorer/releases/tag/2.0.5

1. Launch TegraExplorer.bin trough whatever you want (RCM loader, TegraRCM ecc…)

2. Go to
[SD:/] SD CARD -> tegraeplorer -> syncfix -> Preparation.te -> Launch Script
and follow the script instructions!

3. REBOOT TO TEGRA EXPLORER

4. Go to
[SD:/] SD CARD -> tegraeplorer -> syncfix -> Syncfix.te -> Launch Script -> Launch Script
and follow the script instructions!

5. DONE!


You have to launch Preparation.te only the first time you follow this tutorial.
(Obviously, if you delete the emuMMC folder, you have to launch Preparation.te again but… dunno why you should delete it)

This script will create the following path on your micro sd:
sd:/emuMMC/emummc.ini
sd:/emuMMC/ER00/raw_based

This script is necessary to let Tegra Explorer read/write on your emunand and won’t affect it nowise.
If you pair your joy-cons/controllers to another console or you format your NAND (SYS or EMU), you have to launch again ONLY Syncfix.te to fix the sync issue!



SX OS EMUNAND AS FILE
IF YOU'RE USING SXOS STEALTH MODE OR INCOGNITO MODE, YOU DON'T NEED TO BE IN AIRPLANE MODE.
ON THE CONTRARY, IF YOU ARE NOT USING THOSE, YOU HAVE TO BE IN AIRPLANE ON EITHER SYSNAND AND EMUNAND BEFORE PROCEDING.
THIS SCRIPT IS TESTED ONLY ON FAT32 FILE SYSTEM, SO I DON’T KNOW IF IT WORKS ALSO ON EXFAT, LET ME KNOW IF THE EMUNAND CONFIGURATION IS DIFFERENT FOR EXFAT


DON'T USE TEGRAEXPLORER V2 OR LATER, INSTEAD USE THIS VERSION: https://github.com/suchmememanyskill/TegraExplorer/releases/tag/2.0.5

1. Launch TegraExplorer.bin trough whatever you want (RCM loader, TegraRCM ecc…)

2. Go to
[SD:/] SD CARD -> tegraeplorer -> syncfix -> Preparation.te -> Launch Script
and follow the script instructions!

3. REBOOT TO TEGRA EXPLORER

4. Go to
[SD:/] SD CARD -> tegraeplorer -> syncfix -> Syncfix.te -> Launch Script
and follow the script instructions!

5. DONE!


You have to launch Preparation.te every time you follow this tutorial.

This script will create the following paths on your micro sd:

sd:/emuMMC/emummc.ini
sd:/emuMMC/EF00/file_based
sd:/emuMMC/EF00/eMMC

Then, the script will move and rename all your Sxos emunand files from sd:/sxos/emunand/ to sd:/emuMMC/EF00/eMMC like this:

sd:/sxos/emunand/full.00.bin -> sd:/emuMMC/EF00/eMMC/00
.
.
.
sd:/sxos/emunand/full.07.bin -> sd:/emuMMC/EF00/eMMC/07
sd:/sxos/emunand/boot0.bin -> sd:/emuMMC/EF00/eMMC/boot0
sd:/sxos/emunand/boot1.bin -> sd:/emuMMC/EF00/eMMC/boot1


As I said, if you’re using exfat as your file system, please let me know if you have seven “full.XX.bin” files or less (or even more)!

This script is necessary to let Tegra Explorer read/write on your emunand.
As you can imagine, after launching Preparation.te, you aren’t able to boot to Sxos emunand, SO DON’T DO IT, just REBOOT TO TEGRA EXPLORER and launch Syncfix.te.
In Syncfix.te there’s a part that will revert the process so you can boot to Sxos Emunand again!

If you pair your joy-cons/controllers to another console or you format your NAND (SYS or EMU), you have to launch again FIRST Preparation.te, REBOOT TO TEGRA EXPLORER and THEN Syncfix.te to fix the sync issue!


Unfortunately, the Sxos version is still not running on tegragraexplorer v2 or later... so please, if you want to run the script safely on sxos, use this version of tegraexplorer until i'll update it to a newer version: https://github.com/suchmememanyskill/TegraExplorer/releases/tag/2.0.5
 

Attachments

  • SyncfixSxosEmuAsPartition.zip
    5.4 KB · Views: 353
  • SyncfixSxosEmuAsFIle.zip
    5.6 KB · Views: 313
  • syncfix_v3 - Atmosphere.zip
    1.1 KB · Views: 43
Last edited by MezBar,

tom2199

Well-Known Member
Member
Joined
Apr 23, 2015
Messages
255
Trophies
0
XP
470
Country
Germany
Thanks for the write-up! I had this annoying problem too, your tutorial worked straight away. I wonder why this isn't a widespread problem.
 
  • Like
Reactions: MezBar

MezBar

Active Member
OP
Newcomer
Joined
Feb 26, 2019
Messages
26
Trophies
0
Age
25
XP
252
Country
Italy
Thanks for the write-up! I had this annoying problem too, your tutorial worked straight away. I wonder why this isn't a widespread problem.

Most people don't notice this as a problem and keeps to re-sync controllers everytime... For me was a pain in the ass...
 
Last edited by MezBar,

cearp

瓜老外
Developer
Joined
May 26, 2008
Messages
8,581
Trophies
1
XP
7,578
Country
Tuvalu
thanks for the guide, I moved my emunand save to sysnand and forget the steps I took, but this way looks nice.
Thanks for the write-up! I had this annoying problem too, your tutorial worked straight away. I wonder why this isn't a widespread problem.
it's only a problem if you reformat sysnand or emunand.
if you create emunand from sysnand and don't ever reformat one of them afterwards, you won't get this problem.
 

MezBar

Active Member
OP
Newcomer
Joined
Feb 26, 2019
Messages
26
Trophies
0
Age
25
XP
252
Country
Italy
thanks for the guide, I moved my emunand save to sysnand and forget the steps I took, but this way looks nice.

it's only a problem if you reformat sysnand or emunand.
if you create emunand from sysnand and don't ever reformat one of them afterwards, you won't get this problem.
It's also e problem if you pair your joy-con to another switch so i think is very a common issue
 
Last edited by MezBar,

BlackOmegaTM

Active Member
Newcomer
Joined
Jul 2, 2019
Messages
27
Trophies
0
Age
38
XP
138
Country
Brazil
I have this problem, but I won't even attempt the fix, as I have 3 switches in the house and pairing joycons from one on another is a daily ocurrence...
 

MezBar

Active Member
OP
Newcomer
Joined
Feb 26, 2019
Messages
26
Trophies
0
Age
25
XP
252
Country
Italy
I'm chatting with tegraexplorer dev, the 8000000000000050 file contains not only Bluetooth settings and wifi settings but also other settings... So take all precautions before proceeding to this tutorial.
Also, the dev told me that in future he will try to pull out only Bluetooth settings from that file so we can have a more safe process!
Btw, for now, this tutorial is the only way to sync our controllers between the two NAND but please be careful!
 
Last edited by MezBar,
  • Like
Reactions: cearp

AD2076

Developer
Developer
Joined
Feb 19, 2019
Messages
172
Trophies
0
XP
984
Country
Italy
It works.
But after I did it and booted the emuMMC I got the "red first setup screen" and got scared. It only reconfigured date/time settings.
A warning about it would be nice.
 
  • Like
Reactions: MarkDarkness

MezBar

Active Member
OP
Newcomer
Joined
Feb 26, 2019
Messages
26
Trophies
0
Age
25
XP
252
Country
Italy
It works.
But after I did it and booted the emuMMC I got the "red first setup screen" and got scared. It only reconfigured date/time settings.
A warning about it would be nice.
Uhm, really strange, I tried it multiple times and no "red first setup screen" but hell yes, I will add it to the first post, thanks!
 
  • Like
Reactions: AD2076

OvOvOv

Well-Known Member
Newcomer
Joined
Oct 7, 2018
Messages
66
Trophies
0
Age
37
XP
522
Country
Spain
Be careful is u are using SX emunand in SD files. Dont delete the folder emuMMC (step 12) from the root your sd card or u will lose everthing!!! It happens to me...
 

MezBar

Active Member
OP
Newcomer
Joined
Feb 26, 2019
Messages
26
Trophies
0
Age
25
XP
252
Country
Italy
Be careful is u are using SX emunand in SD files. Dont delete the folder emuMMC (step 12) from the root your sd card or u will lose everthing!!! It happens to me...
I'm very sorry for this... I'll add this to the first post, thanks a lot
 
  • Like
Reactions: OvOvOv

RedHunter

Well-Known Member
Member
Joined
Dec 12, 2014
Messages
440
Trophies
0
XP
1,526
Country
Italy
When I click on system I get this error:

Function: mount_mmc
Errcode: 13
Desc: No Fat

It means that my sd card needs to be formatted in fat?
Or I can try using that script?
 
Last edited by RedHunter,

MezBar

Active Member
OP
Newcomer
Joined
Feb 26, 2019
Messages
26
Trophies
0
Age
25
XP
252
Country
Italy
When I click on system I get this error:

Function: mount_mmc
Errcode: 13
Desc: No Fat

It means that my sd card needs to be formatted in fat?
Or I can try using that script?
Isn't your sd formatted yet in fat32 or exfat?
 
Last edited by MezBar,

RedHunter

Well-Known Member
Member
Joined
Dec 12, 2014
Messages
440
Trophies
0
XP
1,526
Country
Italy
Isn't your sd formatted yet in fat32 or exfat?
It's formatted in exfat. I don't want to deal with splitting the games so that's why I use it.

What if I use another SD card formatted in fat32? I'm using emunand on the system partition tho, don't know if it's safe doing so.
 
General chit-chat
Help Users
    Dark_Phoras @ Dark_Phoras: Do you mean those wooden boxes with the bottle inside?