[Guide] Hacking the Wii U without a GamePad

Discussion in 'Wii U - Tutorials' started by Hillbilleh, Apr 30, 2017.

  1. mive

    mive Member

    Newcomer
    2
    Jul 19, 2018
    Germany
    Thank you very much @Hillbilleh, it works for me (the dongle that I've used has this chipset: kernel: ieee80211 phy2: rt2x00_set_rt: Info - RT chipset 5592, rev 0222 detected). I've used the docker image from the github site because I dont have ubuntu/debian installed. Just compiled drc-sim-c and the needed "wpa tools" from drc-hostap. The two needed python packages were in distribution repository, so I could install them via package manager.

    The only minor issue(s) I encountered:
    - at first there was a weird firmware missing error in dmesg. removing and reloading the rt2800usb module fixed that error
    - first I didn't get video/audio in drc-sim-client and noticed audio and video error messages (invalid length or something like that) and after a few retries I remembered about firewall rules (iptables) and after flushing them I got audio and video
    - I also tried without docker image and with drc-sim python gui (just started with ./drc-sim-backend), but then wifi dongle didn't work (turned on, gui showed connected but immediately disconnected again), not sure whiy

    Performance seems ok for me, but I don't use virtual machine (but cpu usage was quite high. ~116% [1 core was fully used])
    I use systemd-networkd instead of NetworkManager and I didn't lose internet connection (on inbuilt wifi card)

    Also, unlike in your Video, after successful connection I could not press ok on the first confirmation screen (tried with pc and android client), but after I confirmed that screen via controller I could interact with the gamepad screen in the android app (didn't test pc drc-sim-client but I'm pretty sure it would have worked also).

    the long and short of it, thank you very much and also @rolandoislas (who probably doesn't read this, but nonetheless thank you rolandoislas).

    sorry for bad english.

    best regards,

    edit:
    my console was already "pre-setup", so cant say anything about usage after factory reset
     
    Last edited by mive, Feb 1, 2019
  2. Brayton

    Brayton GBAtemp Regular

    Member
    4
    Feb 6, 2016
    United States
    Is there a way to run it without gksu? I can't install gksu even as a .deb for some reason.
     
  3. mive

    mive Member

    Newcomer
    2
    Jul 19, 2018
    Germany
    try with sudo or if gui still wont work (because gtk wont run gui as root [see this: sorry i'm not allowed to post links here so you have to google something like "gtk gui root"]) you can always use without gui.

    first get keys with
    drc-sim-backend --verbose get_key Interface PinCode (e.g. drc-sim-backend --verbose get_key wlp0s29u1u2 1234) (pincode is shown on tv screen as card symbols and you have to convert them:
    ♠ (spade) = 0 ♥ (heart) = 1 ♦ (diamond) = 2 ♣ (clover) = 3
    Example: ♣♠♥♦ (clover, spade, heart, diamond) would equal 3012)
    --verbose shows more output in terminal, not necessary needed

    after this succeeded:
    drc-sim-backend --verbose run_server Interface OutInterface (e.g drc-sim-backend --verbose run_server wlp0s29u1u2 lo) (if you use lo as interface you can only connect locally from the same pc)
    --verbose is same as above

    edit:
    terminal should show something like this:

    ### get_key (with --verbose):
    ...
    2019-02-11 19:41:29,550 FINER:wpa CLI expect - scan results:
    ...
    34:af:2c:a1:64:fa 5240 -56 [ESS] WiiU34af2ca164f34af2ca164fa_STA1
    ...
    >
    2019-02-11 19:41:29,551 INFO:cli Connection status changed to CONNECTING.
    2019-02-11 19:41:29,602 DEBUG:wpa CLI expect waiting for wps_pin input confirmation
    2019-02-11 19:41:29,604 DEBUG:wpa CLI expect waiting for authentication
    2019-02-11 19:41:31,170 DEBUG:wpa PSK obtained
    2019-02-11 19:41:31,346 DEBUG:wpa Saving connection config
    2019-02-11 19:41:31,347 INFO:wpa Authenticated with the Wii U
    2019-02-11 19:41:31,347 INFO:cli Connection status changed to DISCONNECTED.
    2019-02-11 19:41:31,347 INFO:cli Successfully received PSK from the Wii U.
    2019-02-11 19:41:31,347 INFO:cli Stopping
    2019-02-11 19:41:31,347 EXTRA:drcsim Attempting to execute command ['killall', 'dhclient']
    2019-02-11 19:41:31,349 EXTRA:drcsim Failed to execute command "['killall', 'dhclient']" and got output "dhclient: no process found"
    2019-02-11 19:41:31,350 VERBOSE:drcsim Command "['killall', 'dhclient']" output dhclient: no process found

    2019-02-11 19:41:31,350 DEBUG:wpa Stopping psk pexpect spawn
    2019-02-11 19:41:31,501 DEBUG:wpa Stopping wpa process
    2019-02-11 19:41:31,502 EXTRA:drcsim Attempting to execute command ['killall', 'wpa_supplicant_drc']
    2019-02-11 19:41:31,507 VERBOSE:drcsim Command "['killall', 'wpa_supplicant_drc']" output
    2019-02-11 19:41:31,508 DEBUG:wpa Wpa stopped
    2019-02-11 19:41:32,016 INFO:drcsim Exiting


    ### run_server (without --verbose):
    2019-02-11 19:41:32,964 INFO:drcsim Initializing drc-sim-backend version 2.0
    2019-02-11 19:41:32,964 INFO:drcsim Using "/root/.drc-sim/" as home folder.
    2019-02-11 19:41:32,964 INFO:drcsim Enabling CLI
    2019-02-11 19:41:32,964 INFO:cli Starting server
    2019-02-11 19:41:33,990 INFO:cli Connection status changed to SCANNING.
    2019-02-11 19:41:41,068 INFO:cli Connection status changed to CONNECTED.
     
    Last edited by mive, Feb 11, 2019
  4. AlinaDoesStuff

    AlinaDoesStuff Newbie

    Newcomer
    1
    Mar 28, 2019
    Germany
    I can confirm that a Factory Reset Wii U can indeed be activated using DRC SIM
    I used a Broadcom BCM 4321 Chipset (mPCIE) it's an Apple Airport Extreme from an old iMac
    A Dual Core C2D is apprantly also enough to smoothly keep a connection, so good news!!!!

     
Loading...