[Guide] Community noob guide to Wii U hacking

Discussion in 'Wii U - Tutorials' started by Kafluke, Nov 29, 2016.

  1. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    21
    Oct 27, 2002
    France
    Engine room, learning
    I never used geckiine/cafiine/game modding tools.
    But it should work like this :

    1. I don't know if the patchers are working fine with haxchi or CBHC. they were released before haxchi existed, so it might include its own cfw patches and might not like having haxchi/cbhc already in memory. But it's just assumption, like I said I never used these tools.

    2. the principle is like this :

    On PC you run xcx (xenoblade modding tool), which will try to interact with the console.
    on the console, you run a background debugger tool (geckiine) which will act as communicator with the PC.
    then you launch the game, and in the background, the PC tool will tell the debugger to edit game's memory addresses (infinite HP, items, max power, etc.)

    in order for both to communicate, they need to know where to send commands to. either the PC needs your console's IP, or geckiine need the PC's IP.

    3. it's easier if you set fixed IP to both your console and PC, so you'll know the IP address to enter when asked for the "other device's IP".
    if not, then the tool sometime provide the "current IP of this device" that you need to specify in the other tool.
    for example, if homebrew tells you "your wiiu is 192.168.0.2" and xcx asks you the console's IP, this is the number you need to enter.
    on the other way, if homebrew asks you to enter the PC's IP, you need to know it. either xcx provides it, or you'll have to check your computer's info to get it if you didn't set fixed IP manually.


    4.
    so, apparently, when you launch geckiine it tells you "run cafiine with this IP".
    geckiine doesn't know you don't want to use cafiine, but want xcx instead. don't run cafiine on PC.
    run your xcx tool, and it should ask you the IP of the console to connect to. look at geckiine, it provided the IP you need to use in xcx.

    once everything is communicating with each other, launch the game.
    or launch the game before running xcx, I don't know.
     
    Last edited by Cyan, Jan 11, 2019
    Rodrigo2000 likes this.
  2. Escorpion

    Escorpion GBAtemp Regular

    Member
    3
    Aug 25, 2015
    Colombia
    Quindío
    Quick Question:
    On a Wii U (USA) with haxchi installed, can i install EUR eshop titles with no problems??

    Psdt: i want install Oddworld new ´n´ Tasty, which is only in EUR.
     
    Last edited by Escorpion, Jan 12, 2019 at 11:38 PM
  3. jeannotte

    jeannotte GBAtemp Fan

    Member
    3
    Jun 15, 2016
    France
    Hello,

    @Escorpion :

    I advise you to use the titles in the origin of the Wii U.

    Normally you should find it in USA version with Wii U USBhelper.
     
  4. azy77

    azy77 Advanced Member

    Newcomer
    3
    Apr 11, 2016
    @Escorpion I have a Pal WiiU with Haxchi and half my wiiu games are ntsc. Based on this, I don't think you'll have any issue...

    Btw New'n tastey has horrible slowdown in later levels almost like a slideshow.
     
  5. oldsk00l

    oldsk00l GBAtemp Regular

    Member
    2
    Oct 22, 2015
    Gambia, The
    Thank you @Cyan & @Kafluke my old Friends =D. This guide helped me alot to bring me up to date.
     
    Kafluke likes this.
  6. Sheep83

    Sheep83 Newbie

    Newcomer
    1
    Jan 3, 2019
    United Kingdom
    Hi all, back again.

    So mostly everything is going fine with my USB HDD setup, but have had a few issues with specific games. I keep getting the 'USB device has been disconnected' error with the following games:
    • Yoshi's Woolly World
    • Donkey Kong Country Tropical Freeze
    • Xenoblade Chronicles X
    The HDD has its own power supply and works perfectly with all other games I have tried. I ended up installing Yoshi and DK to the nand and they both work fine, so it's not a bad dump issue. I haven't tried Xenoblade on nand as it's too big.

    Also, BOTW would not work from the HDD with the DLC installed. It kept wanting to do a system update and erroring out because I have DNS blocking enabled. As soon as I uninstalled the DLC, it worked fine. I haven't tried this on nand either.

    Not a huge issue as I have plenty of games to keep me busy, just a minor irritation.

    Any ideas?
     
  7. Flaya

    Flaya GBAtemp Regular

    Member
    2
    Jul 15, 2015
    Make sure your HDD doesn't have spin-down. Can't remember how to disable it, but I remember having that issue before.

    Could try a different HDD otherwise.
     
  8. Sheep83

    Sheep83 Newbie

    Newcomer
    1
    Jan 3, 2019
    United Kingdom
    Thanks Flaya.

    I don't think it's a spin-down issue. The error happens at the exact same point with all games, less than a minute after loading. I have disabled HDD power saving through the Wii U's settings.

    I'm beginning to think it's a specific issue with the HDD. It's a fairly old Freecom 250Gb USB2.0.

    Definitely not a big enough issue to fork out for a new HDD.
     
  9. Rodrigo2000

    Rodrigo2000 Newbie

    Newcomer
    1
    Nov 4, 2017
    Brazil
    — Posts automatically merged - Please don't double post! —

    It worked for me. Thanks. Instead of running geckiine, I just went with tpc gecko and connected to xcx tool and it worked.
    Unfortunately, it seems I can't modify the achievements, which was my main concern. But I could do a lot of things anyway.
    Thanks for the help
     
    Cyan likes this.
Loading...