Homebrew RELEASE GUI for NSP Forwarder tool for 12+

shadow256

Well-Known Member
Member
Joined
Sep 30, 2017
Messages
123
Trophies
0
Age
35
XP
438
Country
France
Any chance for an image conversion toggle? The tool likes to compress the crap out of my icons and I did some experimenting with the original non-GUI version of the tool; I was able to get that one to leave the icon alone
I think this could be done easily but I don't have time to do it for now. A checkbox must be added and if it is check or uncheck (depend of the label) the script doesn't do the image conversion instructions (or don't resize the image but convert it in the correct image format, this second solution seems to be the best one) and copy the image in the appropriated folder.
 

unrealsead42

Member
Newcomer
Joined
Sep 4, 2021
Messages
5
Trophies
0
XP
29
Country
Brazil
Hi, i have tried on firmware 13.0 and AMS 1.1.1 and doesn't works anymore (in 13.0 and 1.1.0 worked fine) so i guess maybe some conflict to the new AMS.
There is some fix ti it?
Thnks!
 

shadow256

Well-Known Member
Member
Joined
Sep 30, 2017
Messages
123
Trophies
0
Age
35
XP
438
Country
France
Hi, i have tried on firmware 13.0 and AMS 1.1.1 and doesn't works anymore (in 13.0 and 1.1.0 worked fine) so i guess maybe some conflict to the new AMS.
There is some fix ti it?
Thnks!
Tested on Atmosphere 1.1.1 on firrmware 11.0.0 and no problem, do you have updated your sig_patches for Atmosphere 1.1.1?
 
  • Like
Reactions: unrealsead42

MainHaze

New Member
Newbie
Joined
Sep 29, 2021
Messages
3
Trophies
0
XP
9
Country
Canada
This is so awesome!

It was working super well for me, but I ran into an issue... I had the bright idea to change up my icons so recreated the rom forwarders with my new "artwork".

For some reason, now, whenever I make and install a forwarder, I keep getting the "Unable to play this game" error. It was working fine previously (although it was a bit hit or miss... some would work, some wouldn't).

As an alternative, I tried making a forwarder for the same game using Switch Army Knife. With that tool, the forwarder actually launches the game correctly. However, I don't see the game icon. I only see a question mark.

So basically, with NSP Forwarder Tool, my games won't launch, but I see the icons. With Switch Army Knife, the games DO launch, but I don't see my icons.

I'm using the same prod.keys file with each tool and my sigpatches are up to date. I'm on the latest firmware and atmosphere.

Any idea what's going on? I spent WAY too much time creating these new icons and I'd love to actually use them! :P
 

B-alpha

Well-Known Member
Newcomer
Joined
Jul 6, 2020
Messages
75
Trophies
0
Age
20
XP
507
Country
Germany
noticed the same thing. I resaved my pictures in jpg with paint, after that i could build my forwarders with "Switch Army Knife". Didn't try the other tool though.
 
  • Like
Reactions: MainHaze

MainHaze

New Member
Newbie
Joined
Sep 29, 2021
Messages
3
Trophies
0
XP
9
Country
Canada
noticed the same thing. I resaved my pictures in jpg with paint, after that i could build my forwarders with "Switch Army Knife". Didn't try the other tool though.
You, my friend, have just made my day!! Re-saving the JPG in MS Paint did the trick!

I wonder what kind of meta-data GIMP attaches to the pictures when exporting the original project to JPG that makes them not show up on the Switch menu.

Bah... whatevs! It's working now, so I'll chalk it up as one of the many unknown mysteries of the universe! Thanks again for the tip!
 

Lorraine14

New Member
Newbie
Joined
Sep 28, 2021
Messages
3
Trophies
0
Age
26
XP
11
Country
Argentina
I've got a fun one; it worked fine for me for like 10-15 forwarders.... now none of the forwarders that I make work.
Hi! The same thing happened to me, I made a lot of .nro files from Sega megadrive games and they all work perfectly. Then I did the same but with Snes, GBA and some applications, however none of these worked for me.

I tried to update the sigpatches again but it was still the same.

The solution was to re-download the 0.10b version pack, this time I did not do the Megadrive ones but I tried with Gba and now they work perfectly.

I did not get to try to create Snes or some other application, I will try that tomorrow but I think that, for the moment, we should have a pack of version 0.10b for different emulators.

It worked for me and I hope it worked for you and others too!
 

shadow256

Well-Known Member
Member
Joined
Sep 30, 2017
Messages
123
Trophies
0
Age
35
XP
438
Country
France
Hi! The same thing happened to me, I made a lot of .nro files from Sega megadrive games and they all work perfectly. Then I did the same but with Snes, GBA and some applications, however none of these worked for me.

I tried to update the sigpatches again but it was still the same.

The solution was to re-download the 0.10b version pack, this time I did not do the Megadrive ones but I tried with Gba and now they work perfectly.

I did not get to try to create Snes or some other application, I will try that tomorrow but I think that, for the moment, we should have a pack of version 0.10b for different emulators.

It worked for me and I hope it worked for you and others too!
More precisions could be interesting, I don't have time to test 15 or 30 forwarders creation. The most important thing to now is what was the settings of the last succesful game created before the script start to crash?
 

MainHaze

New Member
Newbie
Joined
Sep 29, 2021
Messages
3
Trophies
0
XP
9
Country
Canada
More precisions could be interesting, I don't have time to test 15 or 30 forwarders creation. The most important thing to now is what was the settings of the last succesful game created before the script start to crash?
I kinda had the same thing with this tool. I'd create a couple of forwarders, and they'd work. Then I'd try something else, and it wouldn't. Nothing would work afterwards either. The only thing that would get it to start making working forwarders again was to re-extract the downloaded tool to another folder. But for me, even that wouldn't work after a while.

It'd be great if this tool worked. But for me, I was only able to get working forwarders with Switch Army Knife.
 
  • Like
Reactions: Lorraine14

Lorraine14

New Member
Newbie
Joined
Sep 28, 2021
Messages
3
Trophies
0
Age
26
XP
11
Country
Argentina
More precisions could be interesting, I don't have time to test 15 or 30 forwarders creation. The most important thing to now is what was the settings of the last succesful game created before the script start to crash?
I think the moment I started creating forwarders from other emulators other than Megadrive it stopped working.

The only configuration that I changed at that time was the path of the core to use and the path of the corresponding roms.

Sorry if I'm not specific enough.

Just in case I inform you that I am using Windows 7 32 bits, Atmosphere 1.1.1 with CFW 13.0.0 & I install my .nro files through Awoo
 
Last edited by Lorraine14,

shadow256

Well-Known Member
Member
Joined
Sep 30, 2017
Messages
123
Trophies
0
Age
35
XP
438
Country
France
I think that a file is not backuped or restored correctly in some specific case, one time I have seen that an important file was deleted but it was during my developpement tests so I haven't paid attention to this, if I find some time I will investigate.

Edit: I think the problem was that the logo image file could be deleted like I have suspected, here is a 0.11 Beta version to test.
 

Attachments

  • Menu 0.11B.au3.zip
    5.6 KB · Views: 8
Last edited by shadow256,

EddCase

Well-Known Member
OP
Newcomer
Joined
Nov 21, 2003
Messages
79
Trophies
0
Age
41
Website
Visit site
XP
808
Country
I was hoping to work on this over the last week whilst I was away on Holiday with my wife.. I spent far too much time relaxing and no time looking at the code. I plan to release a version which allow you to skip the image conversion. I probably won't get a chance to look at it until Monday however
 

Lorraine14

New Member
Newbie
Joined
Sep 28, 2021
Messages
3
Trophies
0
Age
26
XP
11
Country
Argentina
I think that a file is not backuped or restored correctly in some specific case, one time I have seen that an important file was deleted but it was during my developpement tests so I haven't paid attention to this, if I find some time I will investigate.

Edit: I think the problem was that the logo image file could be deleted like I have suspected, here is a 0.11 Beta version to test.
I replaced the file you uploaded with the corresponding one and I just created 6 more .nro files and 3 of them didn't work.

I have noticed that in my megadrive and snes games the Switch logo does not appear in the lower corner when opening them, however in the gba ones it is present.

Greetings!

Edit: nevermind i did it wrong 😅
 
Last edited by Lorraine14,

shadow256

Well-Known Member
Member
Joined
Sep 30, 2017
Messages
123
Trophies
0
Age
35
XP
438
Country
France
I replaced the file you uploaded with the corresponding one and I just created 6 more .nro files and 3 of them didn't work.

I have noticed that in my megadrive and snes games the Switch logo does not appear in the lower corner when opening them, however in the gba ones it is present.

Greetings!
It's note juste a file replacement, you should compile the script or launch it via Autoit.
 

bibliomon

Member
Newcomer
Joined
May 20, 2020
Messages
6
Trophies
0
XP
83
Country
Malaysia
Just wanted to share some icons for the forwarders here.

1633319288436.png
 

Attachments

  • Icon.rar
    146.7 KB · Views: 3
Last edited by bibliomon,
  • Like
Reactions: MainHaze and MazuNX

MazuNX

Member
Newcomer
Joined
Oct 19, 2011
Messages
7
Trophies
0
XP
32
Country
United States
Anyone know how to fix NXThemes Installer? I know that forwarders stopped working for the app, but if there's a work-around I would be interested. The forwarder opens the app, but this text is displayed, and the app isn't usable.
2021100218174100-B01DC45AE97AC6F49278B06CA75F27F6.jpg
2021100218183100-B01DC45AE97AC6F49278B06CA75F27F6.jpg
 
General chit-chat
Help Users
  • El_Doot @ El_Doot:
    how did you go 3 years with cheeto on your mouse without realizing tho
    Gift
  • Julie_Pilgrim @ Julie_Pilgrim:
    do you look under the buttons of your mouse
    Gift
  • El_Doot @ El_Doot:
    why do your friends look under the buttons of your mouse
    Gift
  • Julie_Pilgrim @ Julie_Pilgrim:
    they dont it's just that they saw the outside of my mouse and said it was disgusting
    Gift
  • El_Doot @ El_Doot:
    oh wait I understand my braincells have increased
    Gift
  • El_Doot @ El_Doot:
    by 1
    Gift
  • Julie_Pilgrim @ Julie_Pilgrim:
    funnily enough when i was telling my openly femboy furry bf and my friend(we talk about femboys sometimes) they said "nope we don't wanna hear that that's disgusting"
    Gift
  • Julie_Pilgrim @ Julie_Pilgrim:
    why is cheeto dust of all things
    the subject that crosses the line
    Gift
  • RichardTheKing @ RichardTheKing:
    Wait, Switch Online now has Super Mario 64, right?
    Gift
  • Julie_Pilgrim @ Julie_Pilgrim:
    i really hate to say this but
    Gift
  • Julie_Pilgrim @ Julie_Pilgrim:
    i dont think it does
    Gift
  • RichardTheKing @ RichardTheKing:
    Huh, makes sense; they did sell that through the 3D All-Stars collection.
    Gift
  • RichardTheKing @ RichardTheKing:
    Which, last I heard was removed from the eShop...so they might as well offer it again, I guess...
    Gift
  • RichardTheKing @ RichardTheKing:
    Will they use the same Shindou-translated ROM, or the original English ROM?
    Gift
  • Julie_Pilgrim @ Julie_Pilgrim:
    googling it, it seems that mario 64 is on the service
    Gift
  • Julie_Pilgrim @ Julie_Pilgrim:
    in japan they use the shindou version apparently but in the states and elsewhere they use the original rom
    Gift
  • Julie_Pilgrim @ Julie_Pilgrim:
    oh boy oh boy oh boy i sure do love living in japan and being a mario fan, i just got the new expansion pack, i cant wait to do some bljs!
    +1
    Gift
  • RichardTheKing @ RichardTheKing:
    From what I've heard about the Expansion Pack, the emulator used has some noticeable input delay and/or lag...would BLJs even be possible?
    Gift
  • RichardTheKing @ RichardTheKing:
    Apparently Nintendo adapted the 3D All-Stars emulator, instead of their old Virtual Console emulator - or, if nothing else, copying what fans have done.
    Gift
  • Julie_Pilgrim @ Julie_Pilgrim:
    from what i can seem to gather there's some issues but nothing dramatic enough to severely impact what you're playing
    Gift
  • Julie_Pilgrim @ Julie_Pilgrim:
    honestly the whole expansion pack confuses me since i thought the nes/snes games were just a neat little bonus
    Gift
  • El_Doot @ El_Doot:
    wait julie your bf is a femboy holy shit im jealous
    +1
    Gift
  • AkiraKurusu @ AkiraKurusu:
    So many planes flying overhead, and they sound close...
    Gift
  • DJPlace @ DJPlace:
    do you need friends to play the games online for the switch exapsion pack i know snes and nes do.
    Gift
  • Julie_Pilgrim @ Julie_Pilgrim:
    @El_Doot well hey hot people do get more benefits in life
    Gift
    Julie_Pilgrim @ Julie_Pilgrim: @El_Doot well hey hot people do get more benefits in life