Japanese - 日本語 - Language Learning

Google and Facebook kanji font screw-ups.

Issac

Iᔕᔕᗩᑕ
OP
Supervisor
Joined
Apr 10, 2004
Messages
6,911
Trophies
1
Location
Sweden
XP
6,307
Country
Sweden
When using Google's mobile keyboard input for Japanese and you write nabe or ka they'll display with the font of Simplified Chinese (if I understand it correctly). That's pretty annoying.
When you look at Wiktionary, you'll see many different variations, these are all the same character if you copy and paste them, but they display differently:
1633444852511.png

You'll notice the Korean one has two dots, while Chinese and Japanese has one. But look at the top right, and you'll see the Japanese has the little square to the right side, while the Chinese has it on the left side.

So, Writing in Japanese with the Google Keyboard, it will suggest the Chinese version (with the square to the left), but will in google results show it on the right when it has been entered.
And in the Facebook messenger app it will show the Chinese version, but show the Japanese version on desktop.

I've even encountered that it want to write some kanji like the Korean one in the image, with two dots instead of one, due to font differences.

Have anyone encountered similar things?
 
  • Like
Reactions: velvetmxo

Minox

Thanks for the fish
Former Staff
Joined
Aug 27, 2007
Messages
6,879
Trophies
1
XP
5,530
Country
Japan
I'm regularly using the Google keyboard for my phone and have not had this issue. I do remember it being an issue in Windows in the past, but this is not something I remember seeing recently.

I believe this issue might appear if you have more than one language installed that uses kanji though.
 

Issac

Iᔕᔕᗩᑕ
OP
Supervisor
Joined
Apr 10, 2004
Messages
6,911
Trophies
1
Location
Sweden
XP
6,307
Country
Sweden
I'm regularly using the Google keyboard for my phone and have not had this issue. I do remember it being an issue in Windows in the past, but this is not something I remember seeing recently.

I believe this issue might appear if you have more than one language installed that uses kanji though.
I only have Japanese (Swedish, and English) 🤔
Screenshot_20211006_124843.png
 

Issac

Iᔕᔕᗩᑕ
OP
Supervisor
Joined
Apr 10, 2004
Messages
6,911
Trophies
1
Location
Sweden
XP
6,307
Country
Sweden
Now my Instagram is in Japanese though 😆 Even though Swedish is the main language on my phone. Maybe it'll change when I reboot.
 

Issac

Iᔕᔕᗩᑕ
OP
Supervisor
Joined
Apr 10, 2004
Messages
6,911
Trophies
1
Location
Sweden
XP
6,307
Country
Sweden
How do you do that if you don't mind? is this for the keyboard or actual OS?
What phone do you have?
On mine it's in settings -> system -> language and input (this is where you have keyboards and stuff) -> language and area (or location, mine is in swedish) here you'll be able to add system languages
 
  • Like
Reactions: Minox

Issac

Iᔕᔕᗩᑕ
OP
Supervisor
Joined
Apr 10, 2004
Messages
6,911
Trophies
1
Location
Sweden
XP
6,307
Country
Sweden
I've got an update here, with something I noticed and later solved.

I always had Swedish as my first (and only) system language.
When I added Japanese as a second system language, and rebooting and all that, plenty of my apps were in Japanese. I didn't really care about it all that much, but it was a little bit annoying.

Eventually I got an idea, which turned out to be the case:

When I only had Swedish, I had Swedish apps. And the apps that didn't support Swedish defaulted to English.
Now that I had Japanese as a second language, those that didn't support Swedish went to my second choice, which was Japanese. And that's why those apps were in Japanese. So adding English as a second language and Japanese as the third language solved that issue :P
 

Minox

Thanks for the fish
Former Staff
Joined
Aug 27, 2007
Messages
6,879
Trophies
1
XP
5,530
Country
Japan
I've got an update here, with something I noticed and later solved.

I always had Swedish as my first (and only) system language.
When I added Japanese as a second system language, and rebooting and all that, plenty of my apps were in Japanese. I didn't really care about it all that much, but it was a little bit annoying.

Eventually I got an idea, which turned out to be the case:

When I only had Swedish, I had Swedish apps. And the apps that didn't support Swedish defaulted to English.
Now that I had Japanese as a second language, those that didn't support Swedish went to my second choice, which was Japanese. And that's why those apps were in Japanese. So adding English as a second language and Japanese as the third language solved that issue :P
Oh, that would indeed explain the difference you saw. I've always had English set as my main language with Japanese set as the second one. Swedish I've kept to only being an input method seeing as English is the language I prefer to use for most applications.
 

Latest photos

Group statistics

Members:
27
Threads:
7
Messages:
41
Photos:
0